Question about Kenmore Vacuums

2 Answers

POWERMATE HEAD DOESNT SEEM TO HAVE GOOD SUCTION AND IS LOUD

Posted by on

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 394 Answers

Sounds like a wad of stuff is blocking the suction. If it is blocked the motor will sound loud because the motor needs ample air going in
to get a good suction going. The motor will "starve" for air if there is any obstruction along the way. Please check all places where you can tell the dirt will go for blockage. Good Luck.

Posted on Feb 03, 2010

Ad
  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 16 Answers

Suction wise have you checked the internal pipes on your vacum as for the load noise if it is quite a load noise a humming noise it is ure motor so not worth fixing motors r pricey for a vacum

Posted on Feb 03, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I've bought a dyson dc07 upright vacuum and need to know how to get suction through the hose as opposed to the main machine.


Hi there,

When the cleaner is standing in the upright position, it's engineered to divert suction automatically from the cleaner head to the hose. The correct way to use the hose, wand and dusting tools is shown in the user guide:

http://media.dyson.com/downloads/us/floorcare/manuals/dc07_opmanual_usa.pdf

If there doesn't seem to be any suction coming through the hose when the cleaner is standing upright, you may need to check the machine for blockages. The easiest way to do this is to follow the steps shown in our online support guide:

http://www.dyson.com/support/help.asp?article=4&product=DC07-SY-HEPA_US

It's also a good idea to give the filter a wash, as demonstrated in the video below. Under normal use, this should be done at least once every 3-6 months. Use cold water without any detergents, and always make sure the filter is totally dry before replacing it - this may take up to 24 hours.

By clearing any obstructions and washing the filter, you should be able to resolve your issue without further assistance. However, if you've tried this and are still concerned, it's probably best if you get in touch with us directly. You can call us free on 08002980298 (UK), or 1866MYDYSON (US). One of our experts will be happy to run through some troubleshooting over the phone with you recommend the best course of action.

Kind regards,

Jack
Dyson Online Customer Support

Aug 18, 2011 | Dyson DC07 Bagless Upright Cyclonic Vacuum

1 Answer

I by accident sucked up the corner of a sheet into the powermate of my vacuum. I turned the vacuum off and pulled out the sheet but now the powermate is no longer working (suction works fine) Is this...


These power heads have a kill switch on them. Not exactly clearly labeled.

the kill switch reset button should be on the right side of the unit as you look down like you are using it. you may want to try pushing it with the power to the power brush on. Upon resetting the button there, the power
head should start no problem.

Good luck with that.
Mark

Nov 12, 2010 | Kenmore 25512/ 25513 Progressive Canister...

1 Answer

Kenmore Powermate power head not working


I've got the same problem. Try checking out the electrical connection where the hose attaches to the canister. The hot male terminal is corroded and the female socket is burned out. Its an unfortunate design flaw that every time you open the vacuum to replace the bag the electrical connection disconnects and reconnects. Not sure if I can find replacement parts for a 10 year old vacuum or if a home-made re-wiring job is in order. Will find out tomorrow.

May 30, 2010 | Kenmore 23612 Progressive PowerMate Bagged...

1 Answer

Low suction


Check the tube that leads down to the brush head for clogging as well as any motor or HEPA filters. If that still shows nothing, take the cover off the brush head (like you're changing the belt) and look for obstructions in there. Usually, if you have low suction on the accessory hose, the problem is with a motor filter, HEPA filter, or a clog where the hose goes into the unit. If you have good suction on the accessory hose but none on the floor, it's usually in the brush head (clog or broken belt) Good luck

Feb 28, 2010 | Dirt Devil Vision Turbo W/Bonus Upright...

1 Answer

No suction


Check the tube that leads down to the brush head for clogging as well as any motor or HEPA filters. If that still shows nothing, take the cover off the brush head (like you're changing the belt) and look for obstructions in there. Usually, if you have low suction on the accessory hose, the problem is with a motor filter, HEPA filter, or a clog where the hose goes into the unit. If you have good suction on the accessory hose but none on the floor, it's usually in the brush head (clog or broken belt) Good luck

Feb 28, 2010 | Euro-Pro EP602 Bagless Stick Cyclonic...

1 Answer

Filters all seem clean and clear, suction is fine,but loud noise


Sounds to me it could be tha fan impellor.
This is vac's etc... email us if you need to.
vacs.etc@live.com

Nov 04, 2009 | Dyson DC14 Animal Bagless Upright Cyclonic...

1 Answer

Vacuum doesn't ****


Assuming the unit (motor) runs ok and since it used, you may need to disassemble it and check the suction right at the motor. Sometimes there is a filter screen in front of it that can plug. The motor impeller could be partially obstructed or dirty, reducing the vacuum force. The bag should be the correct one for the unit or suction can be lost if it doesn't fit correctly.

Mar 28, 2009 | Kenmore 23612 Progressive PowerMate Bagged...

1 Answer

Motor on the powermate keeps cutting in and out.


If your talking the motor on the beater bar, then chances are either when the beater bar was attached to the hose near where you hold it, it did not lock, and the connection is intermittent, or the cord has an internal break.

Jan 22, 2009 | Kenmore 22313 Bagged Canister Vacuum

1 Answer

Wiring schmatic for kenmore canistar vacuum


Generally, there are two wires inside the unit which connect to the wiring going down the suction hose.  Since the unit is a/c...it doesn't matter which of them goes to which terminal.  The wires are switched in some cases.  Look for the open terminal.

Dec 19, 2008 | Kenmore 23612 Progressive PowerMate Bagged...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

114 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenmore Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18394 Answers

kakima

Level 3 Expert

102366 Answers

yadayada
yadayada

Level 3 Expert

76109 Answers

Are you a Kenmore Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...