Question about Kenwood KAC-9102D Car Audio Amplifier

1 Answer

Blows the 30 amp fuses

It started making loud "bump" noises when the deck was not on and then all of a sudden, one day it just stopped working. I checked the 2- 30 A fuses and they were fine. There is power going to the amp, I checked with a meter. When I go to change the fuses, they blow upon insertion. If I shut off the system and change the fuses, they don't blow but nothing works after I turn it back on. Thanks for any help! Michael

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 1,068 Answers

Yes you have a internal fault of the amp. the circuit that puts it into safe mode is bad and that is a very small chip on the board know as a op amp. needs to be repaired.

Posted on Feb 04, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Technician can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Technician (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

No air blowing on any setting out any vent. rear works fine.


You need to replace the blower motor, and maybe the ballast resistor also.

Jul 12, 2016 | 2001 Chevrolet Suburban

1 Answer

Why is one 30 AMP fuse pair blowing on Carrier Tech 2000 SS AC Unit?


Pull off one of the wires to the fan. If it still blows a fuse the compressor is shorted. If not replace the fan motor.

Jul 03, 2014 | Carrier Heating & Cooling

1 Answer

I have a newer craftsman riding mower, its a 24 horse, 42 inch cut. When I was mowing today, the deck cut off then the mower died. Upon inspection, I discovered a blown fuse (20 amp), I replaced it and it...


By uping the fuse rating you are definitely putting your equipment at risk for damage. The 20 amp fuse is doing it's job. what you need to do is find the reason it's blowing. Stop running you newer machine with the 30 amp fuse and look for the high current source. Hopefully you know what the fuse is protecting and start looking there. A fuse blows due to a high current condition. If it's a motor it could be a mechanical binding of some sort. If it's wiring, it could be caused by a loose connection or exposed wire shorting itself to ground. Look for signs of obvious damage first but if you can't figure out what it is you should have it checked out by a profesional before you cause more, damage and expense.

Jul 10, 2012 | Craftsman 17.5 hp 42 in. Deck Lawn Tractor...

1 Answer

Loud grinding noise from under passanger seat.. comes and goes... hit a bump and it stops. hit another it starts. greased the u joints and quit for 3 days.. but back again. getting more freaqueant and...


If greasing the u-joints eliminated the noise for 3 days, that would be the first place to suspect. The grease will briefly remove most of the slack in the joint until it is slung out and the needle bearings will once again run dry & wobble. This noise can be anything from a grind to a loud squeal. I hope this helps.

Sep 27, 2011 | Cars & Trucks

1 Answer

Craftsman garden tractor Mod # 917.257740 blows main fuse.


Try checking the battery - make sure it is not under rated - over rated and be sure the starter it's self isn't drawing too much amperage.
the battery may need replacing and for a temp fix - put in a larger fuse - say 50 amp.
Thanks for choosing FIX Ya

Gary @ Fix Ya

Jul 06, 2010 | Craftsman 20 hp 42 in. Deck Lawn Tractor -...

1 Answer

Starts and runs good but after an hour of cutting when you turn off.. then you want to cut again it will start just fine but when you engage the blades the fuse blows it has a 20 amp fuse is this the right...


I normally see 30 amp fuses to the deck...but it depends on which mower you have. If you place a larger fuse and it does take a 20 amp..you may burn something up. I would check the blades, spindle towers and clean all the stuff on top and inside the deck to look for something catching on the blades. www.nnyparts.com

May 27, 2010 | Garden

1 Answer

I have an over the range microwave, and it suddenly stopped heating. Also, makes a loud noise when you turn it on.


It sounds like the High Voltage diode (1) is shorted but it could be the magnetron (2) or the HV capacitor (3). - 1 side shorted to ground. A dead short will blow the fuse and kill the unit.

Sep 11, 2009 | Microwave Ovens

1 Answer

Blower motor or resistor?


If it was the motor that went out then it would not blow at all. The resistor is the culprit that starts killing off speeds. It should be about $25 to $30 at an aftermarket store like autozone or advanced auto parts.

Jan 09, 2009 | 2000 Chevrolet Malibu

1 Answer

Cold weather blown fuse


You might want to try better quality fuses, or allow the amp to warm up a bit before you start bumping down the street make old ladies angry.

Jun 01, 2007 | Rockford Fosgate Punch 700S Car Audio...

Not finding what you are looking for?
Kenwood KAC-9102D Car Audio Amplifier Logo

Related Topics:

100 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4886 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

yadayada
yadayada

Level 3 Expert

77201 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...