Question about Hifonics Brutus BX 1205D Car Audio Amplifier

1 Answer

Amp not working

"hifonics" on the top of amp lights up but the green power light will not illuminate and amp is not working. peridocally will turn on for a few seconds. remote is hooked up, power wire and ground appear to be secure. not sure what the problem is.

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 25 Answers

Sounds like the amp is going into protection mode. maybe a sub is shorted (blown). Or, the only other possibility is the mosfet transistors on the inside of the amp are blown.

Posted on Feb 01, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a hifonics brutus 1606d 1600 watt amp it gets power green light is on lit up across the top but i cant get any sound


Your amplifier may have experienced circuit failure other than a dead short that still allows power to be applied

Dec 05, 2016 | Hifonics Car Audio & Video

1 Answer

Internal fuse


Amps getting power that's good it seems as though either you have a cross in your bridge or you fried your amp

Apr 02, 2014 | Hifonics Car Audio & Video

1 Answer

I have a 2000 watt hifonics brutus amp ...it worked fine but 1 day it just stopped working..the power light doest light up but the hifonics led lights are still on...whats the problem?


there is a step up converter inside the amp that likes to come loose from the board. This may be your problem. Otherwise Check all the chips for burns or disconnect

Nov 13, 2009 | Hifonics Brutus BX 2005D Car Audio...

1 Answer

HiFonics txi4008 not working, partially lighting up


Sounds like your amp has some power supply compents shorted out. Maybe some of the power mosfets are shorted and your only getting a little bit of power. That why only the H is lighting and as far as the green light, it don't take much for it to turn on. If it was major it would go into protect mode but it is'nt. I repair amps for a living and I'm the cheapest you'll find. But if you know about electronics and think you can take a crack at it, check it out. Becareful you could do more damage. Let me know if your interested. skinnman33@gmail.com

Jun 06, 2009 | Hifonics Brutus BXi 1206D Car Audio...

2 Answers

Power good no green light no subs


Make sure you got a good ground. do not ground on painted surfaces! If you got power from battery, check the remote wire running to cd player. Hook up remote blue wire with the one for cd player. If you still have a problem and the fuse is good, then the amp is fried

Jan 30, 2009 | Hifonics Brutus BXi 1206D Car Audio...

1 Answer

Problem!


you have a foulty amp i wtake it bk and change it

Dec 27, 2007 | Hifonics Brutus BX 1505D Car Audio...

1 Answer

Okay i have a problem hifonics brutus 1500 mono d class amp


well your amplifier is obviously going into protect mode,(i used to have this amp and it is awesome) anyway i would go through just to be sure and check all the power connections with a test light, remote wire, positive, and ground. and check the fuse to see if it is still good. you can buy a test light at wal-mart and any automotive store. if you stil have a problem then i would check to see if your running below 1 ohm on this amp. that would cause it to go into protect mode. if all this fails i would just go buy a new one.

Oct 07, 2007 | Hifonics Brutus BX 1505D Car Audio...

1 Answer

Hifonics 1605d stopped working


the red light blinking because your amplifaier its dead look for the alimentation cabel end replace the calibration protector

Apr 16, 2007 | Hifonics BX1500D Car Audio Amplifier

Not finding what you are looking for?
Hifonics Brutus BX 1205D Car Audio Amplifier Logo

Related Topics:

316 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hifonics Car Audio & Video Experts

Professor_V
Professor_V

Level 2 Expert

92 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

Radames Pagan
Radames Pagan

Level 3 Expert

196 Answers

Are you a Hifonics Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...