Question about Kenmore 35912 / 35913 Progressive Upright Vacuum

1 Answer

The drum is not turning when I the vacuum is on. I have good suction. What should I do?

Posted by on

  • rj4natarojr Feb 01, 2010

    this model is a direct drive and does not have a belt. I fixed it by downloading the owner's manual from a Sears website. There is a reset button that I pressed and now it is working.

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 324 Answers

By drum I take it you mean the beater bar on the bottom? I would check the belt and probably replace it. remove the screws holding the very bottom of the vacuum on and remove the access plate / cover. you should see the belt or whats left of it.

Posted on Jan 31, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Miele Vacuum Cat and Dog Upright S7260 Loss of Suction


could be a couple things first make sure the hose is clear check real good the other is make sure your bag is good and tight and clean and make sure you have no holes or tears in the hose

Mar 07, 2014 | Miele Vacuums

1 Answer

I put a new bag in my electrolux 2100 and it seems like it has half of the suction. What seems to be the problem. Does it need a new upper motor gasket?


Take the hose off, turn the vacuum on and see if there is good suction at the vacuum where you attach the hose. If there is good suction at the vacuum there is either a clog in the hose or if it is an old hose the liner inside the hose may be collapsing when you turn the vacuum on. If that is the case you will need to purchase a new hose. I have hoses for sale on my website and on ebay.

Mar 06, 2014 | Vacuums

1 Answer

Why does my filter collect so much dog hair and decreases the suction of the machine. I clean and change (alternate) filters everytime I vacumn, that isn't normal, is it? It seems like I have a seal or...


You obviously have a pet and it's good to see your machine is doing it's job. The only reason you could lose suction while collecting pet hair is due to the pet hair being a solid mass and air not been able to flow through the filters.( must be a lot of hair). Suction loss is only when the particles passing through your machine are dense therefore it will reduce suction and airflow . Very common on vacuum cleaners. Do not worry too much . Also check to see if you have Amy cracks in the seal between the drum and the vacuum cleaner itself

Jul 15, 2011 | Dyson Vacuums

1 Answer

No suction when vacuuming, but suction is good when using hose


check for blockage from where the hose sets in its
holder to the roller brush. Also see if the brush is
turning, the belt maybe broken.

Tom

Oct 22, 2009 | Eureka WhirlWind Litespeed 5844 Upright...

1 Answer

Vaccumn repair ...lostlosing suction, belt still turning roller bar, hose clear


To generate strong suction, the motor has to turn at a good speed.If its a bag vacuum change bag with new one when a great deal of debris builds up in the vacuum bag, the air faces greater resistance on its way out.

Sep 12, 2009 | Vacuums

2 Answers

No suction on my Electrolux central vacuum in all outlets even though motor is running and there is no clog in the hose.


go to the main unit,you have a blockage where the suction originates.can you disconnect the main suction line to the unit?do that and turn it on.if you have suction then then the main suction tube is blocked.a towel or rag of some sort got sucted in and got caught before it made it to the dirt tank please leave feedback

May 05, 2009 | Electrolux Central Vacuum

1 Answer

Dirt Devil Swivel Glide Platinum vacuum suction problem


Is the suction tubing in the head assembly clogged, is the belt broke? If the if the belt looks good the brush may be turned off and you may need to turn the brush switch on.

May 03, 2009 | Dirt Devil SwivelGlide Bagged Upright...

1 Answer

Nutone 353 central vacuum....all of a sudden, poor suction at all house outlets.. Checked hoses and pipes for obstruction...none found


I think this unit has a utility valve on the front. If so, do you have good suction at this valve? If not, disconnect the inlet piping and check the suction directly from the inlet. Make sure the utility valve is closed while checking the suction on the inlet. If you have good suction, you have an open pipe or valve somewhere in the house. If you have any vacpans, check these first. Next, turn the unit on and walk through the house and listen for air whistling. If you do not have good suction from the inlet at the unit with the utility valve closed, replace your bag and look for a secondary filter that may be plugged. Good Luck!

Nov 26, 2008 | Broan-NuTone CV353 Central Vacuum

1 Answer

CENTRAL VACUUM SYSTEM


Disconnect the inlet piping from the unit and check the suction there. Be sure that the utility inlet on the unit is closed. If you have good suction, you have an open/broken pipe somewhere, or possible an inlet valve or vacpan that is not sealing when closed. The easiest way to find it would be to install your tubing back into the inlet of the unit, turn the unit on, and walk around the house listening for air leaks. Good Luck!!

Jun 29, 2008 | Broan-NuTone CV353 Central Vacuum

Not finding what you are looking for?
Kenmore 35912 / 35913 Progressive Upright Vacuum Logo

Related Topics:

119 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenmore Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18394 Answers

kakima

Level 3 Expert

102366 Answers

yadayada
yadayada

Level 3 Expert

76132 Answers

Are you a Kenmore Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...