Question about Seagate FreeAgent Pro - 500GB, 7200 RPM, USB 2.0, eSATA, External 500 GB Hard Drive

6 Answers

Free agent pro not being recognized

The free agent pro 500 gig is not being recognized and when it is it either comes up blank and is just drive f or it comes all the way up and i get the delayed write message. what should I do should i just go ahead and try to take it apart and get the data of with another case or should is there another option I can do.

Posted by on

  • 10 more comments 
  • Lalaura Feb 18, 2008

    The light of my freeagent pro 500 gb started flashing, and the hd wasn't recognised by the computer anymore. It had worked fine for a pair of months
    (enought to put there a lot of datas...)

  • Dale33 Feb 24, 2008

    I connected the USB lead and the power lead when I was in another identiy. The drive lit up but then I realised what was happening probably was transfer of data to the drive from this other identiy. But I didn't want this so I switched back to my own identiy. But no light on the drive and it is not recognized in the Computer list. Only mu C: drive is shown.

  • Anonymous Apr 14, 2008

    When connescting to this windows vista,it rqsts for the driver installation.

  • Anonymous Jun 04, 2008

    Seems to conflict with Firefox while trying to write backups via Memeo software. Then, drive is no longer recognised - despite Windows saying the drive is OK

  • Anonymous Jun 16, 2008

    Just got a new Seagate FreeAgent Pro - 500GB, USB 2.0, eSATA External Hard Drive. When I tried to install it on Windows XP Home the light came on but nothing else happend.. My husband tried it on his Windows Vista and it when right up like it should. We both have Dell Computers.

  • led123 Jun 17, 2008

    I have exactly the same problem. The hard drive worked for a week or so but now will not allow me to download data onto it or take data off it. It is not always recognised by my computer and often shows a delyed write message. Also, sometimes I am half way through downloading data when it says error and stops!

  • naginalf Jun 21, 2008

    I have the same problem as the others. I tried to get it to work on mylaptop and it didnt work, then I hooked it up to one of the computersat the library and it worked just fine. I tried to hook it up to mylaptop after that and it still doesnt work. My laptop only recognizesthe hard drive in the "device manager" and no place else. Part of myproblem is that the software that I need to install the hard drive ison the hard drive itself.

    any suggestions would be greatly appreciated, please emai me.

  • Bill Jul 23, 2008

    Similar problem but related... PC/laptop cannot detect Seagate FreeAgent
    500GB drive USB after several weeks/months of use. I starts with the drive just
    disappearing aafter a period of it killing performance on my system. Then it is
    not detected after reboot, etc. Early solumtionis to unplug drive and then it
    comes back. But finally it goes south and does not come back.





    I have had this happen to three (3) drives so far.





    One guy at Seagate said if Linux EVER mounted drive, it
    would eventually go corrupt. Now I don't know what Linux has to do with it.


    I have two other USB drives [One Seagate 160GB non-FreeAgent
    drive and one WD MyBook] that have survived 100% thru Windows XP and Linux and
    back. What does that one Seagate person know or was he covering for a badly
    implemented drive. I have NOT booted Linux since told that, but the drive is
    gone again July,2008).





    Anyone have any insight to this problem?





    At least, it is under warranty until 2012, but who wants a
    drive that is not dependable???




  • Anonymous Aug 01, 2008

    I have the same problem. Mine seemed to occur after I plugged it into a multi USB port. It had two connetions and after I plugged it in my PC would not boot. It just froze. After I disconnected it fom the multi USB port my PC worked fine but I could never get it or my other computer to recognize the Seagate drive.

  • Anonymous Nov 09, 2008

    I have the agent to go 160GB but the same problems - it worked at first then I got the delayed write fail messages, now it does not come up at all when plugging it into Windows PCs. Tried all different ports, tried with one or both cables plugged in, 3 PCs, and nothing. The drive itself looks normal - orange bar either solid or flashing, but never pops up in windows. Sometimes when I plug both Power and data cables in it beeps. That's all I can see.

  • Kymm
    Kymm Jan 08, 2009

    Seagate tells me
    its a BIOS problem. My BIOS is and has been up to date, the chipset is
    up to date, and the OS is up to date. No other problems exist except
    when this drive is connected to any USB port with USB 2.0 HS 480 Mbs assured enabling in my BIOS. Have you tried
    connecting to another PC to determine it might be your PC? Occasionally It will ID (rarely), why I do not know. The only error I
    get is the Drive will not ID and then I find my shared folders will not
    map to the drive. I've even reformatted the drive thinking it might be
    the installed software it comes with or the formatting as sold. No Change. They won't even send
    me the installed software. Try unplugging your drive and replugging it in. You will see it does ID and intitialize. However it will not do so on boot. You may have partition limitations due to size and that is due to BIOS. However if you have a recently new PC and Your BIOS does not have this Limitation then you have the problem I have. My experience with Seagate seems to be neglect. My past experiecne with them has been very good. I've owned 11 SCSI, and numerous other IDE's this one is the questionable one. In any case the support I am getting needs improving. I cannot afford to go hopping around tech to tech, mfg to mfg trying to determine their expertise.




  • drumsoccer16 Apr 27, 2009

    I HAVE 3000 PHOTOS ON THIS DRIVE AND IM FLIPPING OUT!!!!

×

6 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

**Take the power lead out of the Seagate FreeAgent Pro , restart your computer and then reinsert that power lead. **

In my case the backup drive then reasserted itself by re-installing some software and was once again visible to my laptop. And I had tried every other other suggestion above first and Seagate technical support were about to ship me a new USB cable and then a new drive.

Posted on May 21, 2008

  • bocajeff Oct 16, 2010

    TOTALLY WORKED! Thank you!! I had the flashing and solid yellow bar, and it wasn't being recognized by 4 different computers. Left USB plugged in, unplugged power cable and replugged power...instantly recognized. Thanks again!

×

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 101 Answers

The problem of the first user (weasel79)is simple...
just do this, hope works...k
Right click on MY COMPUTER and select PROPERTIES from that select the SYSTEM RESTORE tab and tick the TURN OFF SYSTEM RESTORE ON ALL DRIVES tab and click apply and then ok and then restart your pc, well that problem is fixed...

second user..(Dale33)
do 1 thing select properties from My Computer then select Manage.. from the left column select DISK MANAGEMENT and see weather your disk is detected...
if yes then allign it a driver letter ~!! hope that helped...

the 3rd user also do the thing done by second user ok...
if any problems then plz inform me ill there to help !

Posted on Mar 10, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Just don't buy Freeagent Pro. It's looks sleek but mine (I have 2 of them) does not function: always connection problem, my computer won't recognize it. Well, the problem is, sometimes it appears, sometimes not so it's not very dependaple. I had to send one of them back, got another refurbished in return - lost my data though. **** product. I rather have an ugly box what workt properly than a lick box that does not deliver.

Posted on Nov 27, 2009

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Thanks. This solved the problem.

Posted on Jun 02, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I wrote something that might work for issues like this, i repaired my friend's seagate freeagent pro 500GB..
BUT it needs the disk to be recognised first to make changes, i've tested it couple of times. I hope it helps ^_^

here the link to my post: http://twiq.zzl.org/fixing-seagate-freeagent-pro

goodluck!!

Posted on Apr 07, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

This problem can be easily solved by using a freeware disk-management utility such as Cute Partition Manager to create a new partition on the drive and selecting the drives full capacity as the partition size,worked for me! hope this helps

Posted on Apr 06, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My seagate 500 gig free agent desk external drive has suddenly stopped working. It was working fine 2 days ago and then yesterday it apparently wasn't connected so I reconnected it and then it seemed to be...


Do a FULL POWER DOWN Reboot. and try a different USB outlet in the PC... same Laptop to see if it is in your PC that is causing the problem.
Note: Most of those Drives do stop unless they are connected to the PC... energy savings.
If that didnt work... you could have a failed drive. Seagate should help you do some diag if it is in warranty... typically 3 years.

Dec 31, 2009 | Seagate FreeAgent Pro - 500GB, 7200 RPM,...

2 Answers

Seagate free agent pro 500 gig external hard drive NOT RECOGNIZED


You better check with the Seagate people. This seems to be a problem with the casing. And since you're under warranty, you can get a replacement.

Aug 28, 2009 | Seagate FreeAgent Pro - 500GB, 7200 RPM,...

1 Answer

Macbook wont recognize 500 gig My Book


Hi,

Having tried 2 cables you should now try it on a different computer. Chances are there is a failure inside the enclosure but you will know for sure if it also fails to recognize on another PC.

Once you're tried that, if it does work on the other computer the problem is corruption in your Mac, archive and re-install the Mac, if it doesn't work on the other computer then take it to your local PC shop or parts vendor and have them move the drive into a different enclosure for testing.

If it works in the new enclosure, buy it and your on your way. If it fails to work even in the new enclosure then you will need the help of a pro to get at the files, if that is the case, reply back with your Country, State and city and I will direct you to an appropriate pro.


Hope this helps FixYa,


Chris

Aug 26, 2009 | Western Digital 500GB My Book World...

1 Answer

My free agent 500gb external not recognized


Try changing the data cable. it should work, I had same problem and after changing cable it worked.

Aug 04, 2009 | Seagate FreeAgent Pro - 500GB, 7200 RPM,...

1 Answer

I have a 500 gig Seagate Free Agent external hard drive that I am having problems with. The problem is that the amber light on the hard drive comes on solid (bright) at initial start up, but then goes dim...


windows - delayed write failed
Windows was unable to save all the data for the file I:\$mft.
The data has been lost. This errors may be caused by failure of
your computer hardware or network connection. Plese try to save elseware.

Aug 03, 2009 | Seagate FreeAgent (ST305004FDA1E1-RK) 500...

1 Answer

Seagate Free Agent Pro Out Of Space


format backup drive and repartition to a single partition. do not backup programs unless you have clone disk.

Jun 20, 2009 | Seagate FreeAgent Pro - 500GB, 7200 RPM,...

1 Answer

Computer not reading free agent pro


I suspect an IRQ conflict in this case. where one day things are workig fine and the next day they are not because the IRQ conflict has made it's self known.

if no IRQ conflict is present , I would suspect a dead drive , time to replace the ole girl. these things happen , touchy equipment , buggy driver sets , you name it , things will however improve.


and remember if it's not hebrew , it's a lie :-> shalom

Sep 08, 2008 | Seagate FreeAgent Pro - 500GB, 7200 RPM,...

Not finding what you are looking for?
Seagate FreeAgent Pro - 500GB, 7200 RPM, USB 2.0, eSATA, External 500 GB Hard Drive Logo

2,331 people viewed this question

Ask a Question

Usually answered in minutes!

Top Seagate Hard Drives Experts

Brian Sullivan
Brian Sullivan

Level 3 Expert

27725 Answers

joecoolvette
joecoolvette

Level 3 Expert

5660 Answers

Michael Thomas
Michael Thomas

Level 3 Expert

3051 Answers

Are you a Seagate Hard Drive Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...