Question about Hitachi 50V500 50 in. HD-Ready LCD Television

2 Answers

No video No Audio, power light on

Hitachi 50v500a
LC3X POWER P.W.B. - JK08574-A - LC37E/15

The power light comes on as if there is no problem but thats it, nothing else, no fan, no audio, no bulb, nothing but the power light. The tv sat for about a month and before throwing it away I thought id take it apart and see what I could find. Looked at both fuses and they were both good, I didn't do much but poke around and I put it back together and it worked! Then the next day it did the same thing and I cant get it back on now.

SO...after a lot of research I THINK its the power board:

There are 5 Green LED's and 1 Red LED on this board. When I plug in the TV:
D913 lights up (which is what its supposed to do I assume)

When I push the power button:
D913 remains lit
D911 turns on (this is the red one it has a slight pulse to it but is still bright)
D933 flashes dimly (only for like 2 seconds and u can hear a little chirp sound and then it goes off (sometimes it never lights at all depending on how long i let the tv sit for before trying to turn it on again))
D930 is off (this one used to flash and chirp as well but now it never does)
D932 is off (never comes on)
D928 is off (never comes on)

If the power board is even the problem the cost of a new one on this tv out weighs the price of replacing the tv. I don't just want to throw it away. I'd like to try and have the board repaired or repair it myself if I could get some guidance. Any help on my problem would be greatly appreciated. Thanks.

Posted by on

  • 2 more comments 
  • Aqualunn Feb 18, 2008

    Amazing....I just today ran into the exact same problem with my 50v500a. I haven't phoned for service, as it's not under any warranties, but the more I read the more I get concerned. With other issues I've read about the TV I am not certain I want to invest any significant money into repair!!



    Any solutions would be appreciated...

  • 05roadking Feb 24, 2008

    I have the same problem if the TV sits for an hour or two it will work fine till you turn it off. I also pulled mine apart yesterday and got the same beep noise and the red bulb D911 lit dim and the went out as the noise stoped.Also when the TV is cold if I turn it on I get a picture and sound turn it right off and wait for the blue power light to stop blinking then turn it back on nothing so it can't be its to hot. I let it sit a while and it works fine picture sound and you can here the fan turn it off and have to wait.

  • solusdeus Feb 28, 2008

    Aqua, you pretty much went through the scenerio exactly how I pictured it playing out. I was almost positive it was the power board and I knew the cost of a new one out weighed the remaining value of the television. I'll have to buy a multi-meter and do some research on how to test capacitors, resistors, etc. From doing more research, I found that the most common problem with similiar power boards is a faulty capacitor or cold joint. At this point I'm leaning towards a faulty capicitor on my board so I'll begin there. When / If I find the solution I'll be sure to post it here in hopes it will help someone in the future.

  • Anonymous Nov 26, 2008

    Have a 4-year old 50V500 with the same problem. If I turn off the TV or my kids turn off the TV accidently, cannot turn the TV on again for about 30 - 45 minutes. If I do, a weird chirping sound is emitted and the blue power button lights with no picture or sound. Have to turn off and wait for previously mentioned amount of time to get TV to turn on.

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

My repair guy narrowed down the same problem you guys are having to the regulator chip which is mounted on a heat sink
on the power board behind the right front speaker.It can only
be accesed from the back of the tv.

Posted on Dec 02, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I asked Hitachi support if they could provide some direction, they opened a service file, told me they could not diagnose internal problems and suggested I go to their website to look for an authorized repair center.

I then paid for a TV serviceman to look at the TV and he has told me that it's a powe board problem... $750.00 to fix!!!

Solution: Bought a Sony with a 5 year extended warranty for twice the repair price. That will be the last Hitachi product that sees my household.

Posted on Feb 25, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Ok well i have a Hitachi 50v500a i have had the light engine replaced about a year ago with no issues, but now when i power up the tv it starts fine but when the picture comes on there are blurry...


Sir try to check if there is a loosed connection in the light engine or cold solder in the electronic circuit board, this loosed connection cause your unit to malfunction, or the light engine of your unit is getting faulty. Good day sir and best regards.

Sep 14, 2011 | Hitachi 50V500 50 in. HD-Ready LCD...

1 Answer

My Hitachi 50V500A tv just quit working while I was watching it.


Symptom: Dead, F901 is open.
Cause: Shorted D902 on the power supply board.

The full service manual for this model, (Hitcahi 50v500) can be downloaded at http://fletchermanuals.com for only $10.00.

Jan 07, 2010 | Hitachi 50V500 50 in. HD-Ready LCD...

1 Answer

Hitachi 50v500a lamp light


"Yes" Or the lamp door on the set is open!, "Check lamp" most of the time the lamp will pop & fail... you will see this by looking at lamp

Jun 30, 2008 | Hitachi 50V500 50 in. HD-Ready LCD...

3 Answers

Pink splotches on Hitachi 50V500A


We had the same problem and just got our light engine replaced last week. Yes, Hitachi will ship the part and they will pay for the part but they will ask you to pay for the install (unless like Dev23 said, it's still under warranty). Hitachi shipped the part to the certified Hitachi dealer that they recommended. Cost to us was around $400. Worth it to us being that the TV cost $3600 when we bought it 3+ years ago and up until we had the light engine problem, the TV has been great. Since the light engine was replaced, TV looks brand new. You will read some post about this problem were people have had up to 3 light engines replaced. Back when Hitachi was made aware of this problem (about a year ago) they were sending out refurbished light engines and not new ones...obvious cost savings and cheap way out for Hitachi. The tech that came out and installed ours said that now Hitachi only sends out brand new light engines.

You should really only deal with Hitachis Customer Relations Department and not regular customer service. When you first call, they will act like they have no idea what you're talking about. After you have someone come out to look and tell you that YES, it's a light engine defect, they will ship the part to the dealer and then the tech will come out and rinstall it. The customer relations department # is 800-654-70103.

If you're willing to pay the install, they will cover the part. The part we were told cost $1500. Regardless of a warranty or not, this is a DEFECTIVE PART and I think Hitachi should pay for the entire tab none the less, we just wanted the TV fixed without a hassle! Good Luck:)

Nov 08, 2007 | Hitachi 50V500 50 in. HD-Ready LCD...

Not finding what you are looking for?
Hitachi 50V500 50 in. HD-Ready LCD Television Logo

354 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hitachi Flat Panel Televisions Experts

The Knight
The Knight

Level 3 Expert

68368 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Paul

Level 2 Expert

223 Answers

Are you a Hitachi Flat Panel Television Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...