Question about Hoover U5491-900 Bagged Upright Vacuum

1 Answer

The brush is spinning (and has been cleaned), there is a new bag, but we get no suction.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 701 Answers

The reason the brush is not spinning is because the belt is stretched or broken. You can get a replacement belt here:

Hoover U5491-900 Belt

Posted on Jan 31, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Electrolux Ultraactive losing suction and turbo head brush won't spin. Canister is empty, no blockage in hose or nozzle of turbo head, filters cleaned, but Hepa not replaced recently. Could that cause it...


Hi, it's Jeremy from Crucial Vacuum.

There are a few potential solutions you should try to fix the suction of your Electrolux vacuum. The first thing you should check is the height of your brush-roll. Your height setting may be too high for the type of floor you are vacuuming. Raise or lower your brush-roll depending on if you are vacuuming on carpet, tile, or wood surfaces.The second thing you should check is the vacuum bag. If it is full your vacuum can lose suction. This is simply remedied by replacing it with a new and clean bag. The third reason for a loss of suction is your hose is clogged. Check the hose for debris or foreign objects that may be obstructing the flow of air in the vacuum. The last potential reason for your vacuum losing suction could be the brush-roll itself. If it is clogged with dirt and hair it may not be spinning and not picking anything up. Check to see the condition of your brush-roll. If it is clogged remove the debris.

You can purchase direct your Electrolux replacement vacuum parts from Crucial Vacuum with free shipping and an exclusive 10% coupon for Fixya.com readers, use code: FIXYA10

http://www.crucialvacuum.com/electrolux.html

I hope this was helpful. If you would like further assistance, please feel free to give us a call at 877.750.9239. We have helpful and friendly customer care representatives on the line ready to assist you.

Jeremy Lerner
Crucial Vacuum Customer Care
http://www.crucialvacuum.com

Aug 05, 2014 | Vacuums

1 Answer

Riccar 8995 no suction


If it's been over a year since you've replaced the belt that is the first place to start. Stretch belts lose elasticity and will still turn the brush roll but when the brush roll is lowered to the carpet it may not turn fast enough to pick up properly. If you have good suction at the end of the hose check to make sure there is not an obstruction in the tube where the hose goes into the bottom of the vacuum to the brush roll. Make sure your filters are replaced at least once per year and the bag is not full or has a lot of fine powder dust in it which can clog the bag.

Jun 13, 2014 | Riccar 8955 Upright Vacuum

1 Answer

Turbo tool used only once or twice, already brush moves so slowly it stops when I try to use. Brush can actually be stopped by hand. Manual says nothing at all about the brush ie. HOW to take apart to see...


It takes a lot of suction to spin the brush. First make sure the suction is good. Make sure the bag and/ or filters are clean. Replace if necessary. Most turbo tools can be opened up to clean. Most have a lever that allows you to open it up to clean hair, dust, etc from the fan and fan shaft and other areas inside the tool. The tools pick up a lot of hair and debris and some will wrap around the moving parts building pup to the point the brush will not spin fast enough. The same thing can happen to the brush roll on your vacuum so be sure to clean it too and replace the belt at least twice per year.

Oct 31, 2013 | Eureka Vacuums

1 Answer

No suction from my kirby sentria


I just took a stiff piece of coax cable, and took the bag off where it attaches to the main unit, and took the head off ( the part with the brush roll in it) AMD cleaned every thing really well, turning the spindle for the fan while " snaking" it and pulled out a baby sock! Ta-Da! Works like New.

Apr 29, 2012 | Kirby Ultimate G Bagged Upright Vacuum

1 Answer

Miele, Flamenco II. 2 probs. 1. the head brush is not turning when I put it on the floor. If I pick it up to look inside...the brush is spinning fast..I put it down on the floor...the head does not...


sounds like the belt is not on correctly on the beater brush or the belt is worned out now for the suction check filters or bags that need to be empty or clean

Feb 16, 2011 | Miele Vacuums

1 Answer

My Kirby Ultimate G does not have enough suction to pick up pet hair. Is there anyway this can be corrected? I felt under the vacuum when it was running, the roller is running, but I felt very little...


An Ultimate G has lots of suction. If you turn on your vacuum and the bag immediately inflates - that is how you can tell if your Kirby is moving air (suction). There is a more modern brush that came out with the Ultimate G Diamond and the Sentria that has stiffer bristles that dig up pet hair better.

Another way to test the suction is to spread some baking soda onto a hard floor and vacuum it up - you can see how much suction your Ultimate G has, or take off the vacuum head and put on a hose and test the suction at the end of the tube.

Ways to increase your Ultimate G cleaning efficiency. Take off the vacuum head and remove the brush roller. Attach your hose attachment and **** vacuum out the head. Put on a new belt, and remove any hair and or string or threads that may be wrapped around the brush roller. Put the roller back on and on the ends of your roller you will see that the ends spin and have numbers on them. If your vacuum brushroll is original - you could have your bristles rather worn and so you can align the #3 on BOTH sides of the brushroller. This would be a good time to consider upgrading to the Sentria Brush.
Remove the bag, and replace with the CLOTH Kirby bag. It has the best filtration and it has the best airflow (which increases what you are referring to as suction). If you want to go the cheap route - at least get the paper Micron Magic with HEPA filtration (but it has slightly less air flow)
Remove the side mini emptor from the vacuum and check to see if there is anything clogged up on either the vacuum or the mini-emptor.
If your engine is running and inflating the bag and you replace the belt, the brush roller and to the cloth dust bag - your vacuum should pretty much run like a brand new Sentria Vacuum. Your vacuum system is outstanding, but may benefit from a little TLC if you have been neglecting it.

Mar 19, 2010 | Kirby Ultimate G Bagged Upright Vacuum

1 Answer

Brush spin,good suction at hose, no suction at


Air passage from back of brush head, through the joint, and up to bag, may be blocked.

Jul 11, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

3 Answers

No suction


you still have a clog in there something is keeping the brushes from spinning. Be sure to remove any hair/string etc twisted around the brushes. Make sure the belt hasn't slipped off the metal pin behind the brushes, this is what creates the rotation. The brushes have a hard plastic molding on each end that fit into the sides of the vacuum. Make sure you have these on the right way or they will strip out and you have to replace the housing and the brushes. Have you cleared any blockages from the feed behind the brushes? Be sure to take the hose and extend it out and run a broom handle or something down it to be sure you do not have something lodged in there. Good luck .. if you need more detail post back. These can be rebuilt if needed, hopefully it is just something lodged further down the suction canal.

Nov 10, 2008 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Brush is not rotating.


Turn the vac over, remove the access plate, covering the brush roll, 2 to 4 screws. Brush roll part number is 2032032if you need it, belt is a Bissell Style 7. While you have the brush roll off, check in dirt inlet to see if it is clogged, also check the hose to see if it is clogged. You won't feel suction at the bag tube, it has to have a bag on it and the lid closed before it will create suction.

Dec 29, 2007 | Bissell 3522 PowerForce Bagged Upright...

6 Answers

Vaccum has no suction


Need a new belt -- you might have suction but you need the brush to spin (hard to help without make or model, upright or canister)

Oct 17, 2007 | Kenmore 25614 / 25615 Progressive Bagged...

Not finding what you are looking for?

Open Questions:

Hoover U5491-900 Bagged Upright Vacuum Logo

Related Topics:

71 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18394 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1466 Answers

Brad Brown

Level 3 Expert

15729 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...