Question about Philips Magnavox 15MF400T 15 in. LCD Television

6 Answers

Problem with Magnavox 15MF605T/17B

I have a Magnavox 15MF605T/17B and this morning when I turned it on, (it was previously off) there was no picture. When I press the power button, the LED light turns amber, but then goes solid green. I have tried unplugging the power supply and reconnecting it to the TV, however no such luck. I even checked out my user manual, again no such luck. Any advice would be much appreciated. Also is there a reset button or anything? There is no smell of burning, no damaged pixels or anything like that. Just sorta died on me I guess. Thanks in advance.

Posted by on

  • 9 more comments 
  • Tayls215 Feb 27, 2008

    My flat panel Magnavox's picture won't work. It started doing this intermittenly, then eventually the picture never returned. When I turn it on the screen looks like it's starting to brighten up for a second, then goes back to being dark - but the sound still works. The TV was a refurb and only had a 90-day warranty (and of course started acting up in about the 4th month of me having it).




    Any thoughts would be greatly appreciated!!!!

  • Anonymous May 27, 2008

    Same problem - no picture (black screen). The green light on the front lower right is on but the screen is black (audio is working fine). Nothing appears on the screen even when I go to 'menu' or 'source'. Everything fine the night before with no indication of impending problem.

  • dah31 Jun 29, 2008

    Thanks to perfidia for getting me out of computer mode.  (I used the Source button on the remote control, since I couldn't find one on the top of the set.)

    Now, I've got the same again: when I turn the set on, the power LED turns amber and then green.  There's a brief (maybe 0.8 s) flash from the backlight, and then all is dark.  (The display panel is working: I can see the OSD when the backlight turns on.)

    I've got the service manual from Electromatics (sorry—Electromaniacs) http://manuals.electromaniacs.com/index.... but it's not a great deal of help.  All the signals going to the inverter board seem correct (and I've installed a new inverter board, so that's fine).

    My current theory is that perhaps the scaler board (motherboard) is driving the BIT3193 CCFL PWM driver chip out of spec.  Google found me an Application Note (as well as the datasheet) for this chip, and page 10 says the ``working voltage range of BIT3193 is 4.5V~8V and recommended operation voltage is 6.5V.''  ...well, I just checked, and it's getting 7.5 V on Vdd, and the ONOFF signal is getting 2.6 V.  The application note says, ``When input voltage of BIT3193 is higher than UVLO [under voltage lockout] (4V) and the input of ON/OFF pin is higher than 1V, then BIT3193 will be turned on.''

    New theory: that the chip's protection circuit is being triggered.  That says to me that the /design/ of the inverter board is incorrect for the chip they used.  Maybe I'll haul out the scope and logic analyser one of these days....

  • Anonymous Jul 26, 2008

    turns off after 15 minutes

  • crazzeecat Oct 28, 2008

    I have the unfortunate problem of owning 2 of these.I bought them from a famous electronics store for an outragous price 3 years ago.BOTH have had the same problem-NO PICTURE suddenly one day-1st one only 1 & 1/2 years after I purchased it & sent it back to the store.It took 6 months to get it fixed.They refused to extend the warranty. The 2nd one lost it's picture exactly 4 days after the 2 year warranty expired. The store won't give me the part name they had to replace.So here I sit without a tv because my husband took the one that works in the bedroom. I think it's only something like a fuse.

    If anyone ever comes up with the answer,I'd love to hear of the solution so I can fix it & watch my almost $400 tv.Thanks

  • Anonymous Dec 26, 2008

    i had the tv on playing fine, then no picutre only sound



  • boneman15 Jan 31, 2009

    Same problem, select the ON button and the indicator light goes Green for a about 1 sec then goes to the amber color.

  • gardengir837 Apr 22, 2009

    I turned on my 15" LCD tv about a month ago - there was no visible picture, but plenty of sound. I had called the cable company to come out to check to see if the problem was with the cable. It turned out to be a problem with the TV itself. Oddly enough, I can see a picture when I aim my floor lamp directly at the screen, but otherwise, it's just black. What causes this problem and is it fixable? I paid $370 three years ago at a mega-electronics store. Thanks for any suggestions that you have.

  • dah31 May 19, 2009

    Green power LED briefly and a flash of the backlight, then amber LED and no backlight.  I have replaced the inverter board, but I think I picked the wrong part number, because the plugs from the lamps didn't fit (I pulled the wires out of their housings and pushed them on the pins on the new board).

    My power supply puts out 16.80 V no load, 16.70 V with the set connected and turned on (it's a Philips EADP-60BB B, 16 V 3.75 A output), so that's a interesting lead to follow up.

  • dah31 May 19, 2009

    Or rather, amber power LED briefly and a flash of the backlight, then green LED and no backlight.


  • twbrewer1 May 11, 2010

    I have the magnavox 15MF605T/17 just got it. It has never been used. The green power light comes on. We have sound, but no picture. We have the power cord plugged in and hooked up to the cable. Is there anything else I need to do to get a picture?



    Thank you

×

6 Answers

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 4 Answers

Hi SgtHoagie and anyone else:

I ran across this problem too, at 1:30 this morning. At that time I had to get out of bed and try to figure out what the hell happened. It seems that my flat panel TV somehow got switched over to the computer monitor mode. When this happens, the light will turn an amber color. On the bottom of your flat panel you'll see some very small buttons, marked "MENU," "CH" "VOL" and "SOURCE." You'll want to click on the "Source" button and that will switch your flat panel back to the TV mode. Your flat panel TV can also be also used as computer monitor.

Posted on Feb 15, 2008

  • LRegan Nov 08, 2011

    For me, the channel had changed from 3 to something else, but this comment helped me fix the problem. Glad it wasn't a board!! Thanks.

×

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

It is a common problem that the inverter board goes bad. I had to replace mine wich cost about forty dollars but is simple to install. You can do a search on the power inverter as I am almost positive that is the problem.

Posted on Apr 08, 2009

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I bought one of these second hand, with the same problem. Seems the power supply has to be very stable, no less than 14 volts, no more than 17. Any less, you get sound no picture. Any higher, you get an amber flash and then nothing. It works great at 14.8 volts, so the problem may be in the power supply.

Posted on Jul 07, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Thanks to the help of all involed. Case closed. Many Many thanks agin

Posted on Oct 06, 2011

Have problem with sound after 1 hour of playing the tv , the sound goes out

Posted on Aug 13, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 4 Answers

I have exactly the same problem. I received this a gift from a friend that was upgradind toa bigger TV. Worked fine for about a month and the suddendly started loosing the image but the sund is OK. It started doing this intermittenly, more and more frecuently each time and then the picture never returned.

I need help, and for what it seems this is a common problem with this model.

Posted on Apr 17, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do you tirn the subtitles off


Hi,
check the link and down load the manual for your tv. Check portion describes the cc closed caption option (page 28) and do the necessary setting.
http://www.m4c.magnavox.com/cgi-bin/cpindex.pl?ctn=15MF605T/17&hlt=Link_UserManuals&mid=Link_UserManuals&scy=US&slg=ENG
www.electro-medical.blogspot.com

Oct 13, 2015 | Magnavox 15mf605t/17 15" Inch Flat Panel...

1 Answer

Magnavox 15MF605T/17B how to remove the front panel to replace speakers?


I presume the back cover does not really open from the back or if it does you cannot see the speakers from the rear?

which if you cannot see them with rear cover removed leaves two possible paths, the entire panel unit with the screen has to be removed and they are under it OR the entire front may be snapped together and has to be pryed out (if you see a seam or crack like area running around the side up front get a thin metal putty knife and try to open it, seen a lot of computer LCD monitors where they come apart from the front--and are snapped together much like some of our plastic remotes--have to go in from the front and not the rear.

Do some careful looking to see what you have.

Dec 06, 2012 | Philips Magnavox 15MF400T 15 in. LCD...

1 Answer

I have a Magnavox 15MF605T 17 that when the power button is pushed it goes green for a couple of seconds then turns amber. No picture, sound, etc. I unplugged the TV for about 10 minutes and when I...


Try to turn it on with a remote if one is available. If you don't have the original remote you can look up the universal code for the cable or satellite remote. Also try to turn it on with the input source(vcr,video game, cable box,etc...) on first. I have the same TV and if it has no signal prior to manual power up it will go to standby mode.

Jul 08, 2011 | AOMNI Corporation Magnavox 15MF605T/17 15...

2 Answers

Where do I purchase a power cord for a magnavox 15mf605t/17


its the same as a computer power cable you can find these all over the place. try ebay

thanks
michael

Mar 25, 2011 | AOMNI Corporation Magnavox 15MF605T/17 15...

1 Answer

This was totally the solution to no picture but normal sound- I purchased the two caps 150uF, 25V. from Digi-key and the tiny 2.5 Amp(or so i think) fuse and voila! Perfect picture is restored for a few...


The caps were standard 150uF 25v electrolytic radial leads Digikey 493-1822-ND
The fuse was ridiculously tiny, a pain to solder 2.5A 32v fast 1206 Digikey F1464CT-ND
Thanks again to Badavis who posted the solution- I wouldn't have even tried fixing it without that.

Apr 21, 2010 | AOMNI Corporation Magnavox 15MF605T/17 15...

1 Answer

Lost my ac/dc adapter


Go to the philips-magnavox-funai web site:
http://magnavox.fox-international.com/

Use the 800 number ... tom

Apr 16, 2010 | AOMNI Corporation Magnavox 15MF605T/17 15...

1 Answer

Magnovox Model # 15MF605T/17 HDTV how do you get the HD to work, I have lost my manuel.


Available in PDF format from the site:
http://www.magnavox.com/ under the support heading.
tom

Mar 18, 2010 | AOMNI Corporation Magnavox 15MF605T/17 15...

1 Answer

Tv with sound but no picture


ur video inverter board is ded.
Need new one.if u lucky it just lose.

Aug 14, 2009 | Philips Magnavox 15MF400T 15 in. LCD...

Not finding what you are looking for?
Philips Magnavox 15MF400T 15 in. LCD Television Logo

3,852 people viewed this question

Ask a Question

Usually answered in minutes!

Top Philips Flat Panel Televisions Experts

The Knight
The Knight

Level 3 Expert

68223 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

 Grubhead
Grubhead

Level 3 Expert

4584 Answers

Are you a Philips Flat Panel Television Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...