Question about Computers & Internet

10 Answers

External Hard drive

Need drivers for Windows XP Pro sp2

Posted by on

  • 19 more comments 
  • d00d23 Feb 16, 2008

    i am having the same problem with my 500GB WD external drive. xp keeps prompting me for drivers every time i plug it in to my pc. my install of xp is up to date with windows updates. i even let the found new hardware wizard search the internet for the drivers and it came up with nothing. anyone have a link to the drivers or an article?

  • Anonymous Apr 06, 2008

    Please describe the specifics of your problem below. We'll add

    your post as a comment to Azzoosmit79's External Hard drive problem, and notify you when a new solution is offered.

  • prafulpai Jul 07, 2008

    I am facing a similar problem with my Seagate 160GB drive, my OS is Vista basic with all updates but still unable to use the external drive. It keeps on telling me driver cannot be installed.



    I checked the same drive on a friend's Desktop which is XP, its working fine there...................plz help

  • paul l34 Jul 12, 2008

    I am having the same issue. My WD book connects just fine to my laptop, using the same outlet and the same USB cable. Whenever I have the WD device connected, it locks everything up. As soon as I unplug the USB cable, everything else on the pc works again. Many of the solutions I've seen online for this issue are Vista specific. There must be something else here. Please help!

    Paul

  • SgtP Aug 12, 2008

    I have a 1TB SimpleTech Pininfarina that was working properly and now it is saying that it cannot find the drivers.

  • dwwittenberg Oct 12, 2008

    My hard drive is no longer recognized by my computer



  • Anonymous Oct 26, 2008

    I would like to download some drivers for this product where can i get the drivers from

  • Anonymous Oct 31, 2008

    i looked on simpletech's website and found nothing as far as drivers for my 320 gb external hard drive so my computer wont recognize it

  • makhtar Nov 13, 2008

    Same driver problem

    I came home after work and found that my XPSP3 saying that Peninfarina 320 is unknown USB device.

  • Anonymous Nov 14, 2008

    tak



  • Anonymous Nov 16, 2008

    has any found the drivers for this device

  • pumken Dec 23, 2008

    I have a simpledrive product number starting 90300. It works fine on two computers but not on the dell which we use most. I have XP and it should plug and play?

  • dbmcgirt Jan 08, 2009

    when i plug in wd my book to my dell xps it tells me that the usb device is not recognized

  • izokay Jan 15, 2009

    i deff could use a driver

  • taniapaoli Jan 21, 2009

    i have the same problem and it asks me to insert the software

  • viking006 Jan 24, 2009

    I have a LaCie 160Gb external HD that does not install on PC with XP Home Ed.
    PC detects HD and when asking for automatic or manual installation, neither works. Messages reads: An error occured and your hard ware may not be installed correctly. Invalid data.

    The HD does not appear on desktop and on the hardware manaegment application it signals with a small exclamation mark that there is indeed a problem with the external HD related to drivers...


  • christoph609 Mar 11, 2009

    I have the same problem with the Seagate FreeAgent Go 500 GB USB 2.0 Hard Drive. and I cant find a driver to download to fix the problem. Where can I get the driver for this hard drive?

  • Anonymous Mar 12, 2009

    I have exactly the same problem as the user above.
    Is there a drive?
    I wonder if it is something to do with the fact that I have only ever used this 160gb Ext HD on a MAC.
    Could that have something to do with?


  • Anonymous Mar 17, 2009

    In windows Xp 1 TB external hard disk detected but not showing content

  • D. Tinsman
    D. Tinsman Mar 28, 2009

    I had the same problem and it turned out I was using the wrong power adapter. The size of the insertion plug is very common. Be sure it the one seen here: power supply

    Once I corrected this, all was well!

  • cln246 Apr 11, 2009

    Same problem my computer detects drive not showing contents, can't find drivers . Who we be the first to find it ? Let the race begin, hope to here from somebody.

    Cln246


×

10 Answers

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

I need drivers for my simpletech external hard drive model number 96300-40001-001

Posted on Dec 28, 2008

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

When I switched on my computer one day, Western Digital drivers were not found.
This works:
I have changed plug sockets, power strip to wall socket and now Western Digitals are now being detected.

Posted on May 24, 2008

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

I switched the USB cable to my camera's (Canon) USB cable and it worked. The WD drive is plugged in a powerstrip.

Posted on Dec 26, 2008

Does anyone understand why this solution works?  it makes no sense.  the drive mounted find and worked for months on the same power strip, now, suddenly, it needs to go directly from a wall outlet?

Posted on Nov 05, 2008

I had the same problem, but once i plugged it straight into the wall socket it seemed to work fine. just make sure that the end of the UBS cable that plugs into the my book has not come loose as this may also cause a disconnection.

Posted on Aug 15, 2008

Dumbest problem reason ever. but the solution does work.

Posted on Aug 07, 2008

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 14 Answers

Have a MicroNet 80GB hard drive PHD8072U2F my son gave me and on another older computer had saved some of my files from....anyway cannot get to other computer and the one I am using is another sons and I need some of my documents on this external drive and cannot find a driver for it to download and be able to even use it. Please help, I am fighting to keep my home and the documentation is on this drive and only on it..... One thing I learned is I will do what I wanted to do in the first place and have at least a double back up plan.....sons thought I was over concerned...I know if it can happen it will to me and should have done it but was a financial burden and listened to them. Thanks and God Bless email dawn8459@hotmail.com

Posted on Jun 07, 2008

  • worzgumm May 20, 2011

    I too am having problems with the SimpleTech SimpleDrive External HDD Firewire & USB 2.0., 160 GB, 9000-40480-001 not being recognized by Windows XP Professional SP3. I have tried plugging the power supply directly into the wall outlet, but this did not help. Orko1978 remarked that the correct power supply is important. Can you please tell me what the correct voltage, mA capacity and polarity should be? (I somehow lost the original power supply). Thanks!

×

I too was having trouble with my WD external drive. One day it was working fine - the next it was not recognized on any ports. Listed as an Unknown device and no drivers installed.

I tried the solution listed above - unpluged it from the power strip, pluged it into a wall socket and ALL WORKS! Darnedest thing I ever seen.

Posted on May 25, 2008

I did a Google search and found another user having the same problem! Apparently the problem goes away if you plug the drive directly into a wall outlet, and not to a power strip.
I did the same thing and it works! Weird, but at least it works for me... No need for any downloading drivers or whatever,.

Posted on May 06, 2008

Well just look at ur mom or u could try fuckin' yourself one or two time kk plz tnx lol

Posted on Oct 20, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I am using windows xp home edition (SP2), when I'm going to insert an external drive to my pc, the external drive is detected but I cannot open it rather it appears "the request could not be performed...


Good Day!

is your HD Fell? have you try to open it to another computer? try it first. if the computer you inserted is OK. there seems a problem regardless to your computer. try to reformat it and install Win XP pro. (SP3)

Thanks and God Bless!

Apr 04, 2011 | Western Digital Elements (WDE1U4000N) 400...

1 Answer

My desktop crashed. I lost everything on it. I thought I downloaded some informatin on my Seagate Externa harddrive, however, I am having problems connecting to other computers to see if any information is...


External hard drives are plug and play, the drivers are build into windows.
IF the hard drive was connected when your computed crashed, and the hard drive was in use, it may have damaged it.
If it does not automatically connect to other PC's looks like it has been damaged

Aug 20, 2010 | Seagate FreeAgent Pro - 500GB, 7200 RPM,...

1 Answer

Hi, My desktop does not respond to segate 320GB external Hard disk on windows server 2003 operating system. But it works fine in windows xp . Can anyone suggest me how to solve this . Thanks in...


It must be some driver problem.Try updating drivers through windows update or you can also try installing latest service pack for Windows 2003 Server.It will definitely solve your problem.

Aug 10, 2010 | Seagate FreeAgent Pro - 500GB, 7200 RPM,...

1 Answer

My WDBAAU0015HBK external harddrive don't boot when i start up my computer. It says initalising USB divices and then when it autodetect the USB mass storage devices it stops. In the BIOS i put the boot...


It sounds like the BIOS is set to auto-boot from the USB device.
Have you reset the 'boot order' in the BIOS?

Also if you are still running sp2 go to Microsoft update and install the updates. You should be running on service pack 3.
(the updates are free, and are more secure than sp2)

Jul 20, 2010 | Computers & Internet

1 Answer

Windows xp will not restart with usb plugged in. I am running windows xp sp2 with a Hitachi 500g external hardrive that is designed to turn on and off with the computer. The same hard drive works fine on a...


Sir, your PC might have been checking for external devices which plugged in to boot from. Thats wrong. So get into the bios of your computer while startup and change the 1st boot device to your computer's hard disk. And its a bad idea, starting your computer with a usb device plugged in.

Jun 29, 2010 | Hitachi 500GB External USB 2.0 Hard Drive

1 Answer

How to partition an external hard drive on windows xp?


Go to Control Panel => Administrative Tools => Computer Management => Storage => Disk Management.

The drive should be shown on the list, just right click for options, you can partition, format, change driver letter, whatever you need to do.

good luck!

Feb 04, 2010 | Seagate FreeAgent Pro - 500GB, 7200 RPM,...

1 Answer

WD Caviar SE16 WD3200AAKS 320GB 7200 not recognized at install


Windows XP does not have built in SATA drivers. You will need to download the XP drivers from Western Digital's website and install before the computer will allow you to format and use your new drive. Hope this helps.

Jul 18, 2009 | Western Digital (WD3200JS) 320 GB Hard...

1 Answer

Replace bad HD with new 5oogb


This is a rather technical problem with MS Windows and the 48bit Logical Block Addressing scheme.
You can read more details here: http://support.microsoft.com/kb/303013

Short solution: You have to install Service Pack 1 (or better SP2) in order to get past this problem.
I assume that you had this disk in you computer before, so the BIOS should be able to handle this as well.

Dec 08, 2008 | Western Digital 500GB My Book Pro-External...

Not finding what you are looking for?
Computers & Internet Logo

Related Topics:

7,946 people viewed this question

Ask a Question

Usually answered in minutes!

Top Computers & Internet Experts

Brian Sullivan
Brian Sullivan

Level 3 Expert

27725 Answers

joecoolvette
joecoolvette

Level 3 Expert

5660 Answers

kakima

Level 3 Expert

98694 Answers

Are you a Computer and Internet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...