Question about Car Audio & Video

1 Answer

What do i need for installation of 1000w Magnum amp?

I have never hooked up a 1000w amp. I would like to know what cables i should use and instructions for PROPER installation.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Mentor:

    An expert who has written 3 tips or uploaded 2 video tips.

    Governor:

    An expert whose answer got voted for 20 times.

  • Expert
  • 199 Answers

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

What is wrong with my 1000w sony xplod amp?


need repairs on the inside usually when u see that fuse melt something else probably melted on the inside. something is grounding out the amp on the inside . get it checked

Jun 05, 2010 | Car Audio & Video

1 Answer

Alpine amp not working.


possably, did you get it professionally fitted? they have lifetime warranty on install,

Apr 22, 2010 | Alpine PDX-1.1000 1000W x 1 Car Amplifier...

1 Answer

My alpine clips out at high volume I took the subs out and hooked um up outside of the car and it was working fine. do I just have a short in a ire or is this the pdx 1000 safe mode. How can I get it fixed


Go to rockfordfosgate.com they have a woolfer wiring wizard that can help you make sure your amp is under the correct ohm load, if your woolfers are wiring up on a 1 ohm stable load the amp will overheat and go into protection mode and cut out.. Need the woolfers on a 2 or 4 ohm stable load, and the amp should run fine with a capacitor, and some good 0 to 2 guage cable, plus a good battery and alternator to feed it

Oct 09, 2009 | Alpine PDX-1.1000 1000W x 1 Car Amplifier...

1 Answer

I have a 1000w amp but it got burned why??


Hello,

I'm sorry but your problem was a little confusing. Your speakers worked fine, you hooked up a 1000W amp and now you cant hear the sound ?

Then you say "they say because the wires were connected wrong in the amp it burned" does that mean your amp burnt out ?

Please post back and sort these facts out for further assistance.
As of right now im not sure if the problem is with the speakers or the amp itself.


Oct 01, 2009 | Alpine MRD-M1005 Car Audio Amplifier

2 Answers

Sony xplode 1000w amp has green light puts out no power to subs


may haveto turn sub on through the stereo itself if rca cables are good.

Jan 08, 2009 | Sony Xplod XM-1652Z Car Audio Amplifier

2 Answers

Amp Turns on Fine, but no Sound


have you checked the levels on the ohms? adjust them higher if need be contact me on yahoo msgr if you need more assistance

jcbproducts-always forward

ym-jcbproducts

Nov 14, 2008 | American Pro VS-2043 Car Audio Amplifier

1 Answer

Amp problems


The main thing that comes to mind is whether you've checked the in-line fuse on the positive wire. Most amp installations are supposed to have a fuse within 1ft of the battery terminal for just such a reason. Next, if you have a voltmeter of some kind (or know someone who does), check to see if you still have 11VDC-14VDC at the power terminals of the amp. If you do, then check the remote turn-on lead (which is supposed to connect to either your head unit or the ignition). If my memory serves, the remote wire should be high (about 12V) when the amp is being told to turn on and low (less than 2V) when it's being told to turn off.

Jul 29, 2008 | Alpine PDX-1.1000 1000W x 1 Car Amplifier...

1 Answer

Install diagram?


i dont know where to find the instructions, but it shouldn't be all that difficult. I used to have one of these legacy amps .....what hookups do you have on it?

Mar 15, 2008 | Legacy 4CH 1000W RED AMP Car Audio...

2 Answers

Hooking up DVC subs


The amp is rated to run a 2 ohm load on each channel. To do this, connect the voice coils of one sub in parallel (tie both "+" on the sub to each other and both "-" on the sub to each other), then connect that sub to one channel of the amp. Repeat this process for the other sub and connect it to the other channel on the amp. The subs will be in stereo and the amp will be outputting it's maximum power.

Mar 09, 2008 | Legacy 2CH 1000W AMP Car Audio Amplifier

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

153 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4724 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

yadayada
yadayada

Level 3 Expert

63801 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...