Question about Creative Labs Gigaworks S750 Computer Speakers

2 Answers

Gigaworks s750 was playing speakers fine then turned off from controller....and then nothing ...controller lights disapeared......and was not working....the power light on the back of the sub is flashing....and no fuses have blown? any ideas...buy a new one perhaps...lol

Posted by on

  • 9 more comments 
  • wheeliemouse Feb 12, 2008

    all connections are good push in and never tampered with or moved since day one ....thanks for idea thow...but already checked.

  • wheeliemouse Feb 12, 2008

    forgot to mention the controller works on friends one.

  • wheeliemouse Feb 12, 2008

    nothing out of place inside...no damage or burning

  • Anonymous Feb 25, 2008

    sme thing has happened to me, switched it off on the remote, now its all dead and wont come on again!

  • maxyvelez Feb 27, 2008

    I have the same problem, went to bed, the next day nothing the control pod dosen't work

  • COKPAT Mar 10, 2008

    Funny... same thing happened to me as well. if there is any solution on this I will keep you posted... Feel free to do the same for me :)

  • Anonymous Mar 16, 2008

    i have the same problem

  • malamutza May 24, 2008

    same here... simply wouldn't turn on again, green light flashing on the back of the subwoofer.

  • kribba May 25, 2008

    i now have it open and i can heear this small click from the amplifier at the same rate as the light is blinking..

    anyone! help!!!

  • Anonymous Sep 24, 2008

    i get the same thing happening.... and i took the back panel off of mine, and plugged it in and the ticking seems to be coming from one of the larger transistors inside. not really sure if it is fixable... and i was wondering if you need the audio control pad to use the system... i lost mine......

  • jonas_x69 Dec 15, 2008

    I got the same issue... Anyone got any ideas? Is this fixable?

×

2 Answers

Same **** happend to me. I have TWO systems, and now none of them are working. Just the flashing green light on the back of the sub...

Posted on Oct 31, 2008

Same problem just went out after about 4 years.... weak lifespan for a 500 dollar system

Posted on Aug 05, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a Creative Gigaworks S700 i have checked both fuses still no power to control box


Stupid question: does the sound still work? it could be the LED just died after continual use (rare, since they last a long time, but not uncommon).
If not... it could be the controlling circuit board died. In which case, unless you have electronics repair experience, it would be probably more worthwhile to just replace the speakers, as pricey a model as it is.

Mar 23, 2012 | Creative Labs Gigaworks S750 Computer...

1 Answer

My gigaworks s750 powers up and lights, but no sound


Hi, have you find any solution? I got the same problem. Can you please email me. mtlmw@hotmail.com. Thank you

Feb 26, 2012 | Creative Labs Gigaworks S750 Computer...

2 Answers

Cambridge Soundworks Gigaworks S750 I left the system on standby over the night next day no sound or some fuzzy sound from the speakers..Is it the remote controller or the whole system went...


To make these your default speakers, you will need to do the following 1. Find the volume control icon on the bottom right portion of your screen 2. Right click the icon 3. Select change default 4. Cycle through the options until you see the logitech speakers as an option 5. Select this new option 6. If you still do not see the logitech speakers then you need to reinstall them with the provided software. If you do not have software, download it for free from logitech.com

Jan 22, 2011 | Creative Labs Gigaworks S750 Computer...

2 Answers

All I need is the control pod for the Gigaworks S750


I had an extra one but I sold it. According to creative labs they do not sell any replacement parts for the speaker systems. The best suggestion that I can give is to check craigslist and ebay for the control pods.

Dec 13, 2008 | Creative Labs Gigaworks S750 Computer...

1 Answer

Creative S750,all speakers distorted


Your problem sounds like it is the high voltage power supply not working. I would start by checking the IRF740 MOSFETs on the power supply board. Below I have pasted a link to a forum thread about fixing the Gigaworks S750 systems. There is a lot of information there about the problem you are experiencing as well as complete diagrams of the power supply and good pictures.

http://forums.creative.com/creativelabs/board/message?board.id=speakers&thread.id=8037&view=by_date_ascending&page=1

Oct 25, 2008 | Creative Labs Gigaworks S750 Computer...

1 Answer

Sub has died overnight


Change the fuse - located at the 220V input. Use a knife ti release it. Then the system will work again.

Oct 08, 2008 | Creative Labs Gigaworks S750 Computer...

2 Answers

Audio control pod


I have a similar issue too, but my problem is that the sub has green light, and my control pod has an 'off' light, but it won't turn on :(

Jun 16, 2008 | Creative Labs Gigaworks S750 Computer...

1 Answer

Control pod


Double check the connections, if the connection for the control pod is good then something is wrong inside. I would say most likely thing would be a problem on the power supply inside the subwoofer box.

Nov 29, 2007 | Creative Labs Gigaworks S750 Computer...

2 Answers

Creative gigaworks s750 bass turning off


switch off the spk and check the woofer spk audio cable connection is it loose or something .swith it on and just connect only your woofer and see r u geeting any sound from it . bye

Sep 16, 2007 | Creative Labs Gigaworks S750 Computer...

Not finding what you are looking for?
Creative Labs Gigaworks S750 Computer Speakers Logo

Related Topics:

609 people viewed this question

Ask a Question

Usually answered in minutes!

Top Creative Labs Audio Players & Recorders Experts

Brian Sullivan
Brian Sullivan

Level 3 Expert

27725 Answers

Carlos L. Burgos
Carlos L. Burgos

Level 2 Expert

618 Answers

yadayada
yadayada

Level 3 Expert

70387 Answers

Are you a Creative Labs Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...