Question about EliteGroup ECS 755-A2 Motherboard

1 Answer

Sytem wont post

Ecs 755a2 mobo asprie x navagator case 500 psu
nvidia2 pci graphics card
fans work lights work nothing on screen and no beeps....
????

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 17 Answers

Remove the rct battery and try again power on again.
Also look for and replace bad cappacitors. If nothing works, you need a new momo!.sytem wont post - 317cfa4.jpg

Posted on Feb 12, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Asus M4A88TD-V EVO/USB3 BIOS: 1702 AMD Phenom II X4 955 PSU Ultra 500watt ATX RAM Patriot DDR3 1600Mhz 2x4Gb Mobo will not POST, no beeps, fans turn for one second and stop. Mobo replaced with same,...


So you changed everything except 1 thing, power supply. Try another power supply or power suply cord.
If it doesn't work, try another graphic card, maybe there is some shor circuit.

May 07, 2011 | ASUS Motherboard M4A88TD-V EVO/USB3 AM3...

1 Answer

Video failure post beeps.. i have am2n-e sli mobo, amd 5200+ 64bit dualcore cpu, 4x1gb ddr2 ram sticks, gf 430gs pcie video, 500watt psu, 2x ide and 1 sata hdds, and a ide dvd burner post check beeps one...


Hi, Thanks for using fixya.

Go into the bios stettings and check the intergrated video graphics are disabled. If you can't see the settings replace the motherboard again.

Terry

If you have any further questions regarding this matter feel free to post a comment or if you are satisfied with my answer, please give it a rating for this is the reason I do this work.

Feb 28, 2011 | ASUS M2N-E SLI (M2N-E SLI GREEN)...

1 Answer

D945GCCR Motherboard: after a thunderstorm the psu got damaged so I repl...


Sorry, the motherboard has been fried - nothing you can do, it's dead. Replace it.

May 18, 2010 | Intel D945GCCR Motherboard

1 Answer

No signal problem with xfx 9400gt fatal1ty


Check for bios jumper set for normal operation, check for onboard vga jumper set for pci or external video.

Jul 14, 2009 | ASUS COMPUTER INTL P5SD2-VM MBD MATX LGA...

1 Answer

No beep,No Display on my monitor,only CPU heatsink fan is moving


You motherboard has onboard video. It's possible it needs to be disabled and the option changed to use the pci or pci-express slot for the Ati card you installed. Since you have no post error beeps this is the best place to start. Also I had built a system not to long ago and had a similar problem. Resetting the cmos on the motherboard (usually a pin combo) solved the issue.

Start by hooking up your vga cable to the onboard video.

Hope this helps.

Apr 07, 2009 | MSI P7N Diamond Core 2 Quad/ Nforce 780i...

2 Answers

Blank Screen, no beeps, New Build


Hi Durmo, your troubles may be the SLI card. If you are using a single 8500GT make sure your SLI card is plugged into the motherboard as a single graphics card. See page 3-9 in your manual. If your 8500GT has dual out puts check both for display. Only one will show you display.
If you have this set correctly & you have tested your monitor on another system (& it is good) yet no display from the system than contact Asus. This board was make in 2007 & is warranted up to 2010. You can do this online or call Asus at 1-812-282-2787 M-F EST. Other countrys click the dropdown menu at Asus home page. http://www.asus.com/products.aspx?l1=3&l2=11&l3=473&model=1474&modelmenu=1

Post if you need more info.
Good luck!
Mike

Aug 19, 2008 | ASUS P5N-E SLI Motherboard

1 Answer

New Graphics card wont work


is the bios set to dispaly using a built in graphics card on the mobo?

Jul 02, 2008 | Intel Motherboard

2 Answers

No beeps on boot up with asrock mobo? help plz


While booting BOIS goes for POST check for detecting the all the hardware .

Disconnect all the connection to DVD, HDD, FDD from MOBO.
Rmove all RAM and start the ssytem from testing RAM Serviceability. If you listened a long intermittent beep place a single pices of RAM in MOBO ( repeat test with other RAM also).

Other wise your video card is unserviceable, if you have any addon plugins like NVIDA graphics card you can check

Jun 10, 2008 | Asrock K7S8X-R3 Motherboard

1 Answer

K8NGM2 Mother Wont Power Up


I've seen situations similar to yours several times and they've always been a bad CPU.  Since you tried a new video card it's not that, I would suggest a new CPU.  Check on ebay, you can usually find used one's on there.

Oct 10, 2007 | ASUS A8N-SLI Motherboard

44 Answers

No beep,No Display on my monitor,only CPU heatsink fan is moving


how to fixed your motherboard no display and no beep, 1st you must clean your memory using eraser and brush for painting if not display again try to clean your video card if have a video card using again the eraser and painting brush if not display again try to pull out the bass in the cdrom and floppy disk. if not display you must replace the memory and video card., if not display try to change your motherboard. The beep put speaker in the motherboard.. gudluck guys

Sep 10, 2006 | Asrock P4I45GV R5 Motherboard

Not finding what you are looking for?
EliteGroup ECS 755-A2 Motherboard Logo

Related Topics:

98 people viewed this question

Ask a Question

Usually answered in minutes!

Top EliteGroup Motherboards Experts

Brian Sullivan
Brian Sullivan

Level 3 Expert

27725 Answers

Mark Taylor
Mark Taylor

Level 3 Expert

728 Answers

Michael Thomas
Michael Thomas

Level 3 Expert

3051 Answers

Are you an EliteGroup Motherboard Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...