Question about Delstar DS 917 Digital Media Player

1 Answer

The menu button

Well my menu button wont move left,right or down and i have no clue whether it will go up b/c that is the up volume and it is up all the way. so when i try to move from folder and song it wont move and i have to listen to it all the way through and i cant get out of a folder so i have to listen to the same songs over and over! idk whether it is just b/c i use it so much or what but it is really getting annoying!
any help!
*Heather*

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 57 Answers

Format the player, or upgrade the firmware for this product.

Posted on Aug 04, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Yamaha rx850 stuck on tuner mode and volume nob has a blinking light no sound mybe stuck on standby mode?


Are any of the buttons stuck on/in , which would jam the processor?
Maybe the tuner button stuck in? Try spraying them with switch cleaner on the front. If not.
ELECTREPAIRUSA@ELECTREPAIRUSA or you can contact us at that address as we repair/renovate all items electronic and electrical old and new.

Jan 07, 2017 | Yamaha Audio Players & Recorders

1 Answer

I have a K r e l l K A V 3 0 0 I get heavy distortion coming from LEFT channel ...After about 30 mins the distortion seems to clear ...it seems only from switching on from cold to 30 mins


This sounds like the either the output transistors breaking down or the electrolytic capacitors on that channel.
If not.
ELECTREPAIRUSA@ELECTREPAIRUSA or you can contact us at that address as we repair/renovate all items electronic and electrical old and new.

Jan 06, 2017 | The Audio Players & Recorders

1 Answer

The volume comes on loud even when i have turned it down before turning off


It sounds as if the UP VOLUME button/switch is broken and ON all the time. See if it is stuck down
ELECTREPAIRUSA@ELECTREPAIRUSA or you can contact us at that address as we repair/renovate all items electronic and electrical old and new.

Aug 09, 2016 | Dual Audio Players & Recorders

1 Answer

I have a m4500 creative speaker the problem is the volume switch when i turn it on the green light is on and when i increasing the volume the become dimmer until its off and no sound,what is cause?


It sounds like the output IC (the amplifer) has a problem.This needs to be replaced.
ELECTREPAIRUSA@ELECTREPAIRUSA or you can contact us at that address as we repair/renovate all items electronic and electrical old and new.

Mar 12, 2016 | Audio Players & Recorders

1 Answer

I have to move the wires in the back around to get the speakers to work right.how do I fix that problem..


IF THERE ARE SCREWS TOTAKE THE BACK OFF THEN DO THIS AND YOU WILL FIND A LOOSE OR DRY CONNECTION

Feb 17, 2015 | Audio Players & Recorders

1 Answer

How do I increase the volume on my record and cd player


Feed the sound into a really loud p.a. system. You can use a high quality Mic to get the best sound.

Jan 11, 2015 | Audio Players & Recorders

1 Answer

How do I increase the volume on the radio


Im sure there must be an app that will do it. Have a look on the internet or google store for a phone app which controls radio sounds

Jan 05, 2015 | Audio Players & Recorders

2 Answers

I have a Rowe R80 jukebox and after moving it it has no sound through the speakers I am in New Zealand


Well, in addition to all the fine suggestions that are here, I would like to add the simple and easy things that may have happened during the move.

IF YOU ARE NOT GETTING A LOUD POP WHEN THE MACHINE IS POWERED ON.......

1) Make sure that the wires on the terminals below are still connected to the screws. There is one ground and one each for left and right. The lower the tap the lower the (max) volume of the jukebox.If they are not connected there will be no sound.
84c9065c-b7c6-4417-be21-0be7a6e74b41.jpg


There is a jumpers on the terminal strip where the volume control connects. Make sure that these connections are correct and tight. Also make sure that the jumpers did not fall off.
c1d72051-525d-47ec-8725-a6a8e655b20c.jpg
7a25e260-d39b-4992-8bce-8c2d2c9b07e5.jpg

If you are getting the loud pop in the speakers when the power is turned on .....

Check the plug on the side of the mechanism, just below the back of the tone are.(looks like a little tube socket) Check to see that it is connected to the mech and the CORRECT PLACE on the amplifier. It mat be possible to have this end in the wrong place. bf77613e-82a3-4e37-b8fe-cc80f4d4dbcb.jpg

Check all all your connections against the pic.

I hope this was helpful.

Mar 24, 2014 | Audio Players & Recorders

1 Answer

It wont turn on, it shows 'push power protect' when you turn it on, or disconnect it and reconnect, i already attempted to disconnect the Sony Stereo MCH-EC909iP Mini Hi-Fi and it shows 'Push Power, P


The only thing I can think of is its goin into protection mode like an amplifier would, you maxed the volume out and it's protecting your speakers or you don't have the right voltage going to it, I can see you don't have it on a straight 120v plug and you might have the wiring wrong on the speakers to it might be too low of a ohm or too high

Nov 22, 2012 | Audio Players & Recorders

3 Answers

Front two speakers not working at all


Hit the the speakers A/B/Off button on the receiver. If you plugged the front channels speaker wire next to the center channel on the back of the receiver make sure its showing B. If you plugged them in the banana plug part, make sure its showing A.

Apr 12, 2007 | Audio Players & Recorders

Not finding what you are looking for?
Delstar DS 917 Digital Media Player Logo

Related Topics:

25 people viewed this question

Ask a Question

Usually answered in minutes!

Top Delstar Audio Players & Recorders Experts

kakima

Level 3 Expert

98758 Answers

 Grubhead
Grubhead

Level 3 Expert

4678 Answers

The Knight
The Knight

Level 3 Expert

69664 Answers

Are you a Delstar Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...