Question about Speakers & Subwoofers

1 Answer

No sound you can see the light that it's on but barely there is no sound the disc shows picture but no sound coming from amp

Posted by on

  • penagih_kopi Feb 12, 2008

    Hello! I just got these speakers with my M-Box 2 Mini Studio Bundle. The first time I tested it worked, but since, there is no sound. It is really really soft even if I blast it to full volume both on my MBox and on the speakers. I have fixed the System Preferences for my Power Mac G5 2.0GHz (10.4.11 Mac OS X Tiger) based on the MBox 2 instructions but still there is no sound. Please help! THANKS!!

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 52 Answers

U gotta make sure all the connectors are right, The dvd player output cables are plugged into the OUTPUT of ur dvd, and they go into the Video Input of the amplifier, U gotta make sure ur speakers are plugged in into right too, out put speakers. Surround system only works on DVDs and some music CDS, so dont expext to have surround sound from all music CDS/

Posted on Feb 10, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Subwoofer repair


Check your connections. Make sure everything is plugged in properly. If it is still making a sound, even a whisper, then the amp is probably fine. Do you have other speakers connected to the amp? If so, they should be sounding too. If not, then it's definitely an amp problem. Ebay sells tons of .... well, everything, so you should check that out...

Mar 05, 2014 | Jmlab Speakers & Subwoofers

1 Answer

Hello i have a s master digital amplifier model number SA-WSF200. Suddenly the right speaker a subwoofer stoped working. I tried plugging the right speaker into the left speaker output on the amp and it...


i dont know if amp has fuse for each channel, but they would be easy to see.. otherwise that baby has a blown component or two on a pc board, maybe an output power transistor of capacitor failed.
Last time i went to a shop it was like $100 plus parts for a similar repair.
I recomend sending Sony support an email and see what they say before you take it anywhere as well..

Dec 04, 2013 | Speakers & Subwoofers

1 Answer

My Mirage S10 subwoofer light comes on showing the subwoofer is on but I cannot get any bass sound to come on. How can this be resolved?


More diagnosis first. We can't assume the source is squawking bass to this thing and you don't mention that you know that to be the case. IS it? The problem could be up the food chain.

We also don't know if you're feeding it Speaker Level or Line Level.

Prove the subwoofer amp is dead or alive by jacking in any source you have that has an RCA output (Tape Out on your unnamed source, CD, TV, etc). Turn the sub volume down to minimum to start as most RCA outputs are at maximum volume. Try that to assess the amp's health. Still dead? Get it worked on.

Jul 07, 2011 | Mirage Prestige S10 Subwoofer Speaker

1 Answer

The subwoofer just quit working the green light is on sound comes out (here voices) the subwoofer no bass


if the light still comes on then the fuse is still good....

a possiblity exists that either the amplifier or the actual speaker itself went bad....if you like you can dissasemble the the subwoofer to access the insides....a simple test....if you connect the driver to another amp (any amp will do as this is just a test) and it makes sound then chances are your amp is bad or just a loose connection.

Aug 30, 2010 | Sony SA-VF700ED Speaker

1 Answer

I HAVE A SONY 5 DISC DVD SURROUND SOUND THEATER SYSTEM. I'M TRYING TO CONNECT IT TO MY TV BUT I DON'T GET ANY SOUND BUT GREAT PICTURE.


Not really enough info here to help much yet.

Helpful info would be:

1.Are you hooking up coax or optical surround from the DVD and have you set the amp to look at the correct type of input?
2. I could be much more specific with help if knew the model number of the surround system and DVD changer.

Sep 12, 2009 | Sony Speakers & Subwoofers

1 Answer

Sound but no picture


look for video mode button or p/n button on remote.press a few times,picture should come on

Apr 07, 2009 | Speakers & Subwoofers

1 Answer

No Sound for Velodyne VLF-1012


Sounds like your amp is damaged.

Jan 29, 2009 | Velodyne VLF-1012 Subwoofer

2 Answers

Jbl pb12 subwoofer


yes it can be repaired. but i need more details on this...

Mar 10, 2007 | JBL PB12 Subwoofer

Not finding what you are looking for?
Speakers & Subwoofers Logo

Related Topics:

106 people viewed this question

Ask a Question

Usually answered in minutes!

Top Speakers & Subwoofers Experts

 Grubhead
Grubhead

Level 3 Expert

4576 Answers

Michael Edwards
Michael Edwards

Level 1 Expert

53 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you a Speaker and Subwoofer Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...