Question about Photography

1 Answer

Minolta X370 film loading problem.

I can't seem to load film in this camera. The advance lever doesn't seem to work and the film is loaded properly.

Minolta XG-M as described, cannot advance film or press switch operating button. It does not depress.Also stop down button is stuck "in " position, will not release and inside mirror is closed down. Camera is new to me, took test photos, ok. Problem began with new roll of film. Please help.

Posted by on

  • Kevin Pettit
    Kevin Pettit May 11, 2010

    Have you tried fresh batteries?

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Master:

    An expert who has achieved Level 3.

  • Master
  • 619 Answers

Hi, check the camera set in auto /manually in auto function, check battery might drain the current , dis engage camera to lense to release the mirror by pressing button beside lense , turn lense in left or right .

Posted on Feb 19, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My Minolta is used, and I can't seem to load film


Most likely cause:
The Minolta X-series was notorious for bad capacitors. There were two of them that went bad. One under the baseplate and another under the top cover. Yes, both require some camera disassembly, snipping, soldering and put all back correctly-after you find the parts that went flying when you opened it, LOL.
You can find the capacitors being sold on Ebay for a few bucks and do it yerself. Or you can send it off for repair.
I suggest Garry's camera repair in Niles, IL. They will fix it, Clean, Lubricate and adjust it all for around 50 bucks. I think its about 45 plus 8 for return ship. About 2 weeks later, your camera is back in your hands, ready to go.
This is a worthwhile investment in a very good little camera. I still have the X-570. I won't part with it, LOL.
I have newer AF cameras, but I love my X-570.

Dec 27, 2009 | Minolta X-370S 35mm SLR Camera

1 Answer

Film advance lever goes back and forth putting no tension or movement inside the camera to advance the film. Was working fine, then after taking my last shot, lever is just sort of loose., couldnt load new...


first make sure the rewind button is not stuck down. open the back door and rotate the advance sprocket back and forth to release the button. if that did not work take the bottom cover off and check the white plastic gear near the take up shaft. if that gear broke it will have to be repaired by a camera repair person.
there are no new parts for this model so get a cost estimate first.

Jul 07, 2009 | Minolta X-370S 35mm SLR Camera

1 Answer

Blank Film Developing


It likely did not catch when it was first loaded, and as such never advanced through the camera. Open the back of the camera, with no film in it, then set the shutter speed to 1, advance the film advance lever and take a shot. You should see the shutter curtains open and then close a second later. Then advance the film lever again and watch to see that the sprockets are turning. If they are, then the camera is exposing and the mechanics are working properly to advance the film. Chances are it was just loaded incorrectly.

Dec 09, 2008 | Canon EOS-AE-1 35mm SLR Camera

1 Answer

Minolta x370 camera, the shutter appears to be stuck ? the film advance lever will not move ?


if you are up to repairing the camera yourself, you may want to remove the film first but cutting it from the lock then rewinding it to the tube (make sure you are in a dark room)...

then move to the small article below...

from PointBreak:

The BIG Minolta Shutter Problem Fix Secret EXPOSED!

The Minolta X-Series have been infamous for having their shutters "stuck" and without the film advancing. The LEDS will light up correctly but the film just wouldn't plain advance when you hit the shutter release button. Frustrating to say the least..but alas..alll is not lost. This has been a very common problem and I'll tell you why.

The X-Series, and other possible makers, contains a/an electrolytical capacitor with 1000 hrs of working voltage. When the capacitor reaches its limit it may fail (bulge/corrode). Whether this was an intentional design concept by Minolta is unknown..yeah right! Basically these capacitors hold a small magnetic charge and that when you hit the shutter release it reverses polarity and allows the film to expose, advance, blah, blah, blah..

OK! What I'm going to explain here will save you anywhere from $10 - $200 (meaning you could buy this info. on Ebay or take your X370 to get fixed at a shop). Vendors on Ebay are hocking this info. from $5 and on up..some are actually bidding on this stuff..DON'T DO IT! They will tell you that it's impossible to locate their "product" which consists of new capacitors and the service/repair manual. Well it took some time and research but I have located everything you need so..

Here it is and ENJOY!

1. Download the X370 manuals from http://www.geocities.com/eskoufos/fmm.html. Cost: FREE!

2. Go to http://www.digikey.com/digihome.html. The part number for the capacitor for the Minolta X370 is: P954-ND (Panasonic P/N is ECE-A0GKS221). The actual spec. on the capacitor is: 4v 220uF @ 85 deg. C(entigrade) (6.3X5X2.5 mm).Cost: $7.00 (includes S/H, min. order was 10 pieces @ $2.00 and they charge $5 for S/H)

3. Unscrew the bottom of the camera (4 little screws) and locate the bad capacitor. It's probablu bulging or leaking.

4. If you don't have one, you need a soldering pen and some standard electrical solder. (Go to Radio Shack or any Hardware store)

5. Remove the old capacitor and then solder on a new capacitor. That's it!
if you have other question just lemme know.

Sep 19, 2008 | Cameras

2 Answers

Film advance lever.


Do you press the shutter button to release the lever for the next photo? That's how you advance the film from the exposure to light, when first insterting the film.

Sep 16, 2008 | Nikon FE 35mm SLR Camera

1 Answer

LOADING FILM INTO MY CAMERA


Camera will not fire with dead battery so you will not be able to advance film to #1.......ck out www.flcamerarepair.com for help

Jun 27, 2008 | Photography

2 Answers

Film advance lever


please read the manual... u ll get the solution.

Jun 24, 2008 | Nikon FM10 35mm SLR Camera

1 Answer

LOADING FILM INTO MY CAMERA


i went to the public library and got a copy of the manual

Apr 05, 2008 | Konica Minolta Maxxum 5 Date with 28-80...

1 Answer

Minolta X370 film loading problem.


 First make sure your batteries are OK , camera will not work without two 1.5 v batteries. If your camera still doesnt work this is probably  because the shutter is cocked but you cannot release the shutter and that is why you cannot advance the transport mechanism. The shutter release mechanism needs repairing first. SREMEDY : take bottom cover off ( 4 screws ) and locate 220 mf 6v capacitor ( it is the only one in this part of the camera , cant miss it ). Replace the capacitor while you keep an eye on the polarity ( indicated on the casing of the capacitor ) and you camera should work fine ( dont forget camera needs  two 1.5v  batteries to work ! ) 

Oct 10, 2007 | Minolta X-370S 35mm SLR Camera

1 Answer

Film advance lever


Yes this is fairly common with K 1000 and the Spotmatics : although the shutter is cocked and hence you cannot advance film you cannot release shutter because mirror box is not cocked. Remedy : remove bottom cover and locate mirror box lever which protrudes slightely and is movable up and down and is spring loaded. Move upwards until it licks in position ( moving up against spring tension ). Now release the shutter and camera should let you advance the film .

Sep 17, 2007 | Pentax K1000 35mm SLR Camera

Not finding what you are looking for?
Photography Logo

Related Topics:

975 people viewed this question

Ask a Question

Usually answered in minutes!

Top Photography Experts

kakima

Level 3 Expert

101554 Answers

Tony

Level 3 Expert

2598 Answers

Brad Brown

Level 3 Expert

14742 Answers

Are you a Photography Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...