Question about Westinghouse LTV-37WI 37 in. LCD Television

1 Answer

Picture clarity My westinghouse occassionally has red and green "snow". I've tried uprading cables to HDMI and resetting factory settings with no difference. The problem comes & goes and usually if I turn off or unplug the tv for a few minutes it goes away, but usually comes back within an hour.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,554 Answers

Sounds heat circuit related, and if under warranty you should notify them before you have to pay for the tuner or sync board.

Posted on Feb 04, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a Samsung 55" LED TV (un55es6100) and the red color is flaring up. Green/Blue are perfectly normal. All other tv functions are normal. Can someone please help me figure out what to replace?


Are you using component cables or HDMI? If component, make sure your red, green and blue are pushed in all the way. Too, make sure your red audio is not the red video. If hdmi is used try a new one. If these do not help unplug your t.v for 10-20 seconds and plug it back in. All else fails reset your t.v to default factory settings.
Good luck!

Apr 04, 2017 | Samsung Televison & Video

2 Answers

I have a Teac LE3285FHD Problem with the Teac LED television I have a Teac LE3285FHD and about 10 minutes ago, as we were watching a dvd, the picture/display went all weird and now the picture/display is...


Sounds like a for sure, cable issue, especially if your running Hdmi, try switching out the cables, when it comes to color runs and weird graphics its always starts with the cable....

May 28, 2011 | Televison & Video

1 Answer

PS3 HDMI No picture nor audio


  1. Make sure the HDMI cable is connected to the HDMI OUT port on the back of the PLAYSTATION 3 system. Connect the other end of the HDMI cable into the HDMI Input port of the TV or display monitor.
  2. While the PLAYSTATION 3 system is in standby mode (red light on the front of the system), hold down the touch-sensitive power button on the front of the system until the system goes into standby mode again . (So the light cycle would go from: red light --> green light --> then back to red light). This will ensure that you have held down the power button long enough to reset the Video Output Settings.
  3. Turn on the PLAYSTATION 3 system and once the system finishes powering up, the Video Output Settings will automatically reset to the standard resolution (or detect the current display output settings of your TV/monitor).

Jun 26, 2010 | Sony Playstation 3 (PS3) Console

1 Answer

When using hdmi outlet,,,the picture comes in for 1 second then screen turns all green


That HDMI port hub it properly shorted,tries used another HMI ports hub?Tries to reset the tv back to factory setting,by unplug,replug it an hour later,go to the tv menu go to PICTURE,go down to reset.So the Tuner board reset itself back to the factory setting,all the HDMI ports hubs,should work now or that HDMI port hub is shorted,or the Tuner board it dead.

Jun 11, 2010 | Sony KLV-S32A10 32 in. HD-Ready LCD...

1 Answer

Westinghouse 47"lcd tv


are you using an hdmi cable or the red blue and green cables that came with the xbox? if using the original cables there is a switch on them that sets it to HD or standard. hope that helps

Jun 06, 2008 | Westinghouse TX-47F430S 47 in. LCD TV

1 Answer

Picture goes to a lime green fuzz and then no piture or sound!


which AV connection are you using? HDMI or the cable supplied with the PS3, If using HDMI, you have to set the PS3 visual settings to HDMI, to do this, use the cable supplied with the PS3, and have the HDMI cable plugged in. Then while using the cables supplied with the PS3, switch the settings over to HDMI, then change the TV's input selector to your HDMI and confirm the settings changes. Hope it helps take care

Oct 17, 2007 | Sony Playstation 3 (PS3) Console

1 Answer

No more picture and sound


Tv was showing perfect picture now it's snow solution 1 please check antena wire & its socket. 2 check for dust where wire is connected. 3 loose contact or print break near tuner. 4 tuner defective.

Sep 15, 2007 | Sanyo DS27930 27" TV

1 Answer

Red?Green picture


If you are connected to a HD cable box or sat. rcvr. using component cables, I would then suspect a loose or bad blue connection or cable. If you have Comcast and have their supplied flat component cable this is a common issue.

Feb 12, 2007 | Toshiba 46HM95 46" HDTV

Not finding what you are looking for?
Westinghouse LTV-37WI 37 in. LCD Television Logo

159 people viewed this question

Ask a Question

Usually answered in minutes!

Top Westinghouse Televison & Video Experts

Dave Naylor
Dave Naylor

Level 3 Expert

834 Answers

The Knight
The Knight

Level 3 Expert

72650 Answers

Jaime Hernandez

Level 3 Expert

2296 Answers

Are you a Westinghouse Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...