Question about Logitech X-540 Computer Speakers

Open Question

Wiring diagram for Altec Lansing Vs4221 Right Speaker Wire

The right speaker wire connection to the sub-woofer got damaged and in the process of amateur repairs the coloured wires got separated from the plug and now in need to know which colour wire corresponds with which pins in order to solder them together.

Thanks


I ACCIDENTALLY PULLED OUT ALL WIRES FROM THE LOGITECH X 540 SPEAKERS SUBWOOFER CONTROLER. NOW I CAN'T REPAIR IT - DESPERATELY NEED INFORMATION ABOUT THE SEQUENCE OF WIRES COLORS IN THE CONTROLER...
COULD ANYONE HELP ME?

Posted by on

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Want to use my current speakers with a new surround sound system. Current system is 5.1 channels, rated at 100w per channel @ 8. Ohms. New System is rated 145watts, 5.2 channels at 6 Ohms. Will b ok?


Hi Ronald.
8 Ohm speakers will work just fine as replacements for the
6 ohm speakers. When fitting speakers you need to consider
The power handling capability. The impedance and the frequencies
involved. Power handling is expressed in wattage ie 100W.
Unfortunately this can be expressed in rms, max or peak music. The rms value (root mean square) is the only really relevant figure as this is the continuose handling power at 1 KHz. The impedance
is the resistance that the amp sees but is not a dc resistance and
varies with frequency. The lower the impedance the more power
will be drawn from the amp. In the event of a short circuit across
the speaker the amp will try to deliver infinite power into an infinitly
small load in an infinitesimal amount of time and will self destruct.
Using an 8 Ohm speaker draws less power than a 6 Ohm speaker.
Connecting speakers in parallel; results in the impedance beingreduced. For example two 8 Ohm speakers in parallel will result
in a 4 Ohm impedance load but in series will be 16 Ohms.
Incidentally the the .1 (5.1) is the sub woofer which only has
to handle the bass frequencies, a small percentage of the
amplifiers overall frequency response..
Connect your speakers and then power up the amp last
after double checking there are no shorts on the speaker
cables.
All the very best from Vintie.





Jan 07, 2017 | Audio Players & Recorders

1 Answer

T612 Altec Lansing ipod player. The connector where the ipod sits is loose. Ipod wont stay.


The connector needs refitting , screwing in or replacing.
ELECTREPAIRUSA@ELECTREPAIRUSA or you can contact us at that address as we repair/renovate all items electronic and electrical old and new.

Jan 06, 2017 | The Audio Players & Recorders

1 Answer

T612 Altec Lansing - the connector to the ipod is loose


Take it to a repair shop and have a new part installed.

Jan 06, 2017 | The Audio Players & Recorders

1 Answer

Altec Lansing 2100 Controller. My controller's power button is intermittently not working. Anyone know if this is an easy fix or have a controller to sell?


Test the remote control for its infrared emission. To get more details about how to check a remote control, visit the site linked here.
http://homenol.blogspot.com/
http://electronicshelponline.blogspot.com/

Jan 06, 2017 | Altec Lansing Audio Players & Recorders

1 Answer

How do I remove the speaker that is held in place by plastic circle that has been melted in certain spots over the edge of the speaker.


You can just use some snippers carefully then when you replace it either use gorilla or a glue gun.
ELECTREPAIRUSA@ELECTREPAIRUSA or you can contact us at that address as we repair/renovate all items electronic and electrical old and new.

Feb 06, 2016 | Audio Players & Recorders

1 Answer

My radio makes popping sound when on for about 20minutes but when i turn volume up it stops but sound is disorted.any ideas on problerm


Sounds like there's wires touching and it's grounding to its self or there's a bare wire rubbing on body. Check all speaker wires in trunk or back to which are the ones easiest to vet messed up

Jan 09, 2015 | Audio Players & Recorders

2 Answers

I have a Rowe R80 jukebox and after moving it it has no sound through the speakers I am in New Zealand


Well, in addition to all the fine suggestions that are here, I would like to add the simple and easy things that may have happened during the move.

IF YOU ARE NOT GETTING A LOUD POP WHEN THE MACHINE IS POWERED ON.......

1) Make sure that the wires on the terminals below are still connected to the screws. There is one ground and one each for left and right. The lower the tap the lower the (max) volume of the jukebox.If they are not connected there will be no sound.
84c9065c-b7c6-4417-be21-0be7a6e74b41.jpg


There is a jumpers on the terminal strip where the volume control connects. Make sure that these connections are correct and tight. Also make sure that the jumpers did not fall off.
c1d72051-525d-47ec-8725-a6a8e655b20c.jpg
7a25e260-d39b-4992-8bce-8c2d2c9b07e5.jpg

If you are getting the loud pop in the speakers when the power is turned on .....

Check the plug on the side of the mechanism, just below the back of the tone are.(looks like a little tube socket) Check to see that it is connected to the mech and the CORRECT PLACE on the amplifier. It mat be possible to have this end in the wrong place. bf77613e-82a3-4e37-b8fe-cc80f4d4dbcb.jpg

Check all all your connections against the pic.

I hope this was helpful.

Mar 24, 2014 | Audio Players & Recorders

1 Answer

It wont turn on, it shows 'push power protect' when you turn it on, or disconnect it and reconnect, i already attempted to disconnect the Sony Stereo MCH-EC909iP Mini Hi-Fi and it shows 'Push Power, P


The only thing I can think of is its goin into protection mode like an amplifier would, you maxed the volume out and it's protecting your speakers or you don't have the right voltage going to it, I can see you don't have it on a straight 120v plug and you might have the wiring wrong on the speakers to it might be too low of a ohm or too high

Nov 22, 2012 | Audio Players & Recorders

2 Answers

Altec Lansing ADA 880 Toroidal Transformer Replacement


Did you solve this? Cause I have the same problem and need some advice...

~Brian
bwalker1978@yahoo.com

Mar 23, 2009 | Altec Lansing ADA 880 Computer Speakers

3 Answers

Front two speakers not working at all


Hit the the speakers A/B/Off button on the receiver. If you plugged the front channels speaker wire next to the center channel on the back of the receiver make sure its showing B. If you plugged them in the banana plug part, make sure its showing A.

Apr 12, 2007 | Audio Players & Recorders

Not finding what you are looking for?
Logitech X-540 Computer Speakers Logo

1,233 people viewed this question

Ask a Question

Usually answered in minutes!

Top Logitech Audio Players & Recorders Experts

kakima

Level 3 Expert

100340 Answers

sonic boom...
sonic boom...

Level 3 Expert

1557 Answers

masterwest

Level 1 Expert

45 Answers

Are you a Logitech Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...