Question about Technics SUV500 2-Channel Amplifier

1 Answer

Technics SUV500 problem in stand-by

The suv-500 in stand-by (led light) make sound "click clack continued" with led operation lighting intermittence (blinking).
The suv-500 in On is in normal condition led's (led stand-by off and led operation light).
The problem is "RL751" ? I can change this?
Excuse for my bad English!!!

Bye Davide De Luca

davedl@tin.it


Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 4,234 Answers

The problem is not the relay. The unit is trying to start, but detecting a problem and shuting down again. Check the output transistors for a shorted condition.
Dan

Posted on May 19, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I need an Operator Manual for a Technics Amplifier SU-600


HI,
I have the User manual of Technics SU-600 in pdf format. If you can sent your email address the i will sent you the manual.Its not possible to sent the manual through this site as it is a pdf file.
OK

Oct 26, 2011 | Technics SUV500 2-Channel Amplifier

1 Answer

How must I connect the amplifyer V500 with my computer for recording from a tape player?


I assume you want to record from tape to computer and monitor the recordings later.
Simple three steps.
1) Connect the tape deck line out ( or labeled PLAY ) to any one of the inputs like Aux / Tuner using an 2RCA connector.
2) Connect Rec out from the SUV' to line input of your PC ( blue socket ) sound card.
3) To monitor your PC sound after recording on to Hard Disc , connect a cable between the PC sound out ( green socket ) and the the SUV Tape monitor IN ( sometimes labeled PLAY ) Now comes the tricky partbobhifi_30.jpg.When you want to record on to your PC put the source switch on the SUV to where you have connected the Tape deck ( Aux / Tuner ). On the SUV keep the Tape Monitor switch to source ( released position ). After having done the recording to monitor and hear the Hard Disk playback turn on the Tape Monitor switch ( dipress it ). The pressing of the Tape switch on the SUV lets you toggle between the source and recording - In your case Tape deck and PC

Mar 31, 2011 | Technics SUV500 2-Channel Amplifier

1 Answer

Hallo, i have a problem with Technics SUV500 , so stand by lamp is allways ON , and everything is DEAD . Thank you for help.


Hi
if the standby lamp is on it means that the protection unit is on it will not let you power on the Amp
its an hardware failure and need to be fixed
if you want to fix the Amp let me know
ecrdn@yahoo.com

Jack

Oct 17, 2010 | Technics SUV500 2-Channel Amplifier

1 Answer

I have a Technics Stereo Receiver SA-GX 500. There is very little sound coming out of all the speakers (A and B) as well as the headphone jack. I have made sure that the speaker button is depressed (A, B...


All sources or just one? Make sure the Tape Monitor isn't engaged unless you're using an external tape deck or processor. A turntable will only work on the PHONO input.

Aug 08, 2010 | Technics SUV500 2-Channel Amplifier

1 Answer

SUV500 2-Channel Amplifier: Hi! can I connect another technics cd-player,sl...


yes you can connect another cd player to the DAT input of your amp.
input connections like DAT, TUNER, CD, AUX etc (except phono) is just to differentiate between what sources are connected, the amp cannot tell what source is connected and will output the sound no problem.

as for the remote operation, if the 2 technics cd players are switched on at the same time they're going to do what you command from the remote together but you'll obviously be listening to 1 at a time.

May 17, 2010 | Technics SUV500 2-Channel Amplifier

2 Answers

Sound cuts when volume is turned up


check that power amplifier rating(how many watt)must be more than total speaker rating by 20% at least..
exampel:if speakers watts are 100 watt-amplifier watt must be 120 watt.

Mar 14, 2008 | Technics SUV500 2-Channel Amplifier

2 Answers

Technics SUV500 Amplifier


check volume balance between right and left-then change inter connection between sound source and amplifier with new cabel(i prefer gold plated type connectors)(see radio shack).
after that if the problem excit your fault in output transistors or output stereo ic depend on circuit design.

Feb 17, 2008 | Technics SUV500 2-Channel Amplifier

Not finding what you are looking for?
Technics SUV500 2-Channel Amplifier Logo

Related Topics:

323 people viewed this question

Ask a Question

Usually answered in minutes!

Top Technics Amplifiers & Preamps Experts

 Grubhead
Grubhead

Level 3 Expert

4590 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Electro Med Services...
Electro Med Services...

Level 3 Expert

5653 Answers

Are you a Technics Amplifier and Preamp Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...