Question about Phoenix Gold Ti600.2 Car Audio Amplifier

1 Answer

Interference my door speakers are ran to an eclipse amp... they have always worked fine...i just bought a phoenix gold ti 600 and when i have this amp on.. my door speakers crack like if theyre blown... but when i disconnect the rca's from the ti 600 my door speakers are perfectly fine... any ideas?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 10 Answers

How many watts is the amp and speker are you sure you are not putting too much?

Posted on Feb 02, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Can i use a 300 watt amp for 2, 800 watt woofers


yes, but you would not get the same performance as you would if you gave them the suggested power. I have found that it is always better to use a more powerful amp than your subs are rated for (as long as it is clean, high quality, low distortion power). I have had the best luck with name brand amps (kicker,rockford fosgate,phoenix gold,etc...). I hope this will be helpful to you.

Jul 30, 2012 | Phoenix Gold Xenon X10D4 - 10" D4...

2 Answers

My phoenix gold x200.4 amp turns on but the protect light keep on flashing


  • What does it mean when the LEDs flash on my amplifier?
    With most recently produced Phoenix Gold amplifiers, a flashing/blinking LED is an indication that the unit is in protect mode, usually due to an overcurrent condition caused by an internal short, external short (speakers), or low impedance. Overheating will also cause the amplifier to shut down temporarily.

    If amplifier remains in protect mode, power down the amplifier, disconnect the speakers, and power up again. If LEDs continue to flash, there is probably an internal problem with the amplifier that will require service attention to fix.
  • Sep 23, 2010 | Phoenix Gold ZX600ti Car Audio Amplifier

    1 Answer

    Phoenix gold ti 12d sub gets hot shuts off amp


    Depending on your location most places will replace certain things. You may try and see if your sub has any type of warranty. But yes I do believe it would be consistent with a voice coile being bad.

    Oct 27, 2009 | Phoenix Gold Ti12D Car Subwoofer

    1 Answer

    I have a phoenix gold ti 1000.2 amp.. this is such a great amp and its hard to find.. the problem is when the bass hit i thought i blew the amp.. no bass comes from the amp anymore but the amp turns on and...


    are you sure its grounded good and are you sure the amp is on or do you know for sure its the amp not the sub to see if its the amp just just wire it to an old speaker not a subwoofer and be sure to switch the lpf off

    Jul 30, 2009 | Phoenix Gold Titanium 1000.2 Car Audio...

    1 Answer

    I have amono 600.1 amp


    if its mono there is nothing to bridge

    Jul 12, 2009 | Phoenix Gold XENON 600.1 600 Watt...

    1 Answer

    How to hook up led lights for phoenix gold x10d4 speakers


    THERE ARE 2 WAYS:

    1. (STEADY ON) - RUN THE POWER FROM THE AMP TO THE POSITIVE LED TERMINAL THE NEGATIVE CAN BE RAN FROM THE NEGATIVE SPEAKER TERMINAL.

    2. (INTERMITTENT; COMES ONE EVERY TIME THE BASS HITS) - RUN THE POSITIVE AND NEGATIVE WIRES FROM THE + AND - TERMINALS TO THE POSITIVE AND NEGATIVE TERMINALS OF THE LED LIGHTS.

    LET ME KNOW IF THIS WORKS FOR YOU -- CADILAC00@HOTMAIL.COM

    Mar 15, 2009 | Phoenix Gold Xenon X10D4 - 10" D4...

    1 Answer

    Phoenix Gold TI500.4


    Your amp is either going into thermal protection mode or one or more of your speakers is shorting out.

    May 18, 2008 | Phoenix Gold Ti500.4 Car Audio Amplifier

    1 Answer

    Need help with the wiring on amp to subs


    http://www.rockfordfosgate.com/rftech/woofer_wizard.asp?submitted=true&woofer_qty=3&woofer_imp=4 DON'T FORGET MY FIXYA RATING!

    Mar 09, 2008 | Phoenix Gold R15.0:1 1500W Octane-R Mono...

    Not finding what you are looking for?
    Phoenix Gold Ti600.2 Car Audio Amplifier Logo

    Related Topics:

    58 people viewed this question

    Ask a Question

    Usually answered in minutes!

    Top Phoenix Gold Car Audio & Video Experts

    Matthew Spark
    Matthew Spark

    Level 3 Expert

    1066 Answers

    Jose Velazquez
    Jose Velazquez

    Level 2 Expert

    227 Answers

    Jeffery Lewis
    Jeffery Lewis

    Level 3 Expert

    316 Answers

    Are you a Phoenix Gold Car Audio and Video Expert? Answer questions, earn points and help others

    Answer questions

    Manuals & User Guides

    Loading...