Question about Phoenix Gold Ti600.2 Car Audio Amplifier

1 Answer

Interference my door speakers are ran to an eclipse amp... they have always worked fine...i just bought a phoenix gold ti 600 and when i have this amp on.. my door speakers crack like if theyre blown... but when i disconnect the rca's from the ti 600 my door speakers are perfectly fine... any ideas?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 10 Answers

How many watts is the amp and speker are you sure you are not putting too much?

Posted on Feb 02, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hooking up my phoenix xs 2200 car amp


red wires go to ur battery and speaker wires go from back of amp to back of sub and there should be a cable that goes from the head unit to the back of the amp.

Mar 07, 2012 | Car Audio & Video

2 Answers

My phoenix gold x200.4 amp turns on but the protect light keep on flashing


  • What does it mean when the LEDs flash on my amplifier?
    With most recently produced Phoenix Gold amplifiers, a flashing/blinking LED is an indication that the unit is in protect mode, usually due to an overcurrent condition caused by an internal short, external short (speakers), or low impedance. Overheating will also cause the amplifier to shut down temporarily.

    If amplifier remains in protect mode, power down the amplifier, disconnect the speakers, and power up again. If LEDs continue to flash, there is probably an internal problem with the amplifier that will require service attention to fix.
  • Sep 23, 2010 | Phoenix Gold ZX600ti Car Audio Amplifier

    1 Answer

    Can i hook up a powered 12'sub to a Pheonix Gold xs2500 amp without blowing the speaker


    First I hope you remove the speaker wires from the speaker that come from the built in amplifire. You cannot hook the powered sub to the amp without doing that first. Then all you need to do is run speaker wire from the sub out of the box to the amp. In no way can you hook up any other part of the powered sub, but the sub itself, to the amp. If you know the wattage of the sub and the ohms then wire it to the amp correctly. Your phoenix amp will put out 125 watts x 2 at 4 ohms and 250 watts x 2 at 2 ohms and 500 watts x 1 at 4 ohms bridged. Remember, only the sub itself in the sub enclosure can be connected to the amp. Hope this helped you. Let me know if you need more help.

    Aug 23, 2009 | Phoenix Gold XS2300 Car Audio Amplifier

    1 Answer

    I have a phoenix gold ti 1000.2 amp.. this is such a great amp and its hard to find.. the problem is when the bass hit i thought i blew the amp.. no bass comes from the amp anymore but the amp turns on and...


    are you sure its grounded good and are you sure the amp is on or do you know for sure its the amp not the sub to see if its the amp just just wire it to an old speaker not a subwoofer and be sure to switch the lpf off

    Jul 30, 2009 | Phoenix Gold Titanium 1000.2 Car Audio...

    1 Answer

    Using JBL 4410 3-Way crossover, trying to use PG 12" Dual 4-ohm


    ok, connect the amp positive to the positive end of one sub coil, take the negative of that coil, and run it to the positive of the second sub coil, then run the negative out of the second sub coil to the negative of the amp.

    Mar 29, 2009 | Phoenix Gold Octane-R 15.0:1 Car Audio...

    1 Answer

    Phoenix Gold TI500.4


    Your amp is either going into thermal protection mode or one or more of your speakers is shorting out.

    May 18, 2008 | Phoenix Gold Ti500.4 Car Audio Amplifier

    1 Answer

    Need help with the wiring on amp to subs


    http://www.rockfordfosgate.com/rftech/woofer_wizard.asp?submitted=true&woofer_qty=3&woofer_imp=4 DON'T FORGET MY FIXYA RATING!

    Mar 09, 2008 | Phoenix Gold R15.0:1 1500W Octane-R Mono...

    1 Answer

    Wiring my subs to my amp


    bridge it and rear channel if you need to know how to bridge let me know

    Feb 07, 2008 | Phoenix Gold Octane-R 15.0:1 Car Audio...

    Not finding what you are looking for?
    Phoenix Gold Ti600.2 Car Audio Amplifier Logo

    Related Topics:

    58 people viewed this question

    Ask a Question

    Usually answered in minutes!

    Top Phoenix Gold Car Audio & Video Experts

    Donald DCruz
    Donald DCruz

    Level 3 Expert

    17129 Answers

    Larry Spears
    Larry Spears

    Level 3 Expert

    625 Answers

    Matthew Spark
    Matthew Spark

    Level 3 Expert

    1066 Answers

    Are you a Phoenix Gold Car Audio and Video Expert? Answer questions, earn points and help others

    Answer questions

    Manuals & User Guides

    Loading...