Question about Jl Audio 500/1 Car Audio Amplifier

1 Answer

Jl 500/1 My green light is on but no power to my subs i hooked it up to a different set of subs and still no power my amp smells a little funny like a burnout or something but i dont know much about this stuff give some advise please

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 43 Answers

Nine times out of ten if the amp smells burnt it usuallly is. Your best bet is to hook another amp to your system and see if you get sound.

Posted on Jan 30, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Have a jl audio 500/1 the red light blinks and no other light turns on. whats the problem with it?


I think you might have your remote turn on from your deck to amp hooked up wrong check that out!! I not are you familliar with the mr. butterworth crossover JL developed for that series of amp? Just like its big nrother the 1000x1 class D the built in smart crossover has many built in pretect modes. If your subs are drawing to much power it shuts down if they draw to little of ohms or to many but that 500 is 1 ohm stable so download the crossover settings from JL and go from there

Apr 28, 2012 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Installin car systems


you dont want to connect both of those amplifiers together. You could run them separately to separate subs or the jl to your sub and your alpine to your front speakers. But you dont ever want to mix and match amps to the same sub. Even if you had 2 jl500/1's you wouldnt want to just hook them up together. Because they both have to be putting out the exact same amount of power. Which no 2 amps are ever exactly the same. Some companies make bridges to properly connect 2 exact amps together. I Hooked up 2 JL 1000/1's to each voice coil on a 13.5 W7 and i smoked the sub. So i definitely dont reccommend doing it unless the amps are conneccted to separate things.

Apr 28, 2010 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

My Jl Audio 500/1, power light comes on but no power to subs


maybe it dont have enough to push it ,,did you try it before you buy it?

Mar 01, 2010 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Green power light on JL Audio 500/1 but no output


Its the power transistors that would be affected by low voltage. It delivered till it finally gave up 'cos the output wattage to be generated at low voltage means more current flowing through the equipment. This high current will adversely affect all small solenoid valves & transistors and IC's. Even failure of one section of any IC is rarely detectable with the naked eye. It has to be thoroughly checked with a multi-meter to assess the damage correctly......sodeep

Jul 30, 2009 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Jl audio 500/1 amp low ohm light at high volume


I would try running the subs in parallel. Pos to Pos Dual Voice, Neg to Neg Dual Voice. Then Run + to + stereo - to - stereo on both channels.
So you have + and - running to one channel and + and - running to the other channel.
Also your LPF filter could be set too high.

Feb 07, 2009 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

If my jl amp e1200 is on green, but no power is going to the sub


your audio wires from the head unit have been pinched or discontected or the head unit is not putting out a signal

Nov 29, 2008 | Jl Audio E1200 Car Audio Amplifier

1 Answer

I bought a 500/1 jl audio amp and also a w7 10 sub


if its cutting off and right back on then check your ground and your power wire makes sure both are connected good and none of your fuse's are blown, either that or you got a wire hooked up backwards in the sub.. but my guess is that the sub is hooked up wrong... that sub should be hooked up in a series or in parallel,

ok if your running just one speaker, it should be hooked up like this and 2 speakers are a different way...

this is parallel :pos to pos , neg to neg, then one wire coming from pos on sub to pos on amp then neg on sub to neg on amp but bridge the amp on your amp should be 2 pos and 2 neg in two different channels take the pos off the sub into the pos on 1 channel and then the neg from sub to the neg on the other channel,

this is series : on the sub it will go pos to neg then the other neg and pos will go to the amp, but make sure the pos and neg r on different sides of the sub, dont hook them both to the same coil

if your need more help give me your email and ill send you a pic of how to do it...


Aug 12, 2008 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

500/1 sub amp stopped working, burnt rubber smell


It sounds like the power supply failed. Generally when the supply fails in that amp, you have to replace all 8 of the power supply FETs and all 8 of the 47 ohm surface mount resistors. Many times, the supply fails because one or two of the output transistors have failed.

If you want to have JL repair it, you MUST go through an authorized JL dealer.

If you have a good local repair shop, they should be able to repair it.

Let me know if you have any other questions.

Aug 06, 2008 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

No sound


if tghelight is green the power is there...but themost common problem s power return..meaning that you might have a bad ground. i wouldsuggest inspecting your ground cable..it should be 6awg minimum and make sure that its grounded to either the frame or negative battery terminal. nothing painted and nothing that doesnt eventually connect to the frame.

Sep 03, 2007 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Jl 500/1 no sound, green light


This is an indication that the MOSFETs are ok but the driver stages may have a problem. Get a schematic find the pre-amp stages and test the voltages levels there as compared to the schematic. I do believe that you will find the problem in the pre-driver pre-amp atages.

Sep 03, 2007 | Jl Audio 500/1 Car Audio Amplifier

Not finding what you are looking for?
Jl Audio 500/1 Car Audio Amplifier Logo

Related Topics:

202 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jl Audio Car Amplifiers Experts

matthew walsh

Level 1 Expert

69 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1042 Answers

Are you a Jl Audio Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...