Question about Bissell 8910 ProHeat Clear View Upright Vacuum

3 Answers

Won't spray. . .nothing happens when pull trigger. . .pump belt is ok. ..

Checked out the troubleshooting on the Bissell.com site and it didn't solve it. no obvious broken parts. seems to have "lost its prime" on the pump but turning it off for a minute doesn't solve the problem.

Not spraying either when we try the handheld attachment. Seems to be a related problem. I've wondered if the portable bucket is seating tightly enough to draw water out of the bucket valve

Posted by on

  • 4 more comments 
  • flag1aa Mar 19, 2008

    I have had three of these machines in less than a year. The first one the pulley
    separated from the pump, just spin on the shaft. Second one the pulley broke in two pieces and now the third one the pump is frozen and the belt melted in two.



  • Anonymous Apr 06, 2008

    my machine isn,t putting out any water or cleaning solution

  • sp1235 May 09, 2008

    No water or soap spraying. Belt not broken but not turning when on.

  • tomanypets Jun 14, 2008

    Won't spray....it's running, just not putting out any water. Belts okay, valve okay, hoses clear...not sure how to fix.

  • crissy1 Dec 18, 2008

    Also the same problem- only used machine 6 times- UGH!!! When I pull trigger nothing comes out of the machine, or the hose attachment- Rollers are turning, hoses are clean, all the rubber pieces are in good condition- ???? HELP!! I guess I am going to replace the pump, don't know what else to do???



  • Asst Apr 06, 2009

    also cleaned the filter & it still does not work

×

3 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 126 Answers

I assume you've changed the flat belt and it's working o.k. So, the next thing to check is the bucket seat. When the bucket is set down into the machine, the bucket valve is opened by the center pin on the receiver in the floor of the machine. You should put clean water into the bucket and install it. Wait a couple of seconds and remove it. Inspect the receiver and see if there is any water in it. If not, check the valve in the bucket and make sure that the rubber seal is in place. Sometimes they come off and stay stuck in the receiver. This will not allow the valve to open. If the seal is stuck in the receiver, remove it and re-install it on the bucket valve and test again.
By the way, if there is no shampoo in the shampoo tank, and the mixture dial is set anywhere but off, the machine will not spray. The pump will suck air through the empty tank and will not pick up water from the main tank.
If there is water in the receiver after you remove the bucket, then the problem is likely in the heater. The heater is located in the center of the handle and you must open the handle by removing the hose storage rack and then the top of the handle. There are two screws behind the hose holder that are at the back/bottom of the handle and are recessed into the handle. Once the handle is open, the heater is obvious. You will find two clear hoses attached and they often become plugged at the connections, just inside the heater. You can clear this with a 1/8" drill bit. Remove the hoses and take the bit in you hand and gently insert and rotate. Once cleared, replace the hoses and reassemble. I hope this helps. Be careful. These machines are a maze of hoses and valves and can be difficult to reassemble. Be very observant whenever taking one apart.
One more thing. I have seen instances where the screws that hold down the hood in the area of the tank have broken through the plastic and will lift enough that the tank will not sit down far enough to allow the valve to open. Check here, too.
I hope this helps.

Posted on Jan 31, 2008

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 13 Answers

Had somewhat the same problem.... I had water comming out but the solution was not comming out.... I called bissell and the woman talked me through it.... first put in water only mode,,,,, then Fill water tank with fresh water and put back in place,,,, then remove soap dispenser put to the side,,,, now , power on your cleaner,,,, for the next steps, do this exactly as I tell you >>>>>>hold down the trigger that releases soap the whole time you do the following>>>>>> switch between water only and heavy traffic four times,,,, all while while holding the trigger, then still holding the trigger, stop on high traffic the fourth time, leave it there,,, now put the soap bottle back in,,,,, still holding the trigger and hold the trigger down for exactly one minute after you replace soap bottle,,,, you should start seeing the soap come out........ (make sure its on floor cleaning and not TOOLS) Hope this helps and if it does,,,, give these instructions to someone else in this help area.........

Posted on Jul 30, 2009

  • Vicky
    Vicky Oct 26, 2014

    should it be on or off?

  • Vicky
    Vicky Oct 26, 2014

    Never mind. It still didn't help. I was trying to memorize the steps.

×

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I had to ues a .110 drill bit into the inlet of the heater.

Posted on Feb 03, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Bissell pro heat wont spray water


Hi, it's Allie from Crucial Vacuum!

Your Bissell ProHeat 25A3 may have stopped spraying water for several reasons. Make sure the bladder or water tank of your unit is filled with water properly and that the 2-in-1 tank has been placed properly.

If the water tank/bladder is filled and the 2-in-1 tank is placed properly, your unit's pump may have lost prime, to check this turn your unit's power off and hold spray trigger for 30 seconds. Turn the machine back on and check the spray flow.

Another thing that may not be allowing your unit to spray properly or spray at all is having a clogged solution filter and may need to be cleaned.

Last, your unit's pump belt may be broken. To replace, turn off your unit and unplug from any electrical outlet. Use a flat head screwdriver into the slot of the belt access door to release where you should have access to your unit's pump belt.

You can purchase direct your replacement belts from Crucial Vacuum with free shipping and an exclusive 10% coupon for Fixya.com readers, use code: FIXYA10

http://www.crucialvacuum.com/bissell-proheat-2x-belts-2pk.html

I hope this was helpful. If you would like further assistance, please feel free to give us a call at 877.750.9239. We have helpful and friendly customer care representatives on the line ready to assist you.



Alejandra (Allie) Sepulveda-Rivera
Crucial Vacuum Customer Care
http://www.crucialvacuum.com

Oct 05, 2014 | Bissell Pro Heat Deep Cleaner Model 25A3,...

1 Answer

Bissell flip-it select won't spray clean solution


I'm sorry to hear about the spray issue you're experiencing.

Here's a quick link to troubleshooting steps to assist you:

http://www.bissell.com/FAQDetail.aspx?id=1237&cid=ccsocial

Mar 07, 2013 | Bissell Flip-It Select Hard Floor Cleaner...

1 Answer

No water comes out when trigger is pulled


Hi Karen! Sorry you're having difficulty with the spray on your CleanShot. Here's a quick link to troubleshooting steps.

http://www.bissell.com/faqs/?c=282&sc=304&searchtext=no%20spray&cid=ccsocial

Dec 30, 2012 | Bissell 9500 ProHeat 2X CleanShot Upright...

2 Answers

Bissell 7920 cannot discharge cleaner solution


go to the web page instructional video and maintenance help for troubleshooting.

God bless you
http://www.bissell.com/how-to-videos/

Jul 19, 2012 | Vacuums

3 Answers

Biseell little green machine wont squirt water out


The Pumps on these go bad after a couple of months. They rust and will sometimes spray and other times not then eventually not work at all. If your a handy man pull the top off it and remove the pump motor and replace it yourself. The part number is 603-5029 you can put this number in google shipping and get it to your door for about $15 and replace it yourself or have a friend do it. Ebay has tons of them once again just put in the part number and a list of them will come up.
Thanks and have a good one
Sincerely, CRTN

May 22, 2010 | Bissell THE BISSELL LITTLE GREEN MACHINE...

2 Answers

Won't spray wate rwhen you press trigger.


When the water won't dispense that usually means that the pump belt is usually stretched or broken. Here is a link to the belt you need and a manual you can view:

Bissell 7920 Belt and Manual

Dec 03, 2009 | Bissell 7920 ProHeat Pro-Tech Upright...

1 Answer

Bissell Proheat only sprays for a few seconds.


When was the last time you changed the flat belt? Even if it isn't broken it could be so stretched out that when the brush hits the floor it slows or stops the pump from spraying. If its a new belt then and your sure there arent any clog's that usually means the pump is bad. Also if youve ever used anything other than bissell shampoo in the machine it could have ruined the pump as well.

Sep 15, 2009 | Bissell 7901-1 ProHeat Scotchgard Upright...

3 Answers

Bissell 7920-E; No spray.


I have a similar problem and `phoned Bissell support. They told me that no spray is either a failed drive belt or a failed pump. I suggest you remove the belt access cover and see if the belt is intact; if so rotate the pump using finger pressure - it should rotate easily with no unusual noises.

If this is all OK, fill the bucket and the mix bottle with warm, clean water. Turn the machine on and with the handle upright press and hold the trigger for about 2 minutes. Hopefully you should see a spray and both the bucket and bottle will reduce in volume. If not you have either a blockage in one of the tubes, the trigger valve needs adjustment or, worst case, the pump has failed.

Hope this helps.

Jun 06, 2009 | Bissell 7920 ProHeat Pro-Tech Upright...

1 Answer

Won't spray


Ensure you have water in tank and solution (or water in solution tank). When you start the vacuum up, the pump starts to prime itself. If you have air in the system, it takes a little longer to prime. Allow the vacuum to run for 1 minute before attempting to pull the trigger. Then pull the trigger.
If this doesn't work, you'll need to open the unit up and check the hoses for any clogs, and next test the pump to see if it is functioning.

Mar 10, 2009 | Bissell 9200 Upright Vacuum

Not finding what you are looking for?
Bissell 8910 ProHeat Clear View Upright Vacuum Logo

1,469 people viewed this question

Ask a Question

Usually answered in minutes!

Top Bissell Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18333 Answers

Roger Potts

Level 3 Expert

694 Answers

Brad Brown

Level 3 Expert

13819 Answers

Are you a Bissell Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...