Question about Car Amplifiers

2 Answers

Lanzer vibe 416 1000watt Amp stay in protection mode completey

I brought lanzer vibe 416 1000 watt amp from the lanzer company. In the first months of having it, it worked fine with the two 12's that i had. Then i upgraded to two 15's kickers and the amp started doing crazy things. I dont use the amp to push the 15's just my inside speakers. I had it up a little one day and it just went out. After taking one channel out it came back on but when i locked or unlock my doors (eletronic) the amp went back into protect mode. As weeks went on i didnt play any mind to it, untill today when i guess the last two channel went out. My questions are. Would two much rattling cause an amp to go bad or what would cause the amp to do that? What would you recommond doing? How would i get it out of protect mode when nothing in any channel? Thank you if you can help me.

Posted by on

  • kmoney1988 Jan 31, 2008

    I figure it out after playing with it. I didnt use the amps to push the subs.(sorry for not putting that) I used it to push my inside speakers and it was on the back of a boxs with two 15's and they were hitting so hard that it cause the inside of the amp component to shake loose and the channels to go out. So imma send it back and get a new one and that should fix my problem, but thanks for trying.

  • YUEXIANG01 Mar 14, 2009

    Dear Sirs or Madam,

    We Yuexiang Eletronic co., ltd. Was founded in Guangzhou.China.In the year 2001.we specialized in all kinds of game parts&accessories for ps1, ps2, ps3, psp, pspslim, psp3000, nds, ndsl, ndsi, xbox, xbox360. main products are laser lens, modchip, lcd screen, touch screen, main boards, flash cards, memory cards, and the little repair parts. Please feel free to contact us either by e-mail or msn.We are looking forward to hearing from you!

    Best regards
    Peggy

    E-MAIL:yuexiang01@yahoo.cn
    MSN:Webmaster-21tvgame02@hotmail.com
    Website: www.21tvgame.com
    Tel:+86-20-22080558
    Add:No.1808,New Asia Internation&Digital Electronic building, Guangzhou,China.

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I'm no pro but I've fixed a few amps in my time.When you had the 12's hooked up it was working fine you say,but when you upgraded to 15's is when the problems started. You probably bridged it too low of ohms and it maxed the amp out,it got too hot and started to burn up the channels. all that matters when you buy speakers and amps. The 12's was probaly 4 ohm coil speakes and the kickers are 2 ohm. The kickers bridged together positive to positive, negative to negative would bring it down to 1 ohm load witch I dought the lanzar can handle. If your a fix it yourself kind of person like me. I can point you in the right direction on where to looke for parts to fix your amp....

Posted on Jan 31, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

We mainly supply many kinds of IC and laser pickup such as SF-DS20, SF-DV21, TOP-1200, SF-HD62, SF-HD6, PVR-802W, PVR-502W,SF-HD80, KSS-240A, KHM-240AAA, PVR-302S, DAX-23E, SF-HD4, SF-C93, HOP-1200W.....use for CD, VCD, DVD player, PS2/3, laptop, AUTO...
dora_component@hotmail.com

Posted on May 19, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

The Ground wire is hooked up right but the red light wont go off and stay green so the amp will work. It is very frusterating all the cables are the right size its is a 1000 watt amp. I have two 500 watt...


Sounds to me like the amp is going into protection mode. Try placing one sub on the amp with very little gain. One of the biggest reason why this happens is because the subwoofers are wired wrong. What is the brand and model number for your amp?

Apr 14, 2011 | Car Amplifiers

2 Answers

Lanzar 800 watt amp protect mode stays on


protect mode usaully means that something has disrupted the power of feed lines to the subwoofer/speakers possibly fuse is blown in amp or amp is blown in which we hope not. see if you have a warrenty if blown and send back or bring it to where you purchased it from.

Aug 01, 2009 | Lanzar VIBE266 Car Audio Amplifier

2 Answers

How do I fix the problem so they work again.?


A 1000 WATT AMP HAS PROBABLY GONE INTO PROTECTION MODE BECAUSE YOU ARE TRYING TO RUN 1600 WATT SUBS COMBINED

Jun 08, 2009 | Car Amplifiers

2 Answers

Lanzar amp 1000 watt stays on protect mode


Hello snow11879,

I haven't been able to locate any support information online about your product, other than the email contact for support questions:

support@lanzar.com

If the amp stays in protect mode all of the time, I would suspect a short in the speaker wiring or speaker(s) voice coil(s), or perhaps a faulty ground. If it plays for a short period of time and then goes into protect mode, it is most likely overheating. First check all of the wiring. Test your speakers on a known good amp and make sure there are no places in your wiring where the insulation may have been damaged, causing an intermittent problem.

Many owners have reported that this particular amp has a tendency to overheat. Also, when run in bridged mode, the speaker impedance needs to be at least 4 ohms. It will overheat if the impedance is below 4 ohms.

Hope this helps.

Apr 18, 2009 | Lanzar VIBE266 Car Audio Amplifier

1 Answer

Soundstorm amp


do you have a model #?
The MAX PRO is the only one rated @ that power.
Let me know, and Ill look it up!

Jan 08, 2009 | Lanzar Vibe 218 Car Audio Amplifier

2 Answers

Protection mode?


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty. Double check your connections. .A thumbs up would be greatly appreciated if this answer is helpful to you. protection-mode-shonxoarcym4awy4zl1imx4o-2-0.jpg Lanzar

May 25, 2008 | Lanzar Car Amplifiers

2 Answers

Lanzar Vibe 1200D protection light


You will need to show it to a service technician as it seems the output section has blown so it remains in protect mode. One reason (could be) that the input to the amp was high and may have been clipping for some time before the amp decided it could take it no more

Jan 14, 2008 | Lanzar Vibe 1200D Car Audio Amplifier

1 Answer

Audio bahn 1205n


sounds like your over working your amp 800 watt on a 2000 watt sub. might wanna upgrade your amp

Nov 28, 2007 | Lanzar 2H 1000W MOSFET AMP Car Audio...

1 Answer

Compatible amp for subs


hi there. yes it should work providing you have the correct wiring it for it, if you buy the LV 416 enquire about a wiring kit to fit, most will. theyre normally around 20pounds. most amps will be compatible with most subs. i run both my 12inch 1000w off one 1200amp at half power, they kick lovely and i have no problems.


any other quiries please ask
adam

Nov 10, 2007 | Legacy 2CH 1000W AMP Car Audio Amplifier

1 Answer

Amp not working correctly goes into protection


Disconnect the speaker wires from the amplifier and see if it still goes into protection mode. If it still goes into protect with the speakers disconnected, there's a problem with the amp; if not, you may have a blown speaker or a shorted speaker wire.

Feb 22, 2007 | Legacy LA2098 Car Audio Amplifier

Not finding what you are looking for?
Car Amplifiers Logo

Related Topics:

533 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Amplifiers Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Pablo Gonzalez

Level 3 Expert

733 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you a Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...