Question about Crane Cow Humidifier

2 Answers

Humidifier makes a huge noise and no mist

A soon as i turn on my humidifier, it makes huge noise and it is not producing mist.

Posted by on

  • 1 more comment 
  • Anonymous Mar 20, 2014

    When I turn on the humidifier, it makes a loud noise that does not go away unless I pound on the top.

  • Anonymous Mar 24, 2014

    Humidifier stopped blowing out mist and it being allergy season I need it very bad my motor is running but no mist is blowing out? Also I do not have the manuel either can anyone please help me by telling me what I should try doing to it? Thanks, sherry

  • Anonymous Mar 29, 2014

    Not misting

×

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 7 Answers

According to the Crane's Troubleshooting section:
The power light is green but there is no mist being emitted:
- Check that there is water in the tank.
- Check for possible lime deposits on the water level sensor or the nebulizer.
- Make sure that nothing blocks the vapor output slots.
- Check that the fan vent on bottom of humidifier is not blocked.
- Empty the humidifier and rinse the water basin with cool tap water and allow to dry for 15 to 30 min.

This next part may or may not be relevant.
Humidifier power light is staying red and not turning green. Or, Humidifier is working then stops:
- Ensure that water level sensor is assembled properly.
- Clean water float.
- Call service center and request replacement water float.

Barring that, here is the service center contact info:
Dart Warehouse Corporation
Tel: 1-888-599-0952 (Business hours Mon-Fri 9:00 am - 4:00 pm Ct)
Website: http://www.crane-usa.com
1835 Ferry Road
Naperville, Illinois 60563

Posted on Feb 12, 2008

Ad
  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Crane coolmist humidifier pink is not misting to the top, vapor seeping out at the base

Posted on Mar 22, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a sunbeam sul2512um ultra sonic humidifier . I have had it for a less than a year . When I turn it on it makes a very loud noise where the mist comes at the base . Is there anything I can do to...


unfortunately thats the noiise a humidifier makes perhaps there are less noiser models on the market now you know as time goes by so technology becomes more amazing.

Nov 10, 2014 | Humidifiers

1 Answer

Humidifier will produce mist for a min then stop If you look you can see it producing mist within but it will not come out of the top Walgreens cool mist ultrasonic humidifier


I have had times where my Crane humidifier won't produce mist if I haven't turned it on for several days (4+) or more. The water that sits in the reservoir may develop a film on the ultrasonic element which inhibits the creation of the mist to come out the top of your humidifier. I would lift off the tank and empty the reservoir. Then VERY GENTLY with a piece of paper towel, wipe the ultrasonic element (looks like a disk the size of a quarter at the bottom of the reservoir) to clean off any film. Then replace the tank and let the reservoir fill up the tank and try it again.

If your humidifier runs properly for a minute and then makes a whirring noise and goes silent (like the motor stopping), then it's a motor problem. The humidifier motor may have gone out of alignment due to bumping or rough handling of the humidifier when cleaning or emptying it. If that is the case, you will have to empty the humidifier reservoir, unscrew the base, and find the screws holding down the motor and check for misalignment. Loosen them a little and put it back together and try again.

Best of luck
thebqe

Feb 13, 2014 | Humidifiers

1 Answer

Hello...i have a sunbeam filter free warm mist humidifier,and i put the water in and turn it on but it doesn't seem to be working. All the lites are on but nothing and it's brand new too never been used.


Hi, have you given it a while? That humidifier usually takes about 10 minutes to get going. After 10 minutes or so you should be able to feel the warm mist coming out, and soon after you should feel a difference in the moisture in the air.

Nov 28, 2010 | Sunbeam Health at Home Warm Mist...

1 Answer

I have a brand new hm500 humidifier and when I turn it on I can see the mist being produced in the reservoir but it won?t come out the top. How do I correct this?


If you can see the mist, then, it is working. The outlet
port of your humidifier could be closed/stucked up/clogged. Please check this the outlet port.

Jan 06, 2010 | Holmes Products HM500-UC 1 Gallon...

2 Answers

New filter,still no mist and water level does not drop


make sure that the filter is VERY snug into the bottom of the humidifier, and that the tank is on correctly. We had the same problem :)

Jul 01, 2009 | Vicks V3100 1.2 Gallon Humidifier

2 Answers

We have a Sunbeam Cool Mist Ultrasonic Humidifier that we bought just over 2 months ago. Up until a couple of days ago, it was producing mist and running just fine. I cleaned it with the brush and got the...


I have this same problem. And cool mist humidifiers DO produce mist. I have had my humidifier for a while now (6 years) and have never had any problems. But after the most recent cleaning, it worked at first, but now seems to not be working anymore... Am also wondering if there is anything I can do to remedy the situation?

Mar 17, 2009 | Sunbeam 701 Humidifier

2 Answers

The humidifier has stopped producing mist


boogiecheck is right, the one pictured uses natural evaporation( no white dust) I just ordered one from abdistrsupport@gmail.com and mine works great. I own 3 total.

Dec 07, 2008 | Venta - Airwasher LW44 Humidifier

2 Answers

Sunbeam ultrasonic humidifier runs but produces no mist


It sounds very much like the transducer has failed. This is likely a crystal transducer and since they produce the agitation that should cause a mist, they are running continuously; not a good thing for something that is trying to shake iteslf apart all the time. These require input from a circuit that produces the fairly high level of power needed to drive the crystal so it could also be the source of the problem.
This isn't something an owner is able to diagnose unless they have some technical training.     

Nov 08, 2008 | Sunbeam Ultrasonic 81696 Humidifier

1 Answer

Noisy ultrasonic humidifire


The grey circle (diaphram) needs replacing. Try Maplin electronics.

Mar 31, 2007 | Swiss Air-O- 7135 Warm Mist Antimicrobial...

Not finding what you are looking for?
Crane Cow Humidifier Logo

5,170 people viewed this question

Ask a Question

Usually answered in minutes!

Top Crane Humidifiers Experts

Marvin
Marvin

Level 3 Expert

82306 Answers

Danny Kuhlmann

Level 3 Expert

1443 Answers

Andrew Taylor
Andrew Taylor

Level 3 Expert

22091 Answers

Are you a Crane Humidifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...