Question about Amplifiers & Preamps

1 Answer

Sony Receiver STR-AV920

When I power it up, it reponds with only Protector in the display

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 682 Answers
Re: Sony Receiver STR-AV920

Something bad in load (speakers and thier cabels).
1-disconnect speaker one by one when the fault goen this speaker and it is cabel are guilty.change it .if you did all above and still have a problem you must send it to service center.

Posted on Mar 10, 2008

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Sony receiver STR D635 goes to ''protect''mode

Does the set work for the 10 secs. If not you have the protection due to a voltage/current drain in the circuit.The protect works to prevent any further damage to the amp and is a safety feature. To look into the fault it is important to have an idea to go about. Disconnect the speakers and check if the fault changes, if so check your speakers for short and replace them or the coils. If not the output of the amplifer can be faulty. check in the output stages with a multimeter for failure of any biasing resisitors that can also drain more current. If you are not familiar get help. The failed component can be replaced after disconnection and testing. Hope my advice helps. Good day

Jul 23, 2010 | Sony Amplifiers & Preamps

1 Answer

Stereo amplifier shutdown.

  • The amplifier is showing the protect mainly due to a safety feature on the power circuit. The fault could be failure or short in the output stages, short in the speakers, fault in the power ciicuit or the error amplifier that triggers the relay.
  • To trace the fault it is impotant to make the test in the main board, disconnect the power to output to confirm if the output is faulty. similarily disconnect the powering circuit one by one to identify. replace or disconnect to confirm. Hope this helps. Good day

Jul 11, 2010 | Sony Amplifiers & Preamps

2 Answers

I have a Sony STR-SE591 Home Theater receiver. As soon as I turn it on, it goes in to "PROTECTOR" mode. Nothing is hooked up to the amp at all, besides the power cable of course. I am no expert at all when...

could have a blown channel or a bad connection, these where often riddled with connection problems,
get a powerfull magnifier and look for connections that aren't solid and redo them. also check the outputs first for shorts if none amp is probibly ok.

Jun 21, 2010 | Amplifiers & Preamps

1 Answer

Sony STR DA2400ESB AV receiver display keeps going off


It's going into "protect" mode.

Usually a power amplifier failure.

You'll need a pro to fix it

Apr 05, 2010 | Sony Amplifiers & Preamps

1 Answer


There is a defect in the final amplification stage of the receiver. This may have been caused by a short in the speaker wires. The typical defective parts are the output transistors. Expect a parts cost in the $40 range for this repair. Any audio service shop should be able to repair this.


Sep 21, 2009 | Sony Amplifiers & Preamps

1 Answer

Sony amplifier STR DA2000ES protector code 22

go to your manual and repeat connection and setup and try with new cables because may be the cat bite something hidden from your eyes.

Apr 10, 2009 | Amplifiers & Preamps

1 Answer

Playing ipod on sony str-de595 receiver

You need a 3.5mm mini jack coupler lead with phono plugs on end plug one end into your headphone output on ipod and phonos into your amp lead must be stereo

Dec 22, 2008 | Sony STR-DE595 5-Channel Amplifier

2 Answers

How to reset a sony STR-AV920

Turn it off, you might have to unplug it and leave it unplugged for 10 minutes or so. It should reset itself. Make sure you don't have a wire short somewhere causing an overload to the Amp. You might have to move the turntable further away from the Amp. It is also important to have the T.table Ground wire connected to the back of the Amp/Receiver. Thanks.

Sep 22, 2007 | Amplifiers & Preamps

Not finding what you are looking for?
Amplifiers & Preamps Logo

Related Topics:

372 people viewed this question

Ask a Question

Usually answered in minutes!

Top Amplifiers & Preamps Experts


Level 3 Expert

4502 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

The Knight
The Knight

Level 3 Expert

66352 Answers

Are you an Amplifier and Preamp Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides