Question about GWC AA1500 External Sound System

1 Answer

AA1500 External Sound

I can have it fcn properly in my vista but the sound coming out is 2 channels instead of 5.1 how come?
is there a new driver or sth?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.


    An expert who has answered 1,000 questions.

  • Master
  • 1,067 Answers
Re: AA1500 External Sound

In system audio under conytrol panel in classic view adjust it to 5.1 speakers and 48000 out ok

Posted on Jan 24, 2008

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

2 Answers

I bought a Gwc aa1500 5.1 audio usb adapter for my laptop. I tried plugging my axpro headphones into the adapter but all the audio seems to be coming through the front speakers. How can i get it to go...

This is an issue with the driver or configuration.

Make sure you have the latest updated drivers for the device

When sound is coming from front for 5.1 system, its most probably to do with settings.Stereo mode Outputs from front speakers only. Try finding a radio button inside sound settings for 5.1 Audio system.

It is most probably found under " Speaker Configuration" Settings.

Mar 12, 2011 | GWC AA1500 External Sound System

1 Answer

Need drivers for predator 5.1 sound card for windows vista 32 bit.

theres no drivers available for vista. Windows XP and below only

visit details here:

visit the drivers here:

Sep 30, 2009 | Mad Dog Multimedia Predator 5.1 DSP 6...

1 Answer

M-audio not connected in windows vista

have you vista supported driver ifyou are not it is the driver only 32 bit windows not for 64 bit

Jun 29, 2009 | M-Audio Fast Track Pro External Sound...

1 Answer

I have a creative audigy Creative Labs Sound Blaster Audigy 2 Sound Card and Creative 7.1 surround sound speakers. When I was using XP all 7 speakers worked perfectly. Now with my newer Vista machine,...

Uninstall all sound drivers for the card. Delete all folder and use search to locate everything related to the sound card. Remove card , turn comp on w/o card. Turn off reinsert card.
Should fix it.
Vista has many,many issues like this.
If you have more types of sound listed in "SOUNDS" delete all but Audigy.
Re-install drivers AFTER you get ALL NEW VISTA UPDATES>

Feb 18, 2009 | Creative Labs Sound Blaster Audigy 2 Sound...

1 Answer

Creative external card

it might be because of windows vista :/ just to make shure did you download off of their website for the vista drivers and not off of the disc that came with it??? btw on a second thought... unless you have a laptop, internal sound cards are more compatible, cheaper, and better than external sound cards... it takes about 3-5 seconds to install in your computer, i remember the first time i had to install a sound card.... i thought it would be really hard and i would break everything. i realized that a monkey can do it. well, to solve your problem i recommend download the right drivers for vista and not the one with your disc... probably your driver should be something like::

"(model#) creative external sound card windows vista X86"

since 32bit oses are popular among manufactures, i think it should be something like that.

Jul 01, 2008 | Creative Labs Soundcards: External USB...

3 Answers

No sound coming from soundcard. Intel 82801DB/DBM 'AC97

you might have to go to and look for driver updates for your sound card for vista .

Jun 19, 2008 | Intel Premier Resources 4-Channel 32-Bit...

1 Answer

Midi sport 2x4 usb midi interface

i have no sound drive in my system so please permit me 2 download sound drive from ur product please grant me 2 download

May 15, 2008 | M-Audio Audiophile USB Audio and MIDI...

1 Answer

Optical out

I think it depends on what software you are using to play the 5.1... VLC lets you, PowerDVD and WinDVD also do there my be some tweaking needed to get them to sound good though.

May 03, 2008 | Creative Labs SB0270 External Sound System

1 Answer

Sound coming through computer speakers instead of through fast track.

Check your audio settings to make sure that it's going to the right driver. goto: start -> control panel -> sound and audio devices out of the 5 tabs, you'll want to pay attention to 2 of them, these are the "audio" and "voice" tabs. Make sure that your speakers on are the external sound system's drivers and not your internal sound card. (Basically, make your sound playback the same as your sound recording)

Feb 17, 2007 | M-Audio Fast Track External Sound System

Not finding what you are looking for?
GWC AA1500 External Sound System Logo

Related Topics:

157 people viewed this question

Ask a Question

Usually answered in minutes!

Top GWC Audio Cards Experts

Brian Sullivan
Brian Sullivan

Level 3 Expert

27725 Answers

Sudeep Chatterjee
Sudeep Chatterjee

Level 3 Expert

3267 Answers

Teet Bergmann

Level 3 Expert

565 Answers

Are you a GWC Audio Card Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides