Question about Sony FD Trinitron WEGA KV-32HS420 32" TV

1 Answer

Sound at power on

My Sony Wega makes a loud buzz sound when powered on. Very similar to the old console televisions back in the 70's. Is there a solution for this problem? I think I purchased the extended warranty but the tv is about 3 years old so I don't know if it is still in effect.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.


    An expert who has answered 20 questions.


    An expert that hasĀ over 10 points.


    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 43 Answers
Re: Sound at power on

The sound you are hearing is the degausing coil which will vibrate for a second when the tv is turned on. This part demagnetizes the picture tube and this sound is really quite normal. Depending on the position of this coil it may vibrate against the front cabinet of the tv and may sound loud at times. If this really bothers you then you need to have the rear cover removed and have it repositioned a bit do it won't vibrate so loudly. Or you can enjoy the buzz for the short time it happens and not worry about it.

Posted on Jan 23, 2008

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

We have an 11 yer old sony wega KV-32FV15 We lost picture and sound. Power on swirtch activates the standby red light which just continues to blink (no Sound no Picture0 We know we have the power plug...

the tv is defected needs to be repaired..have a tech repair your tv.the problem is in the power supply or horizontal circuit.could be any thing in one on those circuit.good luck.

Aug 28, 2011 | Sony FD Trinitron WEGA KV-32FS120 32" TV

2 Answers

Set makes poping sound, but does not turn on, red standy light flashes

problem doesn't seem to be on the power supply board only! had the service center check the high voltage section already? does the popping sound like the one popcorns make?

Nov 26, 2007 | Sony FD Trinitron WEGA KV-34XBR910 34" TV

1 Answer

Samsung Big screen mod. HL-P6163W made load pop, then buzzing sound with screen going to black and white. Make buzzing sound and no picture when turned back on?

This set has a problem with the color wheel falling apart, which if one of the segments should fly off while the set was on it may sound like a loud pop, and the buzzing sound could be mechanical in nature with the wheel being off balance. If smoke appeared after the loud pop, then it could be a capacitor blowing in the power or video circuits. This model uses two different types of Color Wheel assemblies, either an L3 or a L6 and it would be listed on a white label on the Light Engines metal frame. Hope your solution is this easy.

Mar 08, 2011 | Samsung HL-P6163W 61" TV

1 Answer

No picture or sound when powered up. Red Standby light flashes continually. My Sony KV 36 XBR250 Wega Trinitron XBR is about 10 years old and has worked perfectly up to this point. What could be the...

Did you get your set fixed or did you replace it? My same set did the same thing. Turned it off for 2-3hrs after watching it and when I tried to power it up- nothing but the sound it would normally make just before the major power up, sort of a relay click sound. No picture or sound but the red light blinks non-stop.

Jan 20, 2010 | Sony KV-36XBR250 TV

1 Answer

My sony trinitron xbr television will not come on. The power available ligt, flashes at at 7hz and off for 3 constantly. When you push the power button it sounds like its about to come on, then within one...

sounds like a high voltage arc. there are several parts that can cause this. if you want guidance i can help you but you must be careful there is aprox. 30,000 volts in that "snap" ...

Dec 28, 2009 | Sony FD Trinitron WEGA KV-32XBR400 32" TV

1 Answer

TV Doesnt work

replace the flyback transformer.

Mar 01, 2009 | Sony FD Trinitron WEGA KV-24FS100 24" TV

1 Answer

Tv acts like its going to turn on, but then shuts back off

sounds like high volt arcing. i would get it checked out pronto could do much more damage if it is hv arcing.

Dec 13, 2008 | Sony FD Trinitron WEGA KD-36FS130 36" TV

2 Answers


Hello to all you buzzers, I have the answer to your problem. First this is what's happening. The buzzing is coming from the power relay. It vibrates at 60hz because the power supply filter capacitor is not doing its job hence you have a rough d.c. pulse going to the relay.To solve the problem remove back of t.v. slide circuit board out (you will have to disconnect white wire from degauss coil,located on left front) look for a blue box approximately 3/4"x1 1/2" this will be the power relay. Now look for capacitor location #c622 near the relay. This capacitor should be 470uf 25v. Remove and replace with 470uf 35v capacitor, connect white degauss wire temperarily put back on and give it a spin. Hope this solves all the buzzin,robert

Jul 12, 2007 | Sanyo DS24425 24" TV

1 Answer

Sony KV-20FS120

It's normal for new sets, especially Sonys to do that due to some sort of gas build-up in the new tube. My set still gets a high-pitched buzz after power on and lasts for a minute or two before silencing. If the hissing continues when the TV is turned off return it to the shop ASAP. It could be a problem with the power supply, something getting ready to blow up. Good luck

May 30, 2006 | Sony FD Trinitron WEGA KV-20FS120 20" TV

Not finding what you are looking for?
Sony FD Trinitron WEGA KV-32HS420 32" TV Logo

187 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Standard (CRT) Televisions Experts

The Knight
The Knight

Level 3 Expert

66444 Answers

Jaime Hernandez

Level 3 Expert

2267 Answers

matt martin
matt martin

Level 3 Expert

1187 Answers

Are you a Sony Standard (CRT) Television Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides