Question about AudioBahn DUB Mag Audio DUB4001 Car Audio Amplifier

4 Answers

I have a dub 4001 amp

I was driveing down the road and my amp stoped working and when i got home the amp light wutch is green is now red and wont go back to green

Posted by on

  • thizzcore Feb 20, 2008

    so i have this problem to and i changed my ground and now my amp fully works. blue lights fan and all but my subs still have no sound.

  • Anonymous Aug 18, 2008

    i hooked everything up properly (i think). the red light still comes on.its properly grounded and the 12 volt and remote wire are hooked up fine. any suggestions on what i should try?

×

Ad

4 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Turn it on unplug a speaker wire let the light turn gren then plug it back in to trick it it works I have the same amp and matching subs if you get it set up right it will pound I like it

Posted on Feb 05, 2011

Ad

I have the same amp and the same problem.it was under warenty once so i tokk it back they sent it away to get fiexed and all they did was say it works perfectly fine nothing wrong and that i was using a 2ohm sub instead of a 4ohm which i wasnt.so i went out of the shop to my car plugged it all in and no go.took it back into the shop and got the guy to plug it inot his demo units and it still didnt work.he called the repaid centre in which he had no luck so he just gave me a new amp to replace it.it has now done the same thing but is out of warenty.it goes into protection mode and locks itself their.

Posted on Aug 07, 2008

Ad

Me to i've got 4001 DUB amp in my car its so **** man, not like kenwood or pioneer my 1200W kenwood sub disconnected from time to time and return to factory bass, and the amo gets very hot

Posted on Aug 06, 2008

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Contributor
  • 65 Answers

Take it step wise.

Unplug the inputs and outputs from the amp (be sure to mark the wires so you can hook them back up), leaving only the ground, +12, and remote wire hooked up. Now, turn it on. If the amp light goes red, the amp is broken. If it goes green, turn if off, plug in the speakers, then turn it on. if it's red, its a speaker problem, if green, do the same with the inputs, and you'll have your answer.

Posted on Jan 23, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

ABS LIGHT IS ON WONT GO IN TO FOUR WHEEL DRIVE


Check with a code reader or scanner, the ABS could be at fault

Mar 24, 2013 | 2005 Nissan Frontier

1 Answer

Securty problem truck wont start 2001 gmc searra died out driving


You have a fualty electrical condition,This can stem from a broken insulation wire to poor connection or the insulation that has rub through.The problem you have plaque GM. No need to by pass just get to the ignition area inspect the harness if anything you have a bad connection

Mar 12, 2012 | GMC Cars & Trucks

1 Answer

My amp stopped workin, when i turn the stereo on, the green light is on, then when the music starts to play it turns red and stops working,


The red light on amplifier relates to power supply while the green light is indication of sound functionality. An amplifier that allows sound to generate should display both red and green lights. Howeever, some amplifiers would display only green as long as the sound is functioning.

Solving the problem

First, a red light still on means the power connections to the amplifier is fucntional least requirng repairs.

Second, the green ligh should turn on once the stereo were tuned up to produce sound. If the stereo is still on only least produce sound on the amplifier, check on the connection wires between stereo to amplifier that may have disconnected due to woofing or dubbing sound generals with unfirm wiring.

Third,

Jan 28, 2011 | JVC KS-AR7501D Car Amp

1 Answer

Converter wont work red light on when i use the remote it wont turn green when i push the red button manualy it still wont turn green


If you're electronics savy, as in replacing capacitors, open it up.. that's your problem.. one or two of the caps on the power board has gone bad.. most likely a 470uf 25v, which can be replaced with a 470uf 35v found at Radio shack for about $1.29. You can tell if it's bad if the top is cracked open & leaking or just domed out instead of being flat.

Aug 05, 2010 | Apex Digital HT-150 System

1 Answer

Dub 2502 not in protect mode but not putting out


i dnt knowwat type of speaks u got but ifits low then it cud be tht u have too open up the second coil on ur speakers...dnt sound like the amp since its on & not in protect mode,other than tht i'll recheck the wiring

Apr 07, 2009 | AudioBahn DUB Mag Audio DUB2502 Car Audio...

3 Answers

Power protector light on sony xplode 1000 watt amp


a green light is the power indicator, a red light is when the protector is in affect

May 30, 2008 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

Problem with my amp


the proble could be that the negative cable is not touching ground, or that the remote is not tide enough.

Mar 13, 2008 | AudioBahn DUB Mag Audio DUB2502 Car Audio...

1 Answer

Amp stuck in protection mode.


check to make sure your ground wire is attached to a clean metal surface no more then 18" away from amp. check all wires to ensure none are touching other terminal. all else fails remove one sub and see how it play, if its works great switch subs. could be a defective amp. if it is the amp and you payed for it with a credit card or bank card you can do a charge back from the bank to get your money back if the store wont replace it. thell the bank "you want to do a charge back cause it wasnt as discribed).

Nov 10, 2007 | AudioBahn DUB Mag Audio DUB2502 Car Audio...

1 Answer

No Sound coming out of amp to subwoofer


check the fuse box and make sure there is no loose connection there. also check the wire that feeds power to that amp. good luck

May 23, 2007 | AudioBahn DUB Mag Audio DUB1002 Car Audio...

Not finding what you are looking for?
Car Audio & Video Logo

648 people viewed this question

Ask a Question

Usually answered in minutes!

Top AudioBahn Car Audio & Video Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22382 Answers

Jerry Naidoo

Level 2 Expert

151 Answers

Robert Rankin

Level 2 Expert

356 Answers

Are you an AudioBahn Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...