Question about Car Audio & Video

1 Answer

No boom i have an autotek ss75.2 amplifier and i am getting no output signal the light comes on tell me thats its getting power but there is no power to my sub can you help me

Posted by on

  • Zootys17 Feb 07, 2008

    i have a pioneer Amp attached to a Dual bandpass sub system, the amp lights on, but the subs arent getting any signal.. and whats a relay?

×

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Expert
  • 107 Answers

Check your relays. reply me after ^.^

Posted on Jan 22, 2008

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Boom audio, blown fuse


Fill the air with sound from this Boom!™ Audio Boom Bagger Kit. This complete audio kit provides the latest in Harley-Davidson® audio components. When installed, the increased power of the amplifier provides the speakers with a clean signal, and a custom equalization is available to further optimize the performance of the Boom!™ Audio speaker system.
  • 4-Speaker Ultra Boom!™ Bagger Kit
  • Ensure maximum output of your audio system with the recommended High Output Charging System P/N 29900028
  • Dealer Digital Technician software update is required
  • Dealer installation is recommended
  • Kit includes Boom!™ Audio 6.5" fairing speakers, Boom!™ Audio 4-channel fairing-mounted amplifier, amplifier mount and wiring harness
  • Speakers feature two-year warranty
  • Stop by a participating dealer to interact with a unique audio display that lets you simulate how your bike will sound with Boom!™ Audio upgrades. Contact your local dealer for details
From: http://www.harley-davidson.com/store/boom!-audio-boom-bagger-amp---speaker-kit-pa-08-76000411--1

Jun 11, 2012 | Harley Davidson Motorcycles

2 Answers

Autotek XS-900.4 stuck in protect mode


Hi.

The amp does not go on protection only because of wiring or power source problem , but also and mainly when there is an internal fault.

Protection is started whenever an out-of range voltage value is detected from the controller circuit.

Protection can be triggered from a burnt final IC or from a speaker wiring problem.

Since you have ruled out speake, wiring and power source problems, then this Amp is probably defective

If the Amp works fine on a different vehicle, then protection mode may start either because speakers impedance is not within Amp specs, or because the amp has a too big power draw. In this last case the problem is fixed installing a capacitor on the Amp 12V line.

Regards.

Ginko.

Jun 06, 2010 | Autotek XS-900.4 Car Audio Amplifier

1 Answer

Power turns on then 1 second after protection light comes on and power light blinks


MAKE SURE THAT THE POWER AND ESPECIALLY THE GROUND CONNECTIONS ARE 100%. REMOVE THE RCA INPUTS AND SPEAKERS. POWER THE AMPLIFIER UP AGAIN UNDER THIS NO INPUT, NO SPEAKER LOAD CONDITION AND IF IT STILL GOES INTO PROTECTION, THEN IT WILL NEED TO BE SERVICED. LET ME KNOW IF I CAN BE OF FURTHER ASSISTANCE.......V

Dec 10, 2009 | Autotek Car Audio & Video

1 Answer

Have power good ground and remote wire has juice, no sound


no you can buy a 5 dollar volt meter at walmart or autozone to test to see if your rca wires are outputing any signal/ (volts) that will tell you if its the rca wires or head unit!


thanks

erik

Feb 26, 2009 | Pioneer GM-7100M Car Audio Amplifier

1 Answer

THUNDER 5601 WHEN VEHICLE TURNED ON, SUBS BOOM, THEN WORKS OK. ALSO WHEN RADIO TURNED OFF


If the amp produces no boom with no signal input cables connected, I'd suggest using an LOC.

Let me know if you have any other questions.

Sep 30, 2008 | MTX Thunder 3401 Car Audio Amplifier

2 Answers

Aplifier gettieng protection signal and excess heat


for that amplifier, it is recommended that you are driving a 4 ohm load. It can drive a 2 ohm load, but will produce more heat and shorten the life of the amplifier. Is the subwoofer a single or dual voice coil? You'll want to make sure that you're not running below a 2 ohm load or you'll always go into protection. Also, try disconnecting the speaker wire completely from the amp so nothing but power is connected. If the amplifier is still in protection mode when no speakers are hooked up, then the amp is bad and will need repair or replacement.

Sep 28, 2008 | Autotek Car Audio & Video

1 Answer

Need information


This plug configuration should be the same as the old autotek. The wires on the sides of the remote are the positive speaker wires. With the amp orientated so that the 3 wires are on top, the wire left of the remote on the amp plug should be the left positive. The one directly under it is the negative for that channel. The ones to the right are the right channel (negative on bottom again).

You can confirm left/right after you get the amp powered up. Drive signal into one RCA jack at a time and check for output on the corresponding speaker wires.

Apr 12, 2008 | Car Audio & Video

1 Answer

Autotek mx1500.1


i am a master audio amp repairman i am working on an mean machine mx 1500.1 the RCA inputs wer just worn out on mine,
but your problem is much worse your power supply is gone, all mean machine`s are CLASS X mind you NOT CLASS D basicly all that means is that the audio feads directly into one big power supply unit instead of having both an input and output stage.I recomend you find a web site or audio shop with a phone number
for the autotek corp. and have it sent in..DO NOT WORK YOURSELF

Jan 30, 2007 | Autotek MX1500.1 Car Audio Amplifier

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

67 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4991 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Marvin
Marvin

Level 3 Expert

82322 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...