Question about Amplifiers & Preamps

2 Answers

Prosound Power AMP, no sound available

I have a new amp used on my djing equipment, its only 3 months old and been used 3 time. For some reasion i cant get sound from it? yet its all connected up as it was when it was being used with no issues?. i have checked all the fuses. in the amp and plug. When the amp is on the power light is lit? but again no sound? can you help?

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.


    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 1 Answer
Re: Prosound Power AMP, no sound available

Hi jacko, i had the same problem with my prosound 1000.
changed all the fuses etc with no luck.
then as a last resort, i tried wiggling and lightly tapping the internal wires on the main board then all of a sudden there was sound!
i know next to nothing about electronics but i am thinking that i may have reset some kind of power protection cut off that may have been sticking, but what do i know?.
Please, like everything else electrical, if you do try this, make sure power is off first.

hope this helps, its worth a try.


Posted on May 13, 2008

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert that gotĀ 5 achievements.


    An expert who has written 50 answers of more than 400 characters.


    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 95 Answers
Re: Prosound Power AMP, no sound available

Mmmm, to me sound like it's the wires' that connect's to the amp. What brand is it, what type of output stage is it, is it a cheap panasonic style with does big ic's, if it is don't botter you already know the answer.


Posted on Jan 22, 2008

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

ProSound 1600 Professional Power Amplifire, No Manuals, No Service, No Manufakturwebsite? Who can help???

Try on google, To do a search.There are sites where you can download manauls for no charge, I found the owners manaul for my adcom Power Amp that way. End it is over 15 years old.

Oct 21, 2012 | Amplifiers & Preamps

1 Answer

I bought a new 1200 watt xplod amp and pluged it to a 1200 watt double coil sub with my alpine headunit the head unit is too old so i got a new xplod head unit but now i got a really freak low sound...

personally I would probaly contact the place where you bought the equipment, providing you have connected everything up correctly, it sounds like the amp is faulty

May 05, 2011 | Sony Xplod 1200W Class AB Bridgeable 2-Ch....

1 Answer

Can anyone tell me if the Adcom 5503 three channel amp is common ground? I want to use it to power some old school polk SDA 1C as my mains and a CSi5 polk center. Thanks

no reason why not, 3 channel amps used to be the "state of the art" back in the early stereo days. the third channel was produced from the sum of the right and left channels, (the plus side of the right and the plus side of the left were sent to the center channel. produced what was considered at the time a true reproduction of the sound as it was intended to be. your lucky to have this old amp.

Mar 12, 2011 | Adcom GFA-5503 3-Channel Amplifier

2 Answers


first of all you must connect as follows.
1-preamp/mixer-------equalizer/reverb unit------amp-----speakers(keep all equalizer control to 0db).
2-check your cables for good connector no touching of any inner wire to chassis of any equipment.
3-go to radio shack and buy(ground-loop isolator).
parts code(270-054)-----better to buy two pieces and connect it between your equipment.

Apr 01, 2009 | Amplifiers & Preamps

1 Answer

New amp is whining

Try switching power amp output's to the speaker's and see if it still does it if it still does it the it's the speaker ,disconnect every thing from the input's of the power amp if it stop's start pluging thing's in one at a time ,process of elimination best of luck

Dec 27, 2008 | Amplifiers & Preamps

1 Answer

NAD C370 Right channel distortion

Sounds like you have lost the power amp transistor(s) or IC for this channel.

Aug 29, 2008 | NAD C370 2-Channel Amplifier

1 Answer

KENWOOD Power Amplifier

The power amp does need an imput signal ie. tuner, cd , and such to play. You can use the power amp with the other equipment.
Good Luck

Oct 30, 2007 | Yamaha DSP-A3090 7-Channel Amplifier

2 Answers

New to PA systems......

What brands are we talking about my friend?

Oct 09, 2007 | Amplifiers & Preamps

3 Answers

NAD C340 has lost ability to switch between inputs

I have the same problem which started about a month ago and seems to be getting worse. I also noticed today, that 1 channel is significantly louder than the other - fault in the pre-amp stage, as feeding the power stage directly gives balanced, albeit extremely loud sound! Looking on eBay, I found someone else selling an amp with both problems. It would nice to think that NAD would acknowledge a design flaw, and fix for free, but my amp is 5 year old.

Jul 14, 2007 | NAD C340 Integrated Amplifier

2 Answers

Dj equipment

SEnd all the high notes to the small speakers and the bass to the sub. Ran.

Apr 27, 2007 | Gem Sound GemSound PA-585 2-Channel...

Not finding what you are looking for?
Amplifiers & Preamps Logo

Related Topics:

395 people viewed this question

Ask a Question

Usually answered in minutes!

Top Amplifiers & Preamps Experts


Level 3 Expert

4518 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

The Knight
The Knight

Level 3 Expert

66623 Answers

Are you an Amplifier and Preamp Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides