Question about NAD C370 2-Channel Amplifier

3 Answers

NAD 370 Hi My NAD Amp suddenly lost power, it seemed as if the fuse had blown, I checked the fuse in the plug and that is fine and cannot find a fuse inside the unit, there is no power getting to the led and cannot hear the transformer humming. Any suggestions? Many thanks email is stephen@quesst.co.uk

Posted by on

  • 2 more comments 
  • quesst100 Jan 21, 2008

    Thankyou, can you tell me what it looks like and where it is?

  • quesst100 Jan 21, 2008

    Have just found a fuse? about to test it.

  • quesst100 Feb 13, 2008

    Thankyou! I realised there was no circuit breaker and was looking around the transformer for a fuse at first. When looking for the circuit breaker i realised there was a fuse under a cover.



    Many thanks it worked straight away and the capacitors look fine!

  • Anonymous Apr 08, 2008

    My NAD 370 fuse is also blown. Problem is that I can't find this fuse - on the fuse is the following: Buss T4AH250V. Dimention is 20mm x 5mm and it is a ceramic fuse. I suppose it is a Bussmann - looked on their catalogues but nothing close to the description on the fuse.



    Pieter - Sydney

×

Ad

3 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Where do you find the right fuse? how do you order this stuff.

I think the same thing has happened to my 370.

Posted on Jun 11, 2008

Ad
  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 4 Answers

Hi There is no circuit breakers inside. close to front panel on a left side under plastic cover is fuse (AGC type) . Before you change fuse look at four filter capacitors in the middle of unit!!! (close to power transformer on pcb) If they are white do not change the fuse and get unit to good service center( it must be someone who knows what they doing!!!) If the caps are different color (black ,purple) you can try to change fuse. Once again if capacitors are white do not use unit-fire hazard!!!! I'm long time service guy for NAD so trust me on this one Dariusz  dariusz70@verizon.net

Posted on Feb 13, 2008

Ad
  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Expert
  • 104 Answers

Try to re-set mini circuit breaker inside.

Posted on Jan 21, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a nad 3130 amplifier which has been in storage for sometime. I've plugged it in and I have no power to the amp.


If the fuses are good....do this.....
1...unplug the amp from the wall AND KEEP IT UNPLUGGED !!!
2 Turn the power switch on ( again , the amp is UNPLUGGED from the wall )
3 with an ohm meter or a multimeter set on ohms., measure the ohms across the ac cord that plugs into the wall....in other words...take one meter lead and touch it to only one " blade" that plugs into the wall and keep it touching the " blade".....while you are holding it there, touch the other meter lead to the other " blade " that plugs into the wall.....you should get a very low ohm reading ( 2-50 ohms )......if it is over that number, your transformer or your switch is open ( toast ). hopefully it is the switch as transformers are un-available......good luck, be safe, and if you arent sure....ask before doing something silly.....Rob

Apr 03, 2015 | NAD Audio Players & Recorders

2 Answers

I have a NAD 510 CD player with no display lighting working and would like to repair this myself, and also a NAD 710 receiver/amp that does not tune in any stations but otherwise works fine, would it do...


wont do any harm to open it up. look for blown fuses. i have a NAD amp and the desplay goes blank and sound distorts when there is a blown fuse inside, my amp has abourt 8 fuses inside it 4 per chanel

Jan 04, 2010 | NAD C521 CD Player

1 Answer

Hi I have got a sony TAFE 370 amplifier which does not produce any output, i have tried different input devices and also checked speaker wiring and the speaker selection is on i used it a day ago and all...


If you can't hear any sound from the headphone output, and by sound I mean a hum with the volume turned up, then the amp has either got a faulty internal power supply or the main amp has failed. Try looking inside to see if any fuse has blown. Also look around to see if you can see or smell anything has blown.

Sep 24, 2009 | Sony TA-FE370 2-Channel Amplifier

1 Answer

Nad c 370 no power


You need to look inside. There will be a fuse inside too. If your lucky it will restore the amp once replaced, but if it blows again you have a fault. You can track it down yourself if your any good, you might even see a burnt out part when looking for that fuse, otherwise get the repairman in.

Sep 20, 2009 | NAD C370 2-Channel Amplifier

2 Answers

HELP PLEASE. NAD 370 JUST DIED...


This could be as simple as a bad connection at the voltage regulator IC or blown output transistors. If you have a multimeter and some experience with electronics repair, this should be fairly straightforward.

Let me know and I'll try to walk you throught the repair.
Dan

Sep 07, 2008 | NAD C370 2-Channel Amplifier

1 Answer

Nad c350 no power at all


check your output stage for bad speakers cable or bare wire of cable touch the body of amp----short circuit speaker cable----bad speaker it self------ bad input cable or defective input device .
disconnect all and check if it is ok---start to connect one by one from input to outputs------if all above failed you must contact service center for help.

Aug 22, 2008 | NAD C320 2-Channel Amplifier

1 Answer

Nad c370 problem....


Hi arda5
Did you try swapping speaker connections left for right on the back of the amp to isolate the problem. If the fault stays with the speaker, then that is where your problem is. Try this and get back to me here with the results.

regards
robotek


Jun 13, 2008 | NAD C370 2-Channel Amplifier

2 Answers

Nad amp failure


Check fuses mounted near transformer . If blown check output transistor. Also check transistor transistors on small heat sink . they will cause fuse to blow.

Mar 10, 2008 | NAD C350 2-Channel Amplifier

Not finding what you are looking for?
NAD C370 2-Channel Amplifier Logo

Related Topics:

763 people viewed this question

Ask a Question

Usually answered in minutes!

Top NAD Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5547 Answers

The Knight
The Knight

Level 3 Expert

75846 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a NAD Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...