Question about Hoover SteamVac F5914-900 SpinScrub Upright Vacuum

1 Answer

Dispensing problem w/attachment and maybe floor partion

used a new unit w/attachment for 5 minutes...dispensed solution in a powerful triangular fashion. Then the fluid quit dispensing out of the attachment nozzle amost like the pump quit working. Primed the unit several times w/ no success. checked for clogs. can't tell if the floor portion is "pumping' or just dribbling solution onto the floor with the trigger. can see no leaks at this point. unit worked for about 5 minutes on apholstery. all items seem to be sealed and functioning except the dispensing "pump" mechanism.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 126 Answers
Re: dispensing problem w/attachment and maybe floor...

The F5914 has a hose that must be attached to the pump when using the upholstry attachment. Make sure that the solution hose is pushed onto the pump valve all the way. Try pushing the hose down and then pushing the locking collar down to secure it. This will insure that the hose is fully engaged.

Posted on Jan 21, 2008

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Why isn't the soap coming out of the despencer

Check dispenser seating, turn off unit, unplug unit. Reseat dispenser, plug in unit, turn unit on, wait one minute, press sprayer to test. While your at it clean the two filters. The filters need to be cleaned after each use. One is located under the Water Tank Cap and the other is under the Flow Indicator. Bissell Consumer Care 1-800-237-7691

Jun 23, 2014 | Bissell ProHeat Turbo Deep Cleaner Upright...

2 Answers

We have an Emerson hands-free soap dispenser that won't work. We've installed brand new batteries and it still won't dispense soap. The red light comes on to indicate it' s working but no soap will come...

We have 5 Emerson hands-free soap dispensers that don't work. Tried new batteries, light comes on, but no soap comes out. How can we get our money back?

May 20, 2010 | Vacuums

1 Answer

The water is not coming out to clean the floor

Your unit uses water, correct? I have a Proheat 2X and it wouldn't dispense water. I tried the Water Rinse setting and found water came out and was suctioned properly, but on the Light Clean, Normal Clean, and Heavy Traffic settings, the unit failed to do anything. Problem may be with leaving the soap dispenser in-place, which might scum up the tubing.

SO, an alternative to throwing out my unit and buying somethign else was to put one capful of the Bissell soap in the water resevoir and keep the unit on Water Rinse. IT WORKS BEAUTIFULLY NOW. Don't know if this will help, but at least I didn't have to buy a new unit. Rinse everything after using and there's been no problem.

Apr 21, 2010 | Bissell 1697-7 Powersteamer Pro Deluxe...

2 Answers

Soap/water solution pouring out on floor when trying to use hose & attachments

The attachment hose is torn right where it connects to the motor . And there should be a trigger on the end of the hose right below where it connects to the hand tool.

Oct 01, 2008 | Hoover SteamVac F5914-900 SpinScrub...

2 Answers


I'm no expert...i'm just waiting on someone to answer my question....but the unit has to be on the floor with the handled released b4 the roller move.

Aug 23, 2008 | Bissell 9500 ProHeat 2X CleanShot Upright...

1 Answer

PROheat 2X won't dispense water

Make sure that the gasket is on the valve at the bottom of the tank. It has to be on the tank. That valve may be bad, or maybe the tank isn't sitting square on the base. But if less then 1 year old, then it is under warranty, take it in for warranty repair. You taking it apart voids the warranty.

May 31, 2008 | Bissell 9500 ProHeat 2X CleanShot Upright...

1 Answer

Bissell power shoot carpet cleaner

It sounds like the heater may be plugged. This is a problem for an experienced technician. The heater is located in the handle and they are prone to plugging at the tubing connections. The heater is heating soap and water solution and this can cause the soap to coagulate and plug the lines. It must be addressed carefully to avoid damaging the heater.

Mar 23, 2008 | Bissell 7920 ProHeat Pro-Tech Upright...

1 Answer

Attachment problem

make sure everything is filled and secured tightly, if this a new unit it should be something simple ok, also check where machine folds down that the solution hose is not being pinched its right behind the dirty water tank

Jan 21, 2008 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

Will not dispense soap from handle

The soap dispenser, on the side, make sure the seal is on the bottom of it and not in the hole. You may have to replace the valve asm for the dispenser part # 2101795

Sep 30, 2007 | Bissell 7901-1 ProHeat Scotchgard Upright...

Not finding what you are looking for?
Hoover SteamVac F5914-900 SpinScrub Upright Vacuum Logo

Related Topics:

167 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts


Level 3 Expert

18258 Answers

Roger Potts

Level 3 Expert

694 Answers

Ryan S
Ryan S

Level 2 Expert

328 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides