Question about Kenmore 31912 Progressive Direct Drive Bagged Upright Vacuum

1 Answer

Motor quit working. i was vacuuming and all seemed fine. then the motor went really low. when I opened it I noticed that the bag was not attached and the cannister had filled up with stuff and the filter was full. the vacuum will not run now.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Kenmore Master
  • 8,404 Answers

My friend, the dirt you sucked up went right into the motor and it burned up. I am very sorry to tell you this. It is probably not worth repairing unless you are able to replace it yourself.

In addition to not being able to dool itself, you probably got dirt in the bearings and certainly in the motor brushes damaging the armature.

If you want to try the fix, find a new motor at a FisYa.com advertiser or partner, your local Sears or at www.repairclinic.com

Thanks for posting at FixYa.com

Please vote ... and dont kill the messenger

thank you

a

Posted on Dec 13, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My Vacuum is actually shooting out debris rather then pick it up. I don't what is wrong but the vacuum is making a really loud wining sound from the motor. Would it be the motor? Will I have to buy yet...


This happened to my vacuum also. I used it this way for quite a while, starting at one end of the room and "blowing" the dirt behind me as I went and then used a broom and dustpan when I got to the tile floor.

The problem was fixed the next time I changed the bag. Apparently, my husband had put the bag in backwards! hahaha Easy fix! :D So, check to make sure the bag is installed correctly!
var fctb_tool=null; function FCTB_Init_8a84e8d3763141509885ba605a550304(t) { fctb_tool=t; start(fctb_tool); } FCTB_Init_8a84e8d3763141509885ba605a550304(document['FCTB_Init_f78ff4b269924f65ab55b8367ba4e5df']); delete document['FCTB_Init_f78ff4b269924f65ab55b8367ba4e5df']

May 02, 2011 | Eureka 5849A Boss Bagless Upright Cyclonic...

2 Answers

I shampooed my carpet and later that day went to use the Kirby Sentria and it wont turn on... it has always worked fine up to this moment, what could be wrong?


there is a safety feature on the kirby that if there are no attachments on the front or the side it will not turn on. check and make sure your attachments are properly on the machine

Apr 21, 2009 | Kirby Heritage II Vacuum

1 Answer

Bag not filling-seems all the debris is going into the motor


Maybe your just a really clean person and have little dirt. If its picking up stuff and you dont see it it has to be going in the air or bag though. vacume in a room with sunshine comming in and see if you notice excess dust when you push/pull it. If no excessive (where it come out and you see it fall) it is going in the bag. If you see dirt falling all around these are the bigger particles and arnt going into the bag. Look for a place for the bag to be loose ot yjr plate it mounts to being loose.
let me know what you find. Please rate me as high as you can and thanks for using fix  ya.

Apr 09, 2009 | Vacuums

1 Answer

Hoover U5468-900 WindTunnel Supreme suction is suddenly poor


The other possibility is there is a blockage in the foot. these models have dual channel air flow (windtunnel) and become blocked when not cleaned depending on use. under the roller there is a cavity that can be removed for cleaning. a hot motor can be caused by poor air flow.

I’m happy to assist further over the phone at https://www.6ya.com/expert/robert_b96ba3f038cf317c

Mar 15, 2009 | Hoover U5453-900 WindTunnel Supreme Bagged...

1 Answer

Attachments hose won't **** but blows out


the polarity on the motor mite change with use or low suctoin

Dec 20, 2008 | Bissell 3576 CleanView II Bagless Upright...

2 Answers

My Electrolux upright worked fine


Are you using the proper bag? There's a kill/reset switch that needs to be pushed down by the rim of the bag before the unit will run.

Jun 22, 2008 | Electrolux Epic 6500 Vacuum

1 Answer

Sebo x1.1 - burning smell


Try replacing the belt. My vacuum cleaner had the same problem and once the belt was changed the burning smell was gone.

Jun 10, 2008 | Sebo Automatic X1 Bagged Upright Vacuum

1 Answer

Miele vacuum cleaner not working properly


Is the suction low or ok at the vacuum without the hose attached? If it is ok, then there is a clog in the hose. If it isn't, then check filters, is the speed variable, is the contol set too low. Could be a bad motor, running too slow.

Mar 05, 2008 | Vacuums

2 Answers

Overheating vacuum?


if the belt had melted, the only cause can be the brush roll stiff to turn. remove belt and check bbrush roll turns freely

Apr 14, 2007 | Hoover U5144900 / U5146900 / U5147900...

Not finding what you are looking for?
Kenmore 31912 Progressive Direct Drive Bagged Upright Vacuum Logo

106 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenmore Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18429 Answers

Chris Nomland
Chris Nomland

Level 2 Expert

115 Answers

Marvin
Marvin

Level 3 Expert

83527 Answers

Are you a Kenmore Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...