Question about Vacuums

1 Answer

Kenmore progressive canister

Hi there -

My vacuum won't turn on unless the power brush is attached. When it does go on, there is no power in the power brush (the brush does not turn). I hear a flipping noise in the canister (like a broken belt). Do you have any idea why I'm having this problem? It seems so weird. Thank you!


Posted by on

  • Fran Zenowitz Jan 23, 2008

    It's not the power brush that is the problem. The canister doesn't work unless the power brush is attached as I stated above. Someone else told me the motor needs to be replaced. Thanks.




1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 397 Answers

Belt could be melted to the motor that spins the brush, try free spinning the brush with your hand to see if the brush spins freely, if it does not the brush bearings could be frozen, or just need a simple new belt...hope this helps

Posted on Jan 20, 2008


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017


Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

My kenmore progressive canister vacuum turns on only if the hose is attached to the floorwand. It seems that the canister motor is not working because I can't hear anything coming from the caniste

If the floor wand is powered, there may be an electrical connection that is broken when the wand is disconnected. This is part of the design, not necessarily a fault

Jan 05, 2013 | Vacuums

1 Answer

I've had my Kenmore Progressive canister for at least several years and never had a problem. Now, the carpet head brush does not rotate, it's not getting the connection unless I push down maintaining...

Hi, try pushing the reset button with a pen or paper clip. If that doesn't work, the motor may need to replaced. If the reset button is stuck, if the reset button is stuck, use a pair of tweezers to pull it back out......

Secondly, your belt can also be broken or has come off the pulley. Remove the bottom plate and investigate.

Sep 19, 2010 | Kenmore 25512/ 25513 Progressive Canister...

1 Answer

How do I replace the belt on my Kenmore canister vacuum?

Turn the power brush over so the bottom faces up. On the bottom there are two access screws. Remove the two screws and then the top cover can be removed from the base. With the top cover off you can access the belt. You can get a replacement belt for your model here:

Kenmore Progressive Replacement Belt

Nov 17, 2009 | Kenmore 25512/ 25513 Progressive Canister...

1 Answer

The carpet brush attachement loses power while vacuuming

I have seen this many times. It is either a bad connection or a break in the wire. Turn it on and flex the wire and connection until you can reproduce it dependably. Then you will know what it is and where.
It is very aggravating. You need to fix it soon, before you take to jumping up and down on it and bust the wand and the power head also.

May 27, 2009 | Kenmore 25512/ 25513 Progressive Canister...

1 Answer

String caught in end of rug brush

This pdf file should help you - there are instructions in it for removal of the roller.

Rate if this helps :)

Feb 15, 2009 | Kenmore 25512/ 25513 Progressive Canister...

1 Answer

I have the upright kenmore progressive with direct drive and the filter canister stops bringing in air and picking up when hose is put into vaccum, when you remove hose and use as an attachment it starts...

Check the hose after the brushes. With this problem there is normally a clog in between where you disconnect the hose (to use attachment) and the brushes that clean the carpet.

Dec 21, 2008 | Kenmore 31913 Progressive Direct Drive...

1 Answer

Carpet function rollers don't turn

Most likely a broken belt. If the brush roll is turning freely, then check the belt.

Mar 02, 2008 | Kenmore 25812 / 25813 Progressive Bagged...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

148 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vacuums Experts


Level 3 Expert

2572 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18417 Answers

D. Floyd Kolb
D. Floyd Kolb

Level 3 Expert

43501 Answers

Are you a Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides