Question about Vacuums

1 Answer

Kenmore progressive canister

Hi there -

My vacuum won't turn on unless the power brush is attached. When it does go on, there is no power in the power brush (the brush does not turn). I hear a flipping noise in the canister (like a broken belt). Do you have any idea why I'm having this problem? It seems so weird. Thank you!


Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 397 Answers
Re: Kenmore progressive canister

Belt could be melted to the motor that spins the brush, try free spinning the brush with your hand to see if the brush spins freely, if it does not the brush bearings could be frozen, or just need a simple new belt...hope this helps

Posted on Jan 20, 2008

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

My kenmore progressive canister vacuum turns on only if the hose is attached to the floorwand. It seems that the canister motor is not working because I can't hear anything coming from the caniste

If the floor wand is powered, there may be an electrical connection that is broken when the wand is disconnected. This is part of the design, not necessarily a fault

Jan 05, 2013 | Vacuums

1 Answer

I've had my Kenmore Progressive canister for at least several years and never had a problem. Now, the carpet head brush does not rotate, it's not getting the connection unless I push down maintaining...

Hi, try pushing the reset button with a pen or paper clip. If that doesn't work, the motor may need to replaced. If the reset button is stuck, if the reset button is stuck, use a pair of tweezers to pull it back out......

Secondly, your belt can also be broken or has come off the pulley. Remove the bottom plate and investigate.

Sep 19, 2010 | Kenmore 25512/ 25513 Progressive Canister...

1 Answer

How do I replace the belt on my Kenmore canister vacuum?

Turn the power brush over so the bottom faces up. On the bottom there are two access screws. Remove the two screws and then the top cover can be removed from the base. With the top cover off you can access the belt. You can get a replacement belt for your model here:

Kenmore Progressive Replacement Belt

Nov 17, 2009 | Kenmore 25512/ 25513 Progressive Canister...

1 Answer

The carpet brush attachement loses power while vacuuming

I have seen this many times. It is either a bad connection or a break in the wire. Turn it on and flex the wire and connection until you can reproduce it dependably. Then you will know what it is and where.
It is very aggravating. You need to fix it soon, before you take to jumping up and down on it and bust the wand and the power head also.

May 27, 2009 | Kenmore 25512/ 25513 Progressive Canister...

1 Answer

String caught in end of rug brush

This pdf file should help you - there are instructions in it for removal of the roller.

Rate if this helps :)

Feb 15, 2009 | Kenmore 25512/ 25513 Progressive Canister...

1 Answer

I have the upright kenmore progressive with direct drive and the filter canister stops bringing in air and picking up when hose is put into vaccum, when you remove hose and use as an attachment it starts...

Check the hose after the brushes. With this problem there is normally a clog in between where you disconnect the hose (to use attachment) and the brushes that clean the carpet.

Dec 21, 2008 | Kenmore 31913 Progressive Direct Drive...

1 Answer

Kenmore Progressive Model # 116 25914507

I had the same problem with my vacuum. I called in for technical service and was told to push the "reset button". It turns out that there is a small red button right next to the dirt indicator light. I pushed the button, plugged the vacuum back in and started it up and it worked like a charm! :) Hope this helps!

Mar 25, 2008 | Kenmore 23913 Progressive PowerMate Bagged...

1 Answer

Carpet function rollers don't turn

Most likely a broken belt. If the brush roll is turning freely, then check the belt.

Mar 02, 2008 | Kenmore 25812 / 25813 Progressive Bagged...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

144 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vacuums Experts


Level 3 Expert

2572 Answers


Level 3 Expert

18258 Answers

Roger Potts

Level 3 Expert

694 Answers

Are you a Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides