Question about Kenwood eXcelon KAC-X812D Car Audio Amplifier

1 Answer

Car amp not working - Kenwood eXcelon KAC-X812D Car Audio Amplifier

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 47 Answers

Well, it may be fried. Be more specific please. Did it ever work, does it turn on but no sound? There are multiple reasons why an amp won't work. Whats your actual problem

Posted on Dec 13, 2009

  • hopkinsa Mar 10, 2011

    my amp doesn't work. it waz working fine, then the sound just stopped all of a sudden. the power light is on, the protection light is off. I reconnected all of the cables. so it's on, but no sound. what could be the problem?

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How fix Dodge Grand Caravan Touch Screen Not Working


Dodge Grand Caravan Touch Screen Not Working - YouTube

? 0:21
www.youtube.com/watch?v=fl19EnEB0mA
Jul 10, 2014 - Uploaded by Radionut R
The touchscreen of my 2008 Dodge grand Caravan quit working. ... Chrysler Town & Country - 3 Common ...

Dodge Grand Caravan nav touch screen not working ... - Fixya

www.fixya.com > ... > Cars & Trucks > Dodge
Dodge Grand Caravan cars & trucks nav touch screen not working questions and ... How do I fix this problem? check fuses first then check the bulbs do not touch ...

Dodge car touch screen not working Questions & Answers ...



Dec 14, 2015 | Dodge Cars & Trucks

1 Answer

Amp does not work properly


I am just gonna though this one out there, could it be the voltage regulator in your altinater ?

Mar 30, 2014 | Car Audio & Video

3 Answers

Are the fader and balance on my car stereo supposed to work after a new stereo amp has been installed ?


if everything was correctly installed then yes, but depending on what was used, the installer may have opted for a custom configuration. however, the fader and balance really should work.

Jan 07, 2014 | Car Audio & Video

1 Answer

Subwoofer


did you wire the amps in your car? or is it a stock amp?

Dec 17, 2013 | Car Audio & Video

1 Answer

I have a Kenwood KAC-9105D amp. It is brand new and worked for about 20 minutes while I was driving and it hasn't worked since. When I turn my car on, the blue and red LEDs on the amp both come on for a...


First of all, how are your subs wired to the amp. Make sure your amp is not bridged or you'll fry it, it only has one channel. If that doesn't work you probably already fried your amp.

Oct 09, 2010 | Kenwood KAC9105D Car Amp

1 Answer

I have a rockford fosgate x7 amp and the fan stop working and a little while after playing it shut off what do you think


replace the fan in the amp, sounds like the amp is overheating and the cut off is kicking in... you can try the amp while not driving and the car parked, put a fan, like a desk fan where the amp is so it flows over the amp fins, and run the amp turn it up and let it work, see if it still shuts off after that, if so then it could be something internal nut sounds like it is the fan to me... and i have worked with many an amp and system in cars and trucks... hope this helps you

Jun 25, 2009 | Rockford Fosgate Punch P5002 Car Audio...

1 Answer

Amp works fine when car not running...shuts down when car started


It could be a problem with the head units remote wire (blue wire) that connects to the amp. It turns on the amp when the head unit is turned on, Check that wire for 12+ volts when head unit is on.

Be sure the amp is properly grounded,and the input and output signal (speaker) wires are connected.

You could also use a temp. jumper wire at the amp by jumping the power and remote terminals, just to see if the amp works.

Note: Do not leave the temp. jumper in place, amps are not meant to be continuously powered up. Make sure it is in a well ventilated area so as to disperse its heat.

Good luck
Aduz


Mar 14, 2009 | Alphasonik PMA1800A Car Audio Amplifier

1 Answer

Recently bought a 1996 mitsubishi galant S a couple of weeks ago & the interior light was'nt working. Then it started working sometimes then it quit working again. The buzzer when the door was open...


Sound's like you have some sort of a short or an open, somewhere, i would first check your fuse box,
in your engine and in your dash with a test light. make sure all fuses are working, if you had an open or short it could be possible you blew various fuses with a certain surge of power..
Second.. if you have an aftermarket sterio and all said before turns out alright. then i would pull out and check the wiring in the sterio and all surrounding it, one could have been rubbing up on another bare wire or ground out.

good luck..

Oct 26, 2008 | Mitsubishi Galant Cars & Trucks

1 Answer

No power


hi, some car amps need a high current remote supply to turn on. first make sure that you are using the proper gauge b+ and gnd cable for this particular rockford amp. then try switching the remtote turn on to this amp thru a simple Relay.(use the remote supply from your headunit as a trigger for the relay). do these connections without connecting any spks or rca line inputs. once amp is switching on then connect all other cables. OR lastly check the main fuse on the RF amp?? cheers

Jul 22, 2007 | Rockford Fosgate Punch P325.2 2-Channel...

1 Answer

Amp in protect mode


Check to see if the fuse is blown. If it's not, the amp is unfortunately fried. It would not be worth repairing the resistor in it

Apr 11, 2017 | Phoenix Gold Xenon-600.1 Car Audio...

Not finding what you are looking for?
Kenwood eXcelon KAC-X812D Car Audio Amplifier Logo

Related Topics:

72 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

5003 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Marvin
Marvin

Level 3 Expert

83096 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...