Question about Video Cameras

3 Answers

Blue screen on playback on Sony DCR-HC40

Hi - when I switch the Camera into Playback mode and hit play it simply displays a blue screen. I can hear the tape moving and tried several tapes but nothing works. Recording appears to be working and its not a problem with the LCD because I can see the picture in it when I am recording.  Any tips on what I could do? Its a good cam corder in great shape. Would hate to have to dump it.

Posted by on

3 Answers

  • Level 1:

    An expert who has achieved level 1.


    An expert that got 5 achievements.


    An expert who has written 20 answers of more than 400 characters.


    An expert who has answered 20 questions.

  • Contributor
  • 24 Answers
Re: Blue screen on playback on Sony DCR-HC40

You can see an image in a camcorder viewfinder any time the camera's actually on in record mode, whether or not the camcorder is actually recording. So that's no guarantee.

Assuming the obvious (you have the right kind of tapes, they're not in write-protect mode, you rewind before playing, etc). I recommend that you borrow a tape of the same kind from someone else and check it on playback in your camcorder. This should lead you know understand if you have a playback problem or a recording problem.

Posted on Jan 21, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer
Re: Blue screen on playback on Sony DCR-HC40

I think your tape had a lone time not using.
Try to use forward(reward) srach on record mode.
let the tape rolling for a while.then try forward or reward again until tape not so tie.
Waring : this action may damage your machine.

Posted on Mar 28, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer
Re: Blue screen on playback on Sony DCR-HC40

When I open the LCD Screen on my Sony DCR-HC40, the screen is black and it almost looks as though there are cracks running inside the screen. What can I do. I can't use the screen for playback or anything.


Posted on Jun 06, 2010

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Sony Handycam DCR-HC40 Mini DV Digital Camcorder. My touch screen is not working. It show's everything, but if you push the screen, it does nothing. Also, if you are in tape mode or any mode and hit...

The most likely cause for this is a damaged or defective flexible ribbon cable that connects the LCD to the camera body and can be repaired fairly inexpensively. However, it's not a user serviceable problem and will need to be repaired by a qualified service technician.

My name is Rick and I'm a professional repair technician with over 20 years in the business and have repaired many of these. I'm semi retired and work from home with little overhead so I can keep repair costs low. If you decide to have the camera repaired, please click HERE for a directory listing that suits your needs.

If this response has been of any help to you, please be sure and give a positive vote for me on

Sep 01, 2011 | Sony Handycam DCR-HC40 Mini DV Digital...

1 Answer

The LCD is blue and won't play back . We have cleaned it. Camera mode works when recording. Just no playback picture in VCR mode. ...

you most likely has a bad screen, if you can, play back your video into a VCR, dvd burner or televisino with rca type inputs, this will at least let you save your movies.

Mar 18, 2011 | Sony Handycam DCR-TRV250 Digital Camcorder

1 Answer

DCR-TRV530 Digital 8 . . . Problem started with tape being caught in heads. Got a 3121 error message afterward . That stopped but in video playback mode only blue screen with play arrow at top? In...

If video head got clogged then camcorder wont read tape in playback so result comes as blue screen.
Please use video head cleaning tape and clean video head of camcorder. This will solve your problem.
Video-8 head cleaning tape is available with

Dec 03, 2010 | Sony Handycam DCR-TRV530 Digital Camcorder

2 Answers

Sony digital video camera mode no. DCR-HC14E not showing pictures/recording

If your Sony DCR-HC14E shows fine picture in playback of old tapes and does not give live view in camera mode to record then its CDD Imager problem that Sony will repair free of cost.
Click Sony CCD Imager Support for details.

Jun 10, 2009 | Sony Handycam DCR-HC14E Mini DV Digital...

1 Answer

Sony CCD-TRV65. Blue screen during playback

Just bought the exact one from a yard sale for 20 bucks. Had the very same problem with the blue screen on playback. What i did is replace the battery in the small bay when you open the viewfinder. Try playing your tape again and it will work!

Feb 01, 2009 | Sony Handycam CCD-TRV65 Camcorder

1 Answer

Cannot view playback!!!!

First thing to determine is if your (Playback Mode) is set for Auto or Hi 8 / 8. Select VTR setting and then select Menu. Scroll to PB Mode and select Auto. Now try playback.

Oct 25, 2008 | Sony Handycam DCR-TRV820 Digital-8 Digital...

1 Answer

Sony Handycam CCD-TRV87 Hi-8...

I am having the same problem. When I hit Rewind or Fast Foward, i can see the image moving clearly.
When I hit play though, I just get a BLUE screen with the Play arrow displayed. So it's playing, I just got a blue screen. And last night, I got the blue screen but I could hear the audio. 
Then I put a head cleaning tape in the camera, and I did get the picture back on for a little bit.
Skip to this morning, and we are back to the Blue screen again. Only this time, I am getting no audio. And I the head cleaning tape back in but it's not helping anymore. 

Jun 10, 2008 | Sony Handycam CCD-TRV87 Camcorder

1 Answer

No playback on DCR-TRV103

In playback mode the lCD displays the battery time, hi8 symbol and the tape counter. all the functions work the tape will play, rewind, fast forward. The screen stays blank on playback and the tape counter stays at 0:00:00 eventhough I can see the tape turning. I also hooke the camera to my tv and I got no picture.

Dec 23, 2007 | Sony Handycam DCR-TRV103 Digital Camcorder

1 Answer


if the camera is going on in the play mode and you are getting a blue screen with play indicator it is mostly due to dirty head. what have you used for cleaning the head. take the help of repairer for cleaning as he will do so after opening the cover. if that doesent solves the problem then get the video head checked for any damages such as broken tips.

Oct 08, 2006 | Sony CCD-TRV238 Camcorder

Not finding what you are looking for?
Video Cameras Logo

Related Topics:

1,697 people viewed this question

Ask a Question

Usually answered in minutes!

Top Video Cameras Experts


Level 3 Expert

94039 Answers

Larry Stiles
Larry Stiles

Level 2 Expert

286 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you a Video Camera Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides