Question about Euro-Pro NV31 Infinity Vacuum

1 Answer

No suction - Infinity Shark Vacuum NV31C

Getting no suction from bottom of vacuum. Cleared clog in wand hose. Can't see a clog in the lower hose but can't figure how to get to it adequately either. Brushes spin and there is suction through wand.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 8,404 Answers

You might try sucking the sose out with another vacum from the wrong way. You might be able to remove the hose and push a broom handle or stiff wire through. If you have compressed air available, you could try that, outside.

Im sure you have a clog and if you remove it, you will be back in business.

Thanks for your interest in FizYa.com

Posted on Dec 11, 2009

  • 1 more comment 
  • lstringer284 Aug 18, 2011

    the wand hose on the infinity vacuum has 90 degree elbows on each end -- which means a stiff wire or broom handle will not turn the corner of the elbow connectors at each end of the hose. How do you remove the hose from the elbow connectors without breaking the elbow?

  • A Miller Aug 18, 2011

    This is a '... will you help me site' .. not a '... will you do it for me' site. This question is over two years old. If you cant get the stuff out, junk the unit. Simple

  • lstringer284 Aug 19, 2011

    milleraba your "solution" is spurious and without merit.

    There is a sock in the hose of a $500+ vacuum, and I thought this "suggested solutions" site was intended for well intentioned and serious responses.

    The hose is attached to the vacuum by a hard plastic 90 degree elbow, and on the other end of the hose it is attached to the handle of the wand with a 90 degree elbow. Your answer above would work if it were not for the hard plastic elbows. I wondered if you or another reader could offer a different option for a different situation.

    Do you or any other reader have a less flip and more useable suggested solution?

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Clogged Sebo automatic X-1 vacuum


Hi There,

So when this light is displaying, it's says "Bag Full or Clog" on the indicator. If you have changed the bag, and it's still showing this light, it means that you either have a clog in the vacuum, or your filters are dirty, which is reducing the suction and making the machine think that your bag is full. If your machine is actually cutting off, this indicates that your machine is definitely clogged, or something is stuck inside which is causing the motor to not get air flow, and cauing the machine to over heat. When it shuts off like this, it's a protection system that prevents any damage from happening to the motor when it can't breathe and starts to overheat.

My guess is that there is probably a clog in the machine somewhere, or the filters are dirty. Here's what you may do to diagnosis the machine, and try to isolate the clog to find out where it is in the vacuum.

Step 1. Remove the hose and wand assembly from the vacuum cleaner completely. You may do this by pressing the two tabs on the end of the hose that plugs into the vacuum cleaner:


cca2760.jpg
With the hose and the wand removed from the vacuum, it should look like this:

b7c34c5.jpg
Step 2. Now turn the vacuum cleaner on and check to see if the red light comes on while the hose and the wand have been removed. If the light comes on, then this indicates that your filter is dirty (or the PCB electric board is bad if the filter is clean) and needs to be replaced.

Step 2. Re-attach the hose and wand back on the vacuum, but just the end of the hose that goes into the vacuum cleaner, leave the wand out of the vacuum cleaner so it looks like this:


db25806.jpg
Turn the machine on now as if you were using the attachment hose to clean corners or above the floor and see if the red light comes on here. Also listen to the noise the motor makes and see if the noise changes when you put the hose back on the vacuum cleaner. If the red light appears, or if the motor makes a higher pitched noise now, then this indicates that you have a clog in your hose or wand. You may verify this by remove the hose again from the vacuum, and also removing the wand from the hose by pressing the hose release button on the wand and pulling the hose out of the wand. Look down both of the parts and see if you can see thru both sides. If you're not able to see light through the hose, or the wand, this indicates this is where the clog is. You may take a metal clothes hanger, and try removing the clog this way.

Step 3. If the red light did not display with the wand not inserted into the vacuum, put the wand back into the vacuum cleaner as if you were vacuuming the floors:


1a089d0.jpg
Turn the machine on, and see if the red light comes on in this position. If the light does come on, then this indicates that you have a clog in the bottom of the vacuum cleaner. To check and see the clog in the bottom of the machine, I find it easiest to remove the upper bag housing from the vacuum cleaner completely so you're just looking at the bottom power nozzle of the vacuum cleaner. There's a button at the bottom of the machine that is either a grey, or yellow color depending on what color your vacuum is. Simply press this button in, and lift upwards on the handle or the bag housing at the same time:


2b91587.jpg
Step 4. After the bag housing has been removed, turn the lower part of the vacuum upside down so the brushes are facing upwards. There's a little orange flap on the bottom of the machine that is actually a clog port. Almost every time there is a clog in a Sebo, this is where I typically find the clog. Open up this orange colored trap door, and look to see if you can see any obstruction or clog underneath of here:


08da832.jpg
Step 5. You may rotate the neck of the power nozzle part towards you so that you may look inside to see if you see any obstructions inside:

c034305.jpg
Step 5. You may also remove the brushes from the vacuum and look behind the brushes at the suction port, or the area where the suction goes through the vacuum to see if you see anything obstructing the suction here.

These are really the only places that the Sebo can get clogged. If you checked all of these areas, and the red light is still displaying, this means that your PC Board that controls this indicator has gone bad, and needs to be replaced. If this is the case, please just reply to this repair using the comment field, and I'll be more then happy to help you through the replacement of replacing the PCB Board.

I hope this answer was helpful to you, and you were able to find the clog and fix the problem. If you found my repair helpful, please be sure to rate the repair by clicking the 4 thumbs up icons in the top right hand corner, or by leaving feedback for me. This is really what keeps repair professionals continue to post free repair solutions rather then just the paid questions. It's really appreciated when you take the time and do this if the repair was helpful.

Thank you so much,
..

Jan 29, 2013 | Sebo Automatic X1 Bagged Upright Vacuum

1 Answer

Red light on then cuts out how do i unblock please? lost the manual.


Hi There,.

So when this light is displaying, it's says "Bag Full or Clog" on the indicator. If you have changed the bag, and it's still showing this light, it means that you either have a clog in the vacuum, or your filters are dirty, which is reducing the suction and making the machine think that your bag is full. If your machine is actually cutting off, this indicates that your machine is definitely clogged, or something is stuck inside which is causing the motor to not get air flow, and cauing the machine to over heat. When it shuts off like this, it's a protection system that prevents any damage from happening to the motor when it can't breathe and starts to overheat.

My guess is that there is probably a clog in the machine somewhere, or the filters are dirty. Here's what you may do to diagnosis the machine, and try to isolate the clog to find out where it is in the vacuum.

Step 1. Remove the hose and wand assembly from the vacuum cleaner completely. You may do this by pressing the two tabs on the end of the hose that plugs into the vacuum cleaner:


cca2760.jpg
With the hose and the wand removed from the vacuum, it should look like this:

b7c34c5.jpg
Step 2. Now turn the vacuum cleaner on and check to see if the red light comes on while the hose and the wand have been removed. If the light comes on, then this indicates that your filter is dirty (or the PCB electric board is bad if the filter is clean) and needs to be replaced.

Step 2. Re-attach the hose and wand back on the vacuum, but just the end of the hose that goes into the vacuum cleaner, leave the wand out of the vacuum cleaner so it looks like this:


db25806.jpg
Turn the machine on now as if you were using the attachment hose to clean corners or above the floor and see if the red light comes on here. Also listen to the noise the motor makes and see if the noise changes when you put the hose back on the vacuum cleaner. If the red light appears, or if the motor makes a higher pitched noise now, then this indicates that you have a clog in your hose or wand. You may verify this by remove the hose again from the vacuum, and also removing the wand from the hose by pressing the hose release button on the wand and pulling the hose out of the wand. Look down both of the parts and see if you can see thru both sides. If you're not able to see light through the hose, or the wand, this indicates this is where the clog is. You may take a metal clothes hanger, and try removing the clog this way.

Step 3. If the red light did not display with the wand not inserted into the vacuum, put the wand back into the vacuum cleaner as if you were vacuuming the floors:


1a089d0.jpg
Turn the machine on, and see if the red light comes on in this position. If the light does come on, then this indicates that you have a clog in the bottom of the vacuum cleaner. To check and see the clog in the bottom of the machine, I find it easiest to remove the upper bag housing from the vacuum cleaner completely so you're just looking at the bottom power nozzle of the vacuum cleaner. There's a button at the bottom of the machine that is either a grey, or yellow color depending on what color your vacuum is. Simply press this button in, and lift upwards on the handle or the bag housing at the same time:


2b91587.jpg
Step 4. After the bag housing has been removed, turn the lower part of the vacuum upside down so the brushes are facing upwards. There's a little orange flap on the bottom of the machine that is actually a clog port. Almost every time there is a clog in a Sebo, this is where I typically find the clog. Open up this orange colored trap door, and look to see if you can see any obstruction or clog underneath of here:


08da832.jpg
Step 5. You may rotate the neck of the power nozzle part towards you so that you may look inside to see if you see any obstructions inside:

c034305.jpg
Step 5. You may also remove the brushes from the vacuum and look behind the brushes at the suction port, or the area where the suction goes through the vacuum to see if you see anything obstructing the suction here.

These are really the only places that the Sebo can get clogged. If you checked all of these areas, and the red light is still displaying, this means that your PC Board that controls this indicator has gone bad, and needs to be replaced. If this is the case, please just reply to this repair using the comment field, and I'll be more then happy to help you through the replacement of replacing the PCB Board.

I hope this answer was helpful to you, and you were able to find the clog and fix the problem. If you found my repair helpful, please be sure to rate the repair

Aug 09, 2012 | Sebo X4 Bagged Upright Vacuum

1 Answer

Very poor suction.No obstructions in hose.Just cleaned filter and emptied canister.


Are you getting good section at the wall inlet? If so, see below.
Check for a clog inside the power nozzle. Detach wands and drop a small coin into connection. It should fall through. If it doesn't, there's a clog that needs cleared.
A leaky hose could be the problem. Any vacuum hose is often mistreated, though intentionally. But due to the length of the CV hose, it undergoes quite a bit. Being constantly dragged around corners and pulled around, as well as improper storage can all result in holes/leaks in the hose. A few tiny holes throughout the length of the hose will result in an often dramatic loss of suction.
How old is the vacuum? It may be time to replace the hose.

Nov 22, 2010 | Electrolux Central Vacuum

1 Answer

Shark infinity vacuum nv31c motor overheats. everything is clean and free of clogs. it will work for 3-4 minutes, then shut off. does the motor need replacing?


Mine takes longer to shut down, but I just started having this same problem. I wish I knew what's causing it so I could fix it. I think maybe we had a power surge at some point when I was using it last week. :(

Nov 07, 2010 | Euro-Pro NV30 Infinity Bagless Upright...

1 Answer

My Electrolux guardian C135 vac has lost suction. replacing the bag does nothing. removing the HEPA filter has no effect - what do you suggest? Will a replacement HEPA filter make any significant...


No you have a clog in the hose, wand or at the power head. Remove the hose wand and power head from the the vacuum. Turn on the vacuum, put the palm of your hand over the hole in front, you should feel plunty of suction. Then replace just the hose and put the palm of your hand over the end of the hose. If you do not have suction the clog is in the hose. You can try putting the hose on the blower port to blow out the clog or use the wire from a coat hanger. If you have suction, then add just the wand and repeat. If you have suction, then the clog is in the neck of power head, you will have to use a coat hanger to clear it.

May 08, 2010 | Electrolux Guardian Bagged Canister Vacuum

1 Answer

I have the Miele cat & dog S5000 vacuum. I have had it about 1 year and lately the suction doesn't seem as strong and the full bag indicater is always full. I have followed instructions in manual but...


Greetings,

I would say that you have a slight clog in the hose or in the power nozzle somewhere. The full bag indicator is just a guage that will indicate full when it feels like it's lost suction. Example: If you were to take the hose and cover it with your hand, you'll notice that bag full indicator will show full.

To check and see where the clog in the vacuum is, remove the wands and floor attachment so you just have the hose on the vacuum cleaner. With just the hose attached, turn the vacuum cleaner on. Does it still show a full bag? If yes, then remove the hose completely from the vacuum cleaner so it's just the canister part by itself and turn on the vacuum again. If the bag full indicator is now showing an empty bag, this means that you have a clog in your hose.

If the bag full indicator displayed an empty bag when you had the hose on the vacuum, but shows a full bag when you have the wands and floor tool attached, this means that you have a clog in the vacuum either in the wands, or the floor attachment.

For removing clogs from the hose, the quickest way is to just purchase a plumbers snake at your local hardware store, and run the snake through the hose until you find the clog. You may also take a high pressure hose and spray it down the hose until the clog is cleared, but if you use a water hose, MAKE SURE the hose is 100% dry before you use it again.

Also that bag full indicator can be adjusted if you are getting a lot of suction power and it still shows full.

I hope that these suggestions helped you diagnosis your Miele canister to figure out why the indicator showed full. If this helped you please rate my repair helpful.

Feel free to contact me if you need further assitance, I'm always happy to help.

Chris J.

Mar 13, 2010 | Vacuums

1 Answer

The wand has no suction


There's a clog somewhere then - probably at the end of the hose which means you should take off the hose at the bottom by the cord clip and have a look. Also check all inspection air ways to ensure there are no clogs. Usually if there's no suction through the handle a tell tale sign is that something has either got stuck or there's a tear in the hose. Hope that helps.

Feb 22, 2009 | Dyson DC07 Bagless Upright Cyclonic Vacuum

3 Answers

Infinity Shark Vacuum


YOU HAVE BROKEN THE BELT, ORDER ONE FROM HERE

http://www.sharkvac.com/partsearch.aspx?CatID=cxmdqvOilfw%3d

Jan 11, 2009 | Euro-Pro NV31 Infinity Vacuum

Not finding what you are looking for?
Euro-Pro NV31 Infinity Vacuum Logo

1,066 people viewed this question

Ask a Question

Usually answered in minutes!

Top Euro-Pro Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18424 Answers

Dennis Key
Dennis Key

Level 3 Expert

2478 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you an Euro-Pro Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...