Question about Eureka Altima Upright Vacuum Model 2996AVS Vacuum

1 Answer

My HEPA filter get's blown off of the vacuum when I vacuum. I just got all new filters and a new brush roll. Could something be clogging in the inside?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,214 Answers

There should be a cover that closes over the HEPA filter. If the cover is missing, or is there, but does not snap closed, then either snap it closed, or replace the cover.
If something was clogged inside, then the HEPA filter would be less prone to being blown off. But, it sounds like the filter or filter cover is not being correctly installed. The manual is not clear on whether the cover snaps closed.

Posted on Dec 10, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

My lightweight hepa has lost most of its suction. No blockage in the hose?


Hepa filter cleaners have two filters in them. You need to replace both. Sorry some only use one. I would need the brand an model to tell you where they are an where to get them. Your best bet is to call a vacuum repair place an see if they have the filters. Or look online an they can be purchased from make, such as Hoover, Sears, Orich, etc. i replaced mine they just pull out an I never knew they were there. Unless you want a new vacuum.

Jan 29, 2015 | Vax Vacuums

1 Answer

Why won't My Hoover savvy won't turn on


Hi Denell! Your vacuum has a thermal protector that will shut it off automatically if it becomes overheated. This is usually caused by a clog or a filter that needs to be cleaned or replaced. Follow these quick steps to check your vacuum for clogs.

1. Remove the dirt cup and the dirt cup lid.
2. Grasp pre-filter frame and pull up and out of dirt cup.
3. Separate the pre-filter and Hepa cartridge filter. The pre-filter can be cleaned with a brush and then rinsed with water. Allow 24 hours to air dry.
4. Clean the Hepa cartridge filter by tapping either of the ends until dirt stops falling from the filter. The Hepa filter should be replaced once a year.
5. Remove the hose from both ends. Use a broom stick to gently loosen and clear any clogs from hose.
6. Use a wooden spoon or something similar to loosen and remove any clogs from the lower hose

The vacuum will turn back on after it cools off. This can take up to an hour. If the vacuum has been off for over 24 hours we recommend taking your vacuum in to a service center for repair. Follow the link to locate the nearest authorized service center to you.

Service Center Locator

Hope this helps!

Aug 13, 2014 | Hoover U8145-900 Savvy Bagless Upright...

1 Answer

It runs but not pick up dirt in cup


Hello! If the dirt is not entering into the dirt cup this could mean there is a clog in the vacuum or a filter that needs to be cleaned or replaced. Check that the brushes are still spinning. The vacuum has a brush-roll shut-off pedal on the right side of the cleaner if you are standing behind it. Below are simple instructions for checking your vacuum for clogs.

1. Remove the dirt cup. Twist off the dirt cup lid.
2. Remove the filter cartridge from dirt cup.
3. Separate the foam and cartridge filters. Wash foam filter under running. Allow 24 hours to air dry outside the vacuum.
4. Tap the excess dirt out of Hepa filter. Hepa filter may also be washed. Allow 24 hours to air dry.
5. Check the secondary filter by removing the filter cover from base. Rinse the foam filter under running water until it runs clear. Allow 24 hours to air dry.
6. The red baffle tube inside of the dirt cup is apart of the filtration of the vacuum and needs to be cleaned as well. Twist out the baffle tube by turning 1/4 turn clockwise. Remove any hair or debris wrapped around baffle tube. Baffle tube can be rinsed if needed. Allow to dry thoroughly.
7. Remove the hose from both ends. Use a broom stick to loosen and remove any clogs from the main hose.
8. Remove the bottom plate and the brushes as instructed in the owner's manual. Use a wooden spoon or something similar to gently break up and remove any clogs from the lower hose.
9. Inspect the belt for damages, if the belt is broken replace the belt with a Genuine Hoover belt part 562633001 Flat Belt Nano Upright

If the filters are too dirty they may need to be replaced. With regular maintenance the filters should be replaced about once a year. Follow the links below to order replacement filters for your UH20020.



Primary Filter
Exhaust Foam Filter

Hope this helps!

Mar 12, 2014 | Hoover Nano Cyclonic Compact Bagless...

1 Answer

Blows hepa filter from mounting


I have seen generic filters do this. Be sure to use original Miele filters. The generics are a few dollars cheaper to buy but you end up with an inferior quality filter that could cause other problems by continued use. same is true with bags.

A clogged filter may also do this. Miele vacuums are very tightly sealed, the exhaust air has to come out. If the filter is clogged, the pressure could pop the filter out, HEPA filters are suggested to change out about every 50 hours, for most people this is between 1 - 1.5 years.

We had a Miele come in for service the other day with the same complaint, installed filter was a generic, customer said it was a new filter just installed. We replaced with an original filter and problem ceased.

If you need any help feel free to contact me.

Tim
TheVacCenter.com

Mar 16, 2013 | Miele CatAndDog700 Bagged Canister Vacuum

1 Answer

Z8220 STOPS WORKING HEPA FILTER LIGHT FLASHING & NEW FILTERS INSTALLED


check your hose for a clog, id even check from where brushroll is at bottom to the end of hose. sounds like that could be your problem.

Jan 08, 2013 | Electrolux Vacuums

1 Answer

Low suction


Check the tube that leads down to the brush head for clogging as well as any motor or HEPA filters. If that still shows nothing, take the cover off the brush head (like you're changing the belt) and look for obstructions in there. Usually, if you have low suction on the accessory hose, the problem is with a motor filter, HEPA filter, or a clog where the hose goes into the unit. If you have good suction on the accessory hose but none on the floor, it's usually in the brush head (clog or broken belt) Good luck

Feb 28, 2010 | Dirt Devil Vision Turbo W/Bonus Upright...

2 Answers

Kenmore progressive 360 vacuum cleaner has low suction


Check the tube that leads down to the brush head for clogging as well as any motor or HEPA filters. If that still shows nothing, take the cover off the brush head (like you're changing the belt) and look for obstructions in there. Usually, if you have low suction on the accessory hose, the problem is with a motor filter, HEPA filter, or a clog where the hose goes into the unit. If you have good suction on the accessory hose but none on the floor, it's usually in the brush head (clog or broken belt) Good luck

Feb 28, 2010 | Kenmore 35912 / 35913 Progressive Upright...

1 Answer

Kenmore progressive Direct Drive Vacuum w/Hepa


Check the hose and dirt inlet for a blockage. Also the brush roll, check it to see if you can turn it or not by hand. If not, then something may have jammed it.

May 03, 2008 | Kenmore 31913 Progressive Direct Drive...

2 Answers

Dirt devil 12amp,Patent No.6571425


Either it needs a new belt, they stretch and break, then won't turn the brush roll. The dirt inlet by the brush roll is clogged, the hose may have a clog in it, filters are bad. If the hose comes off on one end, is there suction there, is so then the clog is farther down. If no suction, then the clog is in the hose or filter.

Mar 02, 2008 | Dirt Devil 12 Amp HEPA Filter Vacuum...

Not finding what you are looking for?
Eureka Altima Upright Vacuum Model 2996AVS Vacuum Logo

Related Topics:

208 people viewed this question

Ask a Question

Usually answered in minutes!

Top Eureka Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18424 Answers

Jim Parker
Jim Parker

Level 3 Expert

1041 Answers

charlesjo336

Level 1 Expert

8 Answers

Are you an Eureka Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...