Question about Sony XM-2100GTX Car Audio Amplifier

1 Answer

Sony amp I installed a small sony amplifier in my 07 nbs pick up. Everything sounds good ,but i have one problem, i cant get the amp to shut off it stays illuminated and makes the woofers jump,even with the key switch in the off position.I waited one hour for it to shut off,it never did. CAN SOMEONE HELP ME PLEASE! (I can't find a switched accessory wire)

Posted by on

  • jacob keller May 11, 2010

    sounds like you don't have a switched remote wire. where did you get your remote feed?



1 Answer

I simply ran my remote wire to the 15amp fuse for the vehicles radio,that didn't work so i tried drawing enough power from a speaker wire(all @ the advice of my brother)but i got the same results, it just won't shut off.

Posted on Jan 20, 2008


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017


Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

I need a Ford Tech to assist me with installation of Sony Premium Sound System

Around here there are places like (we be audio and video) that install everything from remote starters to ack up cameras.

May 07, 2017 | 2010 Ford F-150

1 Answer

The Cozy Console Pilot flame has been off less than a hour today 07-07 2010 can we wait till the spring time to put back on or call the Gas- company?

Hi, if you are saying that its off now and is it OK to leave it off until spring, yes it is. If you want it to stay off, you can also shut the gas off at the flex line that supplies gas to the unit. Just turn the small handle to the off position, this is just for added safety.
A/C, Heating, & Refrigeration Contractor

Jul 07, 2010 | Cozy Enclosed Front Console Heater 70,000...

1 Answer

How do I remove the driver's door panel on a chevy 2007 nbs?

open door pull ruber boot back on door side unplug wire connections snap lock release on con pull pins pull door

Jun 18, 2010 | 2007 Chevrolet Silverado Classic SS New...

1 Answer

I just got a sony xplod 1000 watt amp i got everything hooked up and when i turned the key the power light chaned from green to red. i check over the amp again and again, i cant find any thing wrong........

Try disconecting all speakers from the amp, turn it on after and if it stays on red it sounds like it had kicked the bucket. if it stays green start from their and check all of your wires for shorts (speaker wires) again. hope this helps...

May 08, 2010 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

Vostro 200 PC freezes on Dell Start up page & won't turn on

If you have windows 7 installed, then see if you can boot to the DVD and run a repair on the OS. You also may want to run a diagnostics on the system if you can get to the F12 menu

Feb 27, 2010 | Dell Vostro 200 PC Desktop

1 Answer

Washburn guitar mg-20 pick up switch position 5 neck pick up no sound or noise humm or anything. all other positions and configurations work?

if everything is standard on that guitar then the only reason that pick up wouldnt work is because its a defective pick up or a wire is disconnected. it may also be possible that the selector switch is bad. take a small screw driver and tap the pick-ups in all positions while plugged in to the guitar amp and the volumes up ( not all the way) just loud enough that you can hear the tapping. you find the bad pick up when you cant hear the tapping with that pick up selected.

Feb 22, 2009 | Washburn Music

3 Answers

Where is the factory amp located in the 2001 Chrysler Town and country?

The amp relay is in the Relay/Fuse box located under the hood. The amp relay is the one labeled NBS which stands for Name Brand Speakers. If you are trying to install an after market radio in a 2001 Chrysler Town and Country, you may notice that no sound comes from the speakers. This is because the single wire that is connected to the factory radio sends a signal to the Bus which tells the relay to turn on - powering the factory amp.

I bypass this by running a wire from the red Acc power wire on the radio to the relay. Connect the wire to pin number 87 on the relay. When standing in front of and facing the van, pin number 87 is the pin, on the NBS relay, which is closest to you and furtherst right.

Are you looking to replace the amplifier? or bypass the speaker wires??

Usually factory amplifiers in vans are under the P/S Front seat. However they can be up under the dash as well (P/S).

If you're looking for it because it is not turning on - check the relay (as above).

Thanks for using FixYa - a FixYa rating is appreciated!

Jan 31, 2009 | 2001 Chrysler Town & Country

1 Answer

Need a lil ore help!!!

If the overcurrent of DC offset lights are not green, the amplifier probably has blown output transistors.

To eliminate other problems, disconnect all speaker wires from the speaker terminals of the amp and disconnect signal cables from the amp. If it powers up normally (all lights green), the wiring needs to be checked. If it still shuts down, the amp likely has blown output transistors.

Jan 05, 2008 | Sony XM-2150GSX Car Audio Amplifier

2 Answers

Amp protection

Hi, Off hand, I believe there is nothing wrong with the setup, maybe just not 100% compatible. It's just that the Sony Amp's protection is doing its job (just too good) and the stock radio is likewise doing it's job (but not too good). Just maybe, at poweron, the stock radio sends out a small burst output (maybe capacitor discharge) that we normally hear as a slight thump in the speakers which was when no Sony amp, ok. However, when you have added the amp, you also amplified the thump, which unfortunately the Sony protection reacts to. You can off course let it be since you have figured out a way to make it work or you can try and install a delay on for the power amp or separate it's power on from the stock stereo. The idea is to turn on the stereo with the Sony off and after a second or less, a manual switch or a delay activated switch will turn on the Sony. The idea is to switch on the Sony after the thump has finished. Good luck and hopes this gives you an idea. Pls post back how things turn up. Kind regards.

Aug 15, 2007 | Sony XM-2002GTR Car Audio Amplifier

2 Answers

Amp protection light

Hi again, Looks like you posted twice, in any case pls have a look at your other post @

Aug 15, 2007 | Sony XM-2002GTR Car Audio Amplifier

Not finding what you are looking for?
Sony XM-2100GTX Car Audio Amplifier Logo

Related Topics:

60 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Car Audio & Video Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

xxxxxx xxx

Level 3 Expert

4905 Answers

Larry Stiles
Larry Stiles

Level 2 Expert

287 Answers

Are you a Sony Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides