Question about Microsoft Office Access 2003 (077-02871) for PC

1 Answer

Problem with macro and On Open procedure

Hi there

I have cut and pasted a procedure to enable me to display pictures on a form and somehow got to be where I am right now with something that sort of works. Don’t ask me how I got this thing working because I have no clue. The fact that it works is truly a miracle of sorts.

There 3 issues which I cannot get sorted out with my extremely limited access knowledge

Firstly, when I start up my database – I get a “Security warning VBA Macro” which never happened before. I think this has to do with the picture procedure that I copied from the supplied site. As I know I should not have any macros in my system, there is probably one now embedded in there somewhere. If this is the correct line of thinking, can you please help me get rid of it.

The second and more irritating issue is when I load my default form: Frm_Contacts_Details_All_Full_Page I get the following error

Access cant find the field “Picture_Location” referred to in your expression.

I have figured out that this must be in an expression on the form properties somewhere, but I’ll be dammed if I can find it. Please help!

And lastly:
Why is it that I can only open Frm_Pictures in the default view whereas all the other created forms, I can open and then select the design view.?

If these problems can be solved by you, I will gladly send you the shell of teh database sa that you can see what I am actually talking about here.Thanks In advance


Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert that got 5 achievements.


    An expert who has written 50 answers of more than 400 characters.


    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 108 Answers
Re: Problem with macro and On Open procedure

Ignore the warning (it's there for your protection). Do a search for your default page and / or insert it into your expression, presumably a script of some sort from (who knows where and being a bit more specific would have helped....grrr). The last problem might be because you have them located in a different area (folder). Check and see. Search (or find) on the name of one that does show and one that does not appear.

Posted on Jan 24, 2008

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

I cannot create a macro in microsoft word 2010

When you open Word 2010, click on the "View" tab. The "Macros" button will be on the far right. Clicking on the button will allow you to create and edit macros.

May 28, 2012 | Microsoft Word 2010

1 Answer

Step by step instructions on how to create a macro, create form f

You can create a macro by using the macro recorder to record a sequence of actions, or you can create a macro from scratch by entering Visual Basic for Applications code in the Visual Basic Editor.
Open a new document.
From the Tools menu, choose Customize.
Click the Commands tab and then scroll down in the Categories box and select Macros. You’ll see the names of any macros you've created in the Commands box on the right-hand side.
Click, hold, and drag your macro onto any toolbar and release, as shown in Figure D. A button with the name of the macro will appear on the toolbar.

May 25, 2010 | Microsoft Office Word 2007 Full Version...

2 Answers

Whenever I open a new spreadsheet now it automatically opens up a spreadsheet calles PERSONAL. Why is that and how can I get rid of it... I think it started after a did a macro but I am not sure. Thanks,...

You're right - it was caused by recording a macro. When you record a macro you are given the option to store the new macro in "This Workbook", a "New Workbook" (the default), or in a "Personal Macro Workbook". It looks like you selected "Personal Macro Workbook".
The recorded macro is stored in a special workbook called "Personal.xls". This workbook is loaded every time Excel is loaded. If you don't want this workbook loaded, then just delete it or rename it.
The file is buried deep in Microsoft's application data area. On my Vista computer it's in C:\Users\frogfund\AppData\Roaming\Microsoft\Excel\XLSTART On my Windows XP computer it's in C:\Documents and Settings\frogfund\Application Data\Microsoft\Excel\XLSTART. Depending on your computer your Personal.xls might be in a slightly different location. You might need to do a search using Windows Explorer.
If you are still having troubles finding personal.xls 1. Open Excel, 2. Open the Visual Basic editor (hit Alt-F11 or click Tools-Macro-Visual Basic Editor) 3. Click Tools-References to bring up the references dialog 4. Click on VBAProject in the list. The file location will be displayed near the bottom of the dialog box. Sometimes this might be cut off at the end, but it should give you a good idea where the file is located. 5. Click Cancel to close the dialog.

Sep 23, 2009 | Microsoft Office Excel 2003 for PC

1 Answer

Missing pdf maker files

Solution Remove Adobe PDF from the Disabled Items list in the Microsoft Office application. To manage your Disabled Items list in a Microsoft Office application:
  1. Open the Microsoft Office application (Word, Excel, Publisher).
  2. Choose Help > About [the application name].
  3. Click Disabled Items.
  4. Select Adobe PDF from the list, and then click Enable.
  5. Quit the Microsoft Office application, and then restart it.
View an Adobe Captivate demo of this procedure
If the error message continues to appear after you enable Adobe PDF, then check the security level for macros in Word:
  1. Choose Tools > Macro > Security.
  2. In the Security dialog, click the Security tab.
  3. Choose Medium or High.
  4. Do one of the following:
    • If you chose Medium, then click OK.
    • If you chose High, then continue with steps 5 through 7.
  5. Click the Trusted Publishers tab.
  6. Check Trust all installed add-ins and templates.
  7. Click OK.
PDFMaker and the right-click context menu should function again.
View an Adobe Captivate demo of this procedure


Apr 02, 2009 | Adobe Acrobat® 8.0 Professional Full...

1 Answer

Problem opening Access Database-upgrade from Access 2003 to 2007

if the form "products" really exists, then your office 2007 security settings are not allowing to load macros. Try the following settings:-

Office 2007 has some security settings disabled by default to prevent any harm to your system.

go to trustcenter settings(click the office button at the top left of the office 2007 screen then click Access options, then select Trustcenter, then click trustcenter settings.)
In trustcenter settings, select message bar then select "Show the message bar in all applications when content is blocked" radio button.

Then from macro settings ,make sure to select "Disable all macros with notification" . Click ok twice to close the settings windows and try opening the file again.

Good Luck

Mar 25, 2009 | Microsoft Access 2003 for PC

3 Answers

Problem opening Access Database-upgrade from Access 2003 to 2007

It seems that you have your Database(.mdb) file is created in Office 2003.... thats why you are unable to open it in 2007.... I faced the same problem.... then I came back to 2003 in order to use our database......

Mar 25, 2009 | Enfocus PitStop Professional 08 Full...

1 Answer


Hi alwinkumar

You can set a default value in most form items under the properties of that item. Look for "value". You can also do this in code, by setting up a sub routine to set/reset the values on your form. Then just run the sub routine before you open or enter the form.

Private Sub resetForm()

'formname.itemname = value
UserForm1.Label1 = "Hello World"

End Sub

For the second one you have a couple of options, you can find the bottom on the data and store the row index in a variable, use a loop to find the next empty cell in a row, and store the value or you can use the current region method to select all the cells with data continously touching the selected range. Example below

numberOfRows = Sheet1.Range("A1").CurrentRegion.Rows.Count

Jul 16, 2008 | Microsoft Office Professional 2007 Full...

1 Answer


Hi motilal

Follow these steps to create multiple macros

Click the Microsoft Office Button , and then click Excel Options.
In the Popular category, under Top options for working with Excel, select the Show Developer tab in the Ribbon check box, and then click OK.

Note The Ribbon is a component of the Microsoft Office Fluent user interface.
To set the security level temporarily to enable all macros, do the following: On the Developer tab, in the Code group, click Macro Security.

In the Macros Settings category, under Macro Settings, click Enable all macros (not recommended, potentially dangerous code can run), and then click OK.

Note To help prevent potentially dangerous code from running, we recommend that you return to any of the settings that disable all macros after you finish working with macros.
Open the workbook that contains the module that you want to copy and the workbook that you want to copy the module to.
On the Developer tab, in the Code group, click Visual Basic.
On the View menu, click Project Explorer .
Drag the module that you want to copy to the destination workbook.


May 06, 2008 | Microsoft Excel for PC

1 Answer

Macros Help PLZ

Change the file ending back to .xls, open the file, enable macros, then try renaming the file to the new extension.

Mar 14, 2008 | Microsoft Excel for PC

1 Answer

View Reports

Hi, There a couple of different way you could do this and I have put two lots of VB code below that you can modify and use. Firstly you create the Combobox list by choosing the option that you will type the values yourself, you then type in all your report names on each line. After that you can then go to the VB code editor and paste my code in and modify it by changing my report names, (Customers) etc to your report names. Make sure you choose the Combobox and the On_Click option in the VB editor to paste the code into.  I like the first method better which checks the value of the Combobox and then opens the corrosponding report in the maximised form. The second method does the value check before running an assigned macro to open each report. With this you must first assign macros to each report in Access.  Remember each of these bits of code must be placed between the "Private Sub" heading and the "End Sub" ending, and change the "Combo23" name to reflect your combobox too. If you need a hand just email me.

First Method
If Combo23.Value = "Customers" Then
    DoCmd.OpenReport "Customers", acViewPreview, acWindowNormal
ElseIf Combo23.Value = "Customers 1" Then
    DoCmd.OpenReport "Customers1", acViewPreview, acWindowNormal
ElseIf Combo23.Value = "Customers 2" Then
    DoCmd.OpenReport "Customers2", acViewPreview, acWindowNormal
End If

Second Method
If Combo23.Value = "Customers" Then
   DoCmd.RunMacro "Macro1"
ElseIf Combo23.Value = "Customers 1" Then
    DoCmd.RunMacro "Macro2"
ElseIf Combo23.Value = "Customers 2" Then
    DoCmd.RunMacro "Macro3"
End If

Oct 28, 2007 | Business & Productivity Software

Not finding what you are looking for?
Microsoft Office Access 2003 (077-02871) for PC Logo

36 people viewed this question

Ask a Question

Usually answered in minutes!

Top Microsoft Business & Productivity Software Experts

Brian Sullivan
Brian Sullivan

Level 3 Expert

27725 Answers


Level 3 Expert

18258 Answers

Sudeep Chatterjee
Sudeep Chatterjee

Level 3 Expert

3267 Answers

Are you a Microsoft Business and Productivity Software Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides