Question about Car Audio & Video

2 Answers

Blown car amp repair (Lanzar Opti 150 stereo bridgeable car amp)

I have a Lanzar amplifier, an OPTI 150. It is driving a Lanzar DC12 sub in bridged mode. The amp has blown twice, so I do not have faith in the repair capabilities of the dealer (South Africa) who sold it to me anymore. I'd like to repair it myself. 1. Info: a) I have determined that two IRF540's on the right channel (one on the push side, one on the pull side) have blown short-circuit. Having removed these, the left channel plays fine. b) I have an oscilloscope, multimeter and signal generator. 2. Questions a) Can I replace only these 2 Mosfets, or should I replace all 20 with mosfets from the same batch? b) What else do I need to check (in terms of setting variable resistors etc for proper calibration) after replacing the components?

Posted by on

Ad

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Novelist:

    An expert who has written 50 answers of more than 400 characters.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 218 Answers

Make sure your speaker load is correct before you blow your amp again after repairing it. I suspect that is why it keeps on blowing.

Posted on Jan 18, 2008

Ad
  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Expert
  • 107 Answers

Its better to change them all. than to change 1 or 2 mosfets, bcuz simetimes it affects the other mosfets. and please check your speaker or maybe there is an resistor, capacitors, or a relay malfunctioning in that area.

Posted on Jan 18, 2008

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Dropped me a red flashlight.The problem is ?


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty. Time to get yourself an old school Lanzar Opti Drive amp .A thumbs up would be greatly appreciated if this answer is helpful to you. dropped-me-red-flashlight-problem-shonxoarcym4awy4zl1imx4o-2-0.jpg Lanzar

Jun 26, 2011 | Lanzar Vibe 530 Car Audio Amplifier

1 Answer

I just bought a old school lanzar opti 50c amp but i need to know what is the postive and negtive for the speaker output and what one is for bridgeing?and what is the spec? what is the lowest ohm i can go


the 50 C was used as a cheater amp back in the 90. You will be shocked by what this thing is capable of doing you can run an entire system subs mids and highs off of this 50 C. About 1300 watts

Jun 19, 2011 | Lanzar OPTI 50c Car Audio Amplifier

3 Answers

I have a Lanzar 4000 watt amplifier hooked up to 2 12inch MA Audio subs. When I crank my car the green power light on the amplifier comes on, but after a second or two it changes to protection mode. I have...


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty. Time to get an old school Opti Drive. .A thumbs up would be greatly appreciated if this answer is helpful to you. lanzar-4000-watt-amplifier-hooked-up-2-shonxoarcym4awy4zl1imx4o-2-0.jpg Lanzar

Jan 29, 2011 | Lanzar VIBE286 Car Audio Amplifier

1 Answer

I have a lanzar opti drive plus 500 old school,i have 2 12'' 1200 watt pyles,running in parallel at 2 ohm. when i bridge it at 2 ohm 1000 watts it blew my 40 amp in line fuse.


The 40 amp fuse is too small. 1000 watts = 12 volts @ 83 AMPS. Bigger power wire my friend. If you want to sell, let me know.

May 15, 2010 | Car Audio & Video

2 Answers

I have a Lanzar Vibe 235 amp. the green power light is not coming on, but the red "protect" light is. how do i solve this problem??


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty. Time to purchase an old school Lanzar Opti Drive. Any of them. The 50 will kill some 12" subs .A thumbs up would be greatly appreciated if this answer is helpful to you. lanzar-vibe-235-amp-green-power-shonxoarcym4awy4zl1imx4o-2-0.jpg Lanzar

Mar 11, 2010 | Lanzar Vibe 235 Car Audio Amplifier

2 Answers

Lanzar 800 watt amp protect mode stays on


protect mode usaully means that something has disrupted the power of feed lines to the subwoofer/speakers possibly fuse is blown in amp or amp is blown in which we hope not. see if you have a warrenty if blown and send back or bring it to where you purchased it from.

Aug 01, 2009 | Lanzar VIBE266 Car Audio Amplifier

1 Answer

How 2 bridge tha opti drive 1222d 12inch subs 2 the opti 600x2hc


You can check Both Crutchfield's learning center on subwoofer wiring diagrams and www.the12volt.com with their wiring diagrams. The crutchfield setup will be more informative for this type of problem. Just go one of the + to one of the - on each sub then wire the other plus's together between the subs as well as the minuses like between the subs and use the open plus and minus that u didn't just bridge. Then there should be just 2 wires a plus and a minus to the amp. Then follow the amp bridge wiring which should be found right above the speaker terminals it will be left plus to right minus or the other way around

May 05, 2009 | Car Audio & Video

2 Answers

Lanzar amp 1000 watt stays on protect mode


Hello snow11879,

I haven't been able to locate any support information online about your product, other than the email contact for support questions:

support@lanzar.com

If the amp stays in protect mode all of the time, I would suspect a short in the speaker wiring or speaker(s) voice coil(s), or perhaps a faulty ground. If it plays for a short period of time and then goes into protect mode, it is most likely overheating. First check all of the wiring. Test your speakers on a known good amp and make sure there are no places in your wiring where the insulation may have been damaged, causing an intermittent problem.

Many owners have reported that this particular amp has a tendency to overheat. Also, when run in bridged mode, the speaker impedance needs to be at least 4 ohms. It will overheat if the impedance is below 4 ohms.

Hope this helps.

Apr 18, 2009 | Lanzar VIBE266 Car Audio Amplifier

1 Answer

Please save my 50c


sounds like inputs are blown or channell blown!!! are you running high output preamp???
either way cheap fix,i had to repair a few of the opti inputs last summer for a customer if you need more info drop me a line 574-220-0162 Randall

Nov 18, 2007 | Lanzar OPTI 50c Car Audio Amplifier

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

399 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4963 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

yadayada
yadayada

Level 3 Expert

80417 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...