Question about Car Audio Receivers

2 Answers

Amp only turns on in cd mode

Hello i was just wondering if u can help me out i just installed an aftermarket head unit into a 1993 Olds cutlass superme and it seems that it only the amp wants to turn on when cd is on but cd only reads error so i am not sure if the head unit it is done or maybe a wire is maybe messed but i hope u can let me know cause the radio stations suck here lol but anyways good luck and thanks for ur time

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers
Re: amp only turns on in cd mode

A little late but a late answer might be better than none at all. The wrong wire most likely is being used for the amp turn on switch. Verify that you are using the correct wire for the remote/ amp turn on.

Posted on Oct 02, 2009

  • Level 1:

    An expert who has achieved level 1.


    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 11 Answers
Re: amp only turns on in cd mode

Was the head unit new if take it back if not get a new one good luck

Posted on Jan 20, 2008

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer


If you are referring to installation and have the aftermarket wiring harness, The wires should be color coded. RED, YELLOW, & BLACK are power, ignition and ground. These should correspond to matching wires on the back of the head unit (CD player). Match the colored wires from the back of the unit to the same colored wires on the aftermarket harness and then connect them using wire connectors/wire nuts. Once you have them into the correct order the aftermarket harness should connect into the harness in your vehicle. I hope this answers your question =)


3 Answers

Cd player dosen't play with amp

hmmm...what cd player are you using?..

May 03, 2008 | Kenwood KDC-MP828 CD Player

2 Answers

Alpine head unit CDE-9870 will not play sound through speakers of a 2003 pontiac vibe. what could be some issues to cause this?

This generation of Vibe may have the upgraded audio system installed from the factory. In order to get the audio from an aftermarket radio to play through the factory amp, the factory remote turn-on lead must be located. If you are using an adapter harness, it may have the wire installed, just attach the blue/white stripe wire from the Alpine to the blue or blue/white stripe wire on the aftermarket harness adapter.

Mar 01, 2011 | Alpine CDE9870 CD Player

1 Answer

I just installed a sub and it only is working for

there should be two blue wires. one solid blue and one with a white stripe. if i remember the solid should be antenna remote and the blue with white stripe is the amp remote turn on. if you are using the power antenna,it will turn off the amp when not in radio mode.

Mar 08, 2010 | Sony CDX-GT420IP CD Player

1 Answer

Amp turns on with the tuner setting and plays, when i switch to ubs mode the amp shuts off

Hello daweeksy115x,

You did not specify your install specifics, but the trouble is probably the head unit "remote turn-on" lead. Some head units will have both a power antenna and a remote lead. If you inadvertently wired the amp turn-on to the power antenna lead, it can cause the problem you described.

If you head unit does not have a dedicated remote lead, the best solution is to wire the amp turn-on terminal to a switched accessory 12V source.

Hope this helps.

May 24, 2009 | Alpine iDA-X200 Car CD/ MP3 Player

1 Answer

Aftermarket installation of head unit in 97 jeep grand cherokee

well, if you go to you can find everything you need for way cheaper than a 100bucks. i own the same jeep and have installed everything without bypassing my sounds great. just check that site out and give them a call. they will hook you up

Mar 01, 2009 | Cherokee (REF) AM/FM Stereo with CD Player...

1 Answer

Installing a nokia handsfree kit to my car

what is the make and model of the head unit - not many aftermarket radios have a mute line input

Nov 21, 2007 | JVC KD-S6060 CD Player

1 Answer

Kenwood kdc-mp528 amp/speaker problem???

This is a common mistake. This problem indicates that you are using the solid blue wire from the head unit to the remote turn-on on the amp. This is a power antenna wire that only receives power when on FM radio. You need to replace this with the Blue & White wire from the head unit (power control wire) to your remote turn-on on your amp. This should solve your issue.

May 12, 2007 | Kenwood KDC-MP528 CD Player

1 Answer

My l/o works but my speakers running from head unit does not

You have to find the subwoofer setting on your head and turn it all the way up.

Aug 26, 2006 | JVC KD-G320 CD Player

Not finding what you are looking for?
Car Audio Receivers Logo

Related Topics:

123 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio Receivers Experts

xxxxxx xxx

Level 3 Expert

4679 Answers


Level 3 Expert

56798 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you a Car Audio Receiver Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides