Question about Projection Televisions

1 Answer

No Picture/Sound I have a sony grand wega KF-60XBR800 after I turn it on the sound and picture goes out for approx 15-30 seconds then comes back on, the picture looks good sound is good then 1-2 minutes later it goes out again.the stand-by red light is flashing every second the picture is out. Is it the bulb ? does it need replacing again I just replaced it less then two years ago. My friend got the same TV at the same time and has never replaced the bulb ?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.


    An expert whose answer got voted for 500 times.

  • Master
  • 4,402 Answers
Re: No Picture/Sound

Can you go to the error menu?
im assuming it's the lamp however the error menu will tell me more
If the standby light blinks five times repeatedly, that's indication of a "Lamp driver error". The probable cause listed is, "lamp driver faulty". Its also possible that the internal antenna used to detect the presence of high voltage has become mis-positioned. The lamp driver provides the high voltage. If no high voltage is detected, it is assumed that the lamp driver is faulty.
Otherwise, it is assumed that the lamp is bad and the LAMP LED lights
the part number for the lamp is XL2000U. Its available for $200 at Use the Part or Accessory Number to locate the part.

Posted on Jan 17, 2008

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Sony Grand WEGA KF-60XBR800 Service Manual

Lamp/Bulb A1601-753A (XL-2000U) .

Apr 29, 2014 | Sony Grand WEGA KF60XBR800 60" Rear...

1 Answer

My Sony KF-60XBR800 has sound but no picture and i have a faint glow on my screen

I would re check your steps. If you have a harness that is not hooked up, that is bad. It goes some where.

May 10, 2012 | Sony KF-60XBR800

1 Answer

I have a Sony Grand Wega KF-42WE610. When turned

there is a 12v cable to main board it prob has a dry joint

Oct 31, 2009 | Sony Grand WEGA KF60WE610 60" Rear...

1 Answer

Sony Grand WEGA KF-50WE610 LED blinks 4 times

4 times blink shows Temp Error and requires temperature sensor replacement in Sony KF-50WE610 TV

May 21, 2009 | Sony Grand WEGA KF50WE610 50" Rear...

1 Answer

Sony kf-42we610 does not come on, makes clicking sounds in back, no picture

sony kf-42we610 does not come on, makes clicking sounds in back, no picture

Apr 21, 2009 | Sony Grand WEGA KF42WE610 42" Rear...

1 Answer

Sony Grand WEGA, Sound on, but no picture

Please replace Lamp in TV and I would recommend to buy Sony genuine Lamp from Sony Accessories, type mode number in search box and find Lamp in list, price would be approx $200

Dec 16, 2008 | Sony Grand WEGA KF60WE610 60" Rear...

1 Answer


The first thing to check is for dry solder joints on all parts of the circuit board you are having problems with, but as for that popping sound more often than not it is caused by a faulty capacitor somewhere. Hope this helps.

Aug 22, 2008 | Sony Grand WEGA KF60XBR800 60" Rear...

1 Answer

Sony KF-60WE610 Screen and Sound On/Off

All symptoms in your TV shows that you need to replace its Lamp as it has been consumed its life hours and TV requires new lamp. Lamp can be obtained from Sony Website. Price is $200, Hope this info will help you to enjoy your Sony TV in coming days.

Aug 17, 2008 | Sony Grand WEGA KF60WE610 60" Rear...

Not finding what you are looking for?
Projection Televisions Logo

Related Topics:

422 people viewed this question

Ask a Question

Usually answered in minutes!

Top Projection Televisions Experts

Jaime Hernandez

Level 3 Expert

2267 Answers

matt martin
matt martin

Level 3 Expert

1187 Answers


Level 3 Expert

56631 Answers

Are you a Projection Television Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides