Question about Cobra DC5600 Digital Camera

Open Question

I have a Cobra DC550

Ok my husband got it for me in dec. of 2006. Ok I hadnt never used the flash on it until dec.2007 at parents house for christmas. Anyways when I used the flash it went hay wire. I had brand new batteries in it before I use it. And when I tried to use it wouldnt do nothing. The green light was on but the flash wouldnt work on it. And when I contacted the manufacturing company they couldnt do nothing about it cause it didnt have no warranty. The warranty had ran out. But what I was wondering if it needs a new bulb or something.

Posted by on

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


1 Points

Related Questions:

1 Answer

Cobra MD210 flashgun on Nikon D90

Take care. Nikon does warn every user of the modern DSLR's not to use old flash guns. Old camera's were fitted with mechanical switches. In those days nobody cared about 5, 12 or even 100 volt on a flash gun. Modern camera's use electronic switches (transistor) and they only can survive when hooked up to modern flash guns, because these guns block high (above 5 Volt) voltages.

Nov 04, 2013 | Nikon Digital Cameras

1 Answer


Hi ill have a look now for you and let you know what you need to do ok bare with me for few minutes ok

Feb 12, 2008 | Cobra Digital DC6550 Digital Camera

2 Answers

Lens Error on Nikon Coolpix S550

Try to hold the camera with your right hand with its lens facing the ground. Then tap the camera's base to your left palm while you are pressing the power on button. Do this several times. If this does not work, then try to avail the warranty to avoid further cost.

Feb 27, 2010 | Nikon Coolpix P1 Digital Camera

1 Answer

I have a Cobra camcorder.It came with 2 memory cards, one that records 16 minutes, and the other that records about an hour and a half. I put the chip in that had more space and went to use it at my...

first see if the card has any device for locking on it ...than if you can put it on the computer ...just do it and format the card ...(go to my computer ...find it ..right click on it ...and format ...) try to see if the card is ok in the camera after that ...
if the camera have formatting memory unit in the menu ..u can use even from there ...

Dec 24, 2009 | Cobra Digital DVC960 Digital Camera

1 Answer

Christmas lights

No flash and set the shutter a little slow also use a camera stand if possible!

Dec 17, 2008 | Kodak EasyShare C743 Digital Camera

2 Answers

Canon A640 flash problem

I sent my camera into Canon for repair. They said the flash was malfunctioning, and there was something wrong with the flash exposure control. The repair cost about $87. It took approximately 10 days from the time I sent the camera in until the time I got it back.

Jul 11, 2008 | Canon PowerShot A640 Digital Camera

1 Answer

Sony dsc-w50 flash going off before or after shutter has opened and closed

hi there
you can try doing this and it should work and solve the problem for you

  1. Press Menu button
  2. togle across from REC Mode to setup
  3. togle down three times from camera to setup 1
  4. togle across into sub menu
  5. togle down from four times to Initialize
  6. togle across again to the sub-menu
  7. togle up from cancel to OK
  8. press center button to accept the OK choice
  9. Screen changes and so press okay again
  10. It should restart the camera
  11. Opening on the 'Clock Set' screen
  12. togle down to cancel and use the camera and make sure that you have the camera to flash, if it works try again in the Auto function.
  13. If it is still not working do not worry follow the steps again two or three more times, As this is generally a software error message and

Jan 20, 2008 | Sony Cyber-shot DSC-W50 Digital Camera

2 Answers

FE-280 Olympus

u did see this after pic below, and you have tried deleted usb controllers in device manager then reboot c5374dd.jpg can u tell me if, cam lights up/does windows make a connection sound, when usb from cam is connected? posted by Jordiane on Nov 18, 2007 Report abuse

It says it is unable to find a camera connected to the USB ports. Any idea where I could find a driver to help this or is it another problem?
Have the same problem? Click Here
6 Other Users Have The Same Problem Comment by Emilie, posted on Nov 21, 2007 The display doesn't turn on when the camera is turned on unless I switch the mode on the dial. The camera turns off when I toggle the zoom.
Comment by Guest, posted on Nov 29, 2007 Zoom does not work
Comment by Guest, posted on Dec 27, 2007 I receive the message the software was unable to find an Olympus digital camera conected to a USB port on your computer.
Comment by petedrum, posted on Dec 23, 2007 Same Problem. Tried it on two XP computers, can't find camera on either. Camera lights up when plugged in.
Comment by Kellib, posted on Jan 01, 2008 I'm having the exact same problem with my camera. i can't figure anything out with it and if i plug the usb into the computer, i hit ok for PC and then my computer freezes. someone please please help me figure this out
View All Best Solution posted on Dec 24, 2007 2%20stars.png
noavatar_s.png Mickoolz
Rank:nonexpert_s.gif Apprentice
Rating: 70%, 3 votes

I had this same problem, I'm using Vista on my HP laptop and I managed to correct it. Apparently HP like to customize Vista and when connecting some USB device's they don't recognise them as what they should. A USB mass storage device. You will need to connect the camera to the computer, the camera will come on then click the ok button so it selects PC. Wait until it finishes its search click cancel and open device manager, scroll down and below Network Adaptors you should see an expandable tree with an yellow exclamation mark named Portable Device's --> FE-280/X820/C520 you will need to right click on the FE-280/X820/C520 icon and select "Update driver software". Then select "Browse my computer for driver software" then select "Let me pick from a list of device driver's on my computer" Scroll down till you see "Universal serial bus controllers" then select "USB Mass storage device" in the next window. It should all work fine now! If it still doesn't work try selecting "Portable devices" then select "WPD File system device" --> "Microsoft WPD filesystem Volume Driver".
Hope it helps.

Cheers, Mick
Was this solution helpful? Show your Appreciation by rating it:

Jan 04, 2008 | Olympus FE-280 Digital Camera

Not finding what you are looking for?
Cobra DC5600 Digital Camera Logo

Related Topics:

34 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cobra Digital Cameras Experts


Level 3 Expert

94267 Answers

Jim Goldsmith
Jim Goldsmith

Level 3 Expert

1869 Answers

ray gallant

Level 3 Expert

34739 Answers

Are you a Cobra Digital Camera Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides