Question about Logitech X-530 Computer Speakers

1 Answer

My logitech speakers are not working - Logitech X-530 Computer Speakers

Posted by on

  • Edgardo Burgos Rodriguez

    check the cables, if they are properly good. For good example, if you read the manual, how this think sound. Is the cable are..

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 51 Answers

Have you got any more information on what is/isn't happening? No power, power lights on but no sound etc?

Back when I worked for a company that sold Logitech speakers the most common faulty with the X series was a small fuse that would blow. Usually the speakers would appear to receive no power at all if this was the case.

It's a $10 part if your speakers are out of warranty. Sometimes Logitech may even send this part out for free. Check your warranty though, in some countries there is up to 2 years on these speakers.

If it's a different problem, a little more information on the problem may help the FixYa community to give you some better advice.

Posted on Nov 20, 2009

  • dave Sep 06, 2012

    So where is the fuse located?

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

It seems that my logitech LS11 have not been working, my head phones work but when i plug in the speakers they dont seem to work


i assume that you have had these speakers a couple months now. by this time the design already starts messing up .... buzzing speakers, not working, as you can tell from this sight no one is happy with these speakers. http://reviews.logitech.com/7061/4252/logitech-ls11-speakers-reviews/reviews.htm by this time most people pretty much garbage it anyway.

Jul 01, 2011 | Logitech LS11 Speaker 2 Speakers

1 Answer

Logitech z-2300 subwoofer not working


ahh logitech always the sub that goes. its buggered but dont toss out the whole speaker set just buy another one and youl have spare speakers when you need them

Jul 28, 2010 | Logitech Z-2300 Computer Speakers

1 Answer

Speakers not working when reconnected to pc


How do I get hold of the necessary graphics driver?

Apr 18, 2010 | Logitech X-540 Computer Speakers

1 Answer

I have the logitech z560, sub works but none of the satellite speakers work


Hi, I suggest you to contact the Logitech support for a replacement this is an hardware failure and it's covered by warranty terms.
US/Canada support: http://www.logitech.com/en-us/contact
European support: http://www.logitech.com/en-gb/contact
Thanks and have a nice day ! J -

Feb 01, 2010 | Logitech Z-560 Computer Speakers

1 Answer

Logitech Soundman S-20 speakers not working after Op Sys reload


Hi Aceofmktg,
go to start menu, control panel, sound. Then here go into the Tabs and select the Speakers. Apply, Done !
If it does not work, then I suggest you to contact the Logitech support for a replacement this is an hardware
failure and it's covered by warranty terms.
US/Canada support: http://www.logitech.com/en-us/contact
European support: http://www.logitech.com/en-gb/contact

Jan 27, 2010 | Logitech SoundMan S-20 Computer Speakers

1 Answer

Where can I get repair for Logitech Z2300 speaker system? The yellow input to the amp doesn't work - both speakers will work in the other input


Contact Logitech - their information is here:
http://www.logitech.com/index.cfm/support_downloads/support_contactus/&cl=us,en

If it's under warranty, they'll likely be able to replace it.

Dec 11, 2009 | Logitech Z-2300 Computer Speakers

1 Answer

I have logitech x-120 speakers and cant get any sound out fo them


I have logitech 530 speakers, can only get 2 speakers and sub to work. Just installed new sound card. When I run a test on all speakers they work, till i try to listen to music, then only 3 work

Mar 09, 2009 | Logitech X-530 Computer Speakers

1 Answer

Vista, logitech 2.1 speaker problem.


my 2.1 logitech woofer doesnot work.... wat to do..

Nov 29, 2008 | Logitech : X-220 2.1 SPEAKER SYS Computer...

1 Answer

Speakers not registerying as a hard ware and is not working


Try going through this troubleshooting procedure site first: http://logitech-en-amr.custhelp.com/cgi-...*uWZ8vi&p_accessibility=0&p_lva=&p_sp=cF9zcmNoPTEmcF9zb3J0X2J5PSZwX2dyaWRzb3J0PSZwX3Jvd19jbnQ9NzgmcF9wcm9kcz04NDQsMTcmcF9jYXRzPSZwX3B2PTIuMTcmcF9jdj0mcF9zZWFyY2hfdHlwZT1hbnN3ZXJzLnNlYXJjaF9ubCZwX3BhZ2U9Mg**&p_li=&p_topview=1 If you get no solution from this, there are other similar logitech speaker systems that have had similar problems on initial models. it appears that logitech have been very helpful with replacing speakers in the past if design is faulty. Give them a try.

Feb 15, 2007 | Logitech S-100 Computer Speakers

Not finding what you are looking for?
Logitech X-530 Computer Speakers Logo

Related Topics:

1,098 people viewed this question

Ask a Question

Usually answered in minutes!

Top Logitech Audio Players & Recorders Experts

kakima

Level 3 Expert

102366 Answers

gunzmith

Level 1 Expert

27 Answers

Henry  Thomas
Henry Thomas

Level 3 Expert

1074 Answers

Are you a Logitech Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...