Question about Sony Xplod 1200W Class AB Bridgeable 2-Ch. Amplifier w/Variable Low-Pass Crossover

2 Answers

I have 2 1300 watt 12inch subs connected to a 2 1/2 channel 1200 watt amp. but when I bridge my speakers my amp goes into protection mode. is there a resolution to this

Posted by on

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 8,546 Answers

It's trying to tell you the impedance is too low when you bridge. Run the speakers in series, not parallel.

Posted on Nov 20, 2009

Ad
  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

You need to make sure your ground is hooked up good and if it is your running your subs lower than 4 ohms wich you need to bridge your subs all two channel subs need at least 4ohms

Posted on Dec 22, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

I have a Lanzar 4000 watt amplifier hooked up to 2 12inch MA Audio subs. When I crank my car the green power light on the amplifier comes on, but after a second or two it changes to protection mode. I have...


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty. Time to get an old school Opti Drive. .A thumbs up would be greatly appreciated if this answer is helpful to you. lanzar-4000-watt-amplifier-hooked-up-2-shonxoarcym4awy4zl1imx4o-2-0.jpg Lanzar

Jan 29, 2011 | Lanzar VIBE286 Car Audio Amplifier

1 Answer

I have a 1200 watt G-Max sub amplifier and it just went into protect mode


Turn down the volume or power settings on it since its pulling too much power and shutting off for a few sconds to keep from blowing. Depending on the amp and speakers your using dont bridge the channels. If it won't come out of protect mode then unhook everything and just hook power, ground, and remote and wee what happens. If it comes on again and stays on then amp is blown.

Aug 11, 2010 | Jl Audio Car Audio & Video

1 Answer

I Have a Sony Xplod 800 watt amp and 2 12 inch Sony Xplod subs


You should definately bridge them. Firstly, lay the 2 speakers face down next to each other. Note the connections +- +-. The first + will go to the amplifier. The next terminal(-) will be connected to the next speaker(+). Take the last(-) and connect to amplifier. Please note that your amplifier has a bridge section which is normally the first + and the last- on the two channels. Connect your woofers on the bridge.

May 28, 2010 | Sony XM-ZR1252 Car Audio Amplifier

1 Answer

How can i bridge a mtx 9500 using a mono amp?


You cant bridge it to the MONO AMP . You can only bridge subs & speakers to 2 CH & 4 CH AMPS that are bridgeable. Because if it appears that there is 2 channels on a Mono amp its so its convenient for you to hook up 2 4ohm subs to it easily But both channels are actually connect internally together in parallel inside the amp unlike a 2 channel they are separate.

So just connect your mtx 9500 to a plus and a minus and doesnt matter which since all the + terminals of are connected together and - are connected together already.

Whats important is on the side of the sub/box it reads 2 ohms. The lower the ohms the more power the Mono amp will put out. Mono amps are designed to handle 2ohm loads.

If it reads 4ohms The MONO amp is the wrong amp to use cause the power will be weaker. So if you have a 1000 Watt Mono amp at 4ohms the sub will only get 500 WATTS Max while a 2 ohm will get the full 1000 Watts.

If it reads 4 ohms connect it to a 2CHANNEL AMP and BRIDGE IT (connect + of the sub to 1st channels positive of the amp then connect - of the sub to 2nd channels negative of the amp) . The power will be doubled when you bridge it on a 2 channel amp. NOW if it was a 2 ohm sub and you bridged it to the 2 channel amp it will fry the subs and ruin the amp. 2 CHANNELS CANT TAKE A 2OHM LOAD BRIDGED OK.

Apr 08, 2010 | MTX (SLH-T7512X2-A) Car Speaker

1 Answer

Wiring diagram for sony xplod amp and how to bridge one


if you have the model number handy i can tell you

but most sonys are marked like this ..

+12v goes directly to the + termanl on the battry
GND goes to a solid metal object on the car (ground)
REM remote turnon goes to the remote turn on from your headunit

unbridged speaker outputs
+L positve left speaker
-L negative left speaker
+R positive right speaker
-R negative right speaker


ok to bridge a amp (must be capabul of doing so) look for a mono switch and set to mono ..

then take the +L channel put it to your subs + and take the -R channel and put it to the - of your sub

also set the cross over switch to LPF if your running bridged for a sub

if that is a bit hard to understand msg back with the model number of the amp and i can get u the orignal manual for the wireing diagram

hope that helps

Jan 26, 2010 | Sony Z2X-1200 SPL Car Amplifier (1200...

1 Answer

Amplifier loads


Hello ronnieyannon,
A single 4 ohm speaker wired to each channel, like you have them wired, presents a 4 ohm load. And it appears that you have them connected properly. The 401s is only stable to 4 ohms when bridged, so if you were to parallel the 2 4 ohm subs in bridged mode, the load would be 2 ohms and the amp would most likely overheat and go into protection.

I'd wire them the way you have them wired.

Each channel of the amp outputs only 100 watts into 4 ohms. That is adequate for regular full-range speakers, component speakers, mid-range drivers, and even some small subs. But it is a little low on power for most subwoofer applications.

Hope this helps.

Apr 22, 2009 | Rockford Fosgate Punch 401S Car Audio...

1 Answer

How do i bridge 3 subs to a 4 channel amp


My information shows the XM-1652Z as being a 2-channel amp. It will not be stable below 4-ohms in bridged mode. For best power, your subs will need to be 2-ohms with all 3 wired in series. This will present a 6-ohm load to the amp. After wiring the subs in series, connect the positive speaker wire to one channel (+) and the negative speaker wire to the other channel (-). For the 1652Z no other wiring is necessary. For subs you will also want to set the LPF (80Hz) switch to the "ON" position (to the right).

Keep in mind that the rated output is only 400 watts RMS at 4-ohms in bridged mode. That's kinda wimpy for 3 subs. You would probably obtain better results from two 2-ohm subs, each connected to a separate channel. That way each sub would be getting 200 watts RMS, still low but there's lots of good subs that will sound pretty loud with 150-200 watts

Mar 25, 2009 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

2006 12" Kicker L7 4 ohm


first whats the range in terms of WATTS that your 12" sub can handle in 4 OHMS ? second , lets check the AMP , POWER ACOUSTIK 1800 WATTS , Now thats a lot of power to drive a single 12" sub speaker . your amp is 1800 watts , per channel is around 500 watts , if BRIDGE thats around 1600 watts rms for ONE channel , if your sub can handle that kind of wattage fine , but it will not blow the amp , what it does is shuts down , some kind of protection mode , it will come back on after a minute or so. I suggest to use one channel in stereo mode , or purchase another sub to use the other channel. i hope this helps AJ

May 06, 2008 | Kicker 06ZX750.1 Car Audio Amplifier

1 Answer

Low amp output


Make sure the BOSS isn't in "Protected" mode (Red led lit) and connect the speakers properly (check the connections if they are in "bridged" mode).
Also, make sure you set the cross-over, bass boost setting, bass volume control and the bridge mode according to the speakers you are connecting. Check the input level too.
The BOSS amplifiers are of very poor quality and it can be easily broken. Maybe yours is broken.

Feb 15, 2008 | Jl Audio E2150 Car Audio Amplifier

1 Answer

Protection mode override


If you have your subs wired to the amp in a bridged configuration, try wiring one to each stereo channel instead. Also, make sure your ground wire is secure and connected to a clean, solid metal part of the vehicle body with the paint scraped off. If this doesn't work, disconnect both subs and try connecting only one at a time; one of the subs may have a problem that is shutting down the amplifier.

Mar 11, 2007 | Sony XM-2002GTR Car Audio Amplifier

Not finding what you are looking for?
Sony Xplod 1200W Class AB Bridgeable 2-Ch. Amplifier w/Variable Low-Pass Crossover Logo

389 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Audio Players & Recorders Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

kakima

Level 3 Expert

102366 Answers

 Grubhead
Grubhead

Level 3 Expert

5151 Answers

Are you a Sony Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...