Question about Kenwood KAC-9152D Car Audio Amplifier

Open Question

Accidentally touched the remote wire to the ground while the head unit was playing and the head unit shut off, what kind of damage could be caused by this?

Posted by on

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 20 Answers

SOURCE: i have an kenwood 600watt amp and then amp keeps turning off and on when i turn the gain up

1) Pull your speaker wires, grab an ohm meter and confirm that each speaker reads 4-8 ohms nominal impedence.
2) Ohm out your speaker wires to chassis ground & confirm no 0 ohm (short)
3) Confirm 12 volts plus at amp power wire. Low voltage will send amp into protect mode.

If speakers are disconnected and amp turns on, look for a red led. If red then you have an internal problem that is protecting the amp.
If going into protect mode due to internal issue, then it's time for a new amp.
Also, you will need to use a "line out adaptor" in order to covert from speaker out to low level (RCA) input to amp. Too much voltage from head unit can fry the pre-amps in the amp.

And yes, I'm an electronics tech and yes, I know my stuff on car audio:)

Just a side note, never confirm a fuse as good by sight:)

Posted on Nov 15, 2013

Testimonial: "ok the 12'' speaker is reading 4.34 ohms and the amp is getting (when car is off) 12.37v and is still turning on and off but i found out is that it doesnt do that when the speakers are unpluged, the led light on the amp is red but when i put the speaker in the led red light is dying off its not turning another color just off (but its day light out and cant really see the led with the sun light) but with the speaker unpluged the amp is on and i can turn the gain all the way up and the amp stays on but when i plug in the speaker its on and off but with the gain at a really low level the amp stays on and also the amp is called for 2x 20a fuses and i have 2x 25a fuses just found that out today and i took one of them out to check them the amp stayed on with only one fuses??? i dont think they are suppose to do that???? thats all i fouund out so far"

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Connected a Dual XPA2100 300 watt amp to the battery and connected ground to chassis of vehicle. Vehicle is 2004 Saturn Ion with battery located in trunk area. Amp does not power on, all connections are...


The remote wire DOES need to be connected to the head unit. You can see if thats the problem simply by touching the remote wire to the power wire. The unit should come on. The head unit should either have a remote lead, or a power antenna lead, and thats what you need to turn the amp on and off. BE SURE your ground is solid, and its usually best to take that to the battery as well to prevent unwanted engine noise. Hope this helps!

Sep 25, 2011 | Dual XPA2100 2/1 Channel 300 Watt...

1 Answer

When i power it on it shuts off i got a kenwood kdc-mp825


Disconnect all of your speaker leads at the head unit, make sure none are touching, then power it back on. If it still cuts out, check your ground, if it doesn't, re-connect speakers one by one and test power again. It will either cut out when you get to a speaker or wire that's shorted, or work just fine. it's protecting itself from damage by cutting off when speakers are either bad or have shorted wiring. Most common shorted wiring happens on door speakers at the hinge. If it continues to cut off without speakers connected and you have a good ground, the unit needs service. If it still plays and you find the speaker or wire that's causing the problem, disconnect the wire at the speaker and test again, if it works, replace the speaker, if it doesn't, replace the wire. Hope this helps

Jul 07, 2011 | Kenwood Sirius KDC-MP825 CD Player

1 Answer

How can i set up the amp alpine model mrd-m1000


The basic steps to set up a car amplifier are these: 1. Disconnect the car battery's negative terminal before doing ANY electrical work on your vehicle. Failing to do so can damage your equipment or cause injury to your person. 2. Determine where you are going to mount your amplifier. This can be in the trunk, on the back of a seat, under a seat, etc. Pick a place with good airflow, otherwise your amp may overheat while playing. 3. Run the ground wire from the mount location to a ground location. The ground location should be a location where you can securely connect the cable to the vehicle chassis, and the connection should be metal-to-metal, without any paint in between. 4. Run the speaker cables to the amp. This means any cables coming directly from subwoofers as well as RCA cables coming from the head unit. Don't forget the remote wire from the head unit. 5. Run the positive (live) power wire directly from the vehicle battery to the amp. You will most likely have to drill through the vehicle firewall in order to get the cable through. 6. Connect the ground wire to the ground location. 7. Connect the speaker wires and remote wire to the amp. Make sure these cables are connected on each end to the proper inputs. 8. Connect the ground wire to the amp. 9. Insert the fuse into the in-line fuse on the live power cable, within 2 feet (24 inches) of the positive terminal connection.If your cable didn't come with an in-line fuse, you will have to buy a fuse separately, strip the power cable, cut it, and insert the fuse in the specified location. 10. Connect the power wire to the amp first, and then to the battery. 11. Power up your system, and play some music!

Mar 06, 2011 | Alpine MRD-M1000 Car Audio Amplifier

1 Answer

When i put on power protect light come on


If the amp is in protect mode, it probably has shorted output transistors. To eliminate other possible causes, do the following. Disconnect all speaker wires from the 'amplifier's speaker terminals' and disconnect RCA/signal cables from the amp. If it powers up normally, the speakers/wiring need to be checked. If it still shuts down (goes into protect mode), the amp almost certainly has shorted output transistors and will need to be repaired. If the amp only shuts down when it's driven to relatively high volume, you need to confirm that you have sufficient power supply voltage. With your multimeter set to DC volts, the black meter probe on the ground terminal of the amp (not on the point where the ground wire connected to the vehicle) and the head unit on (so the amp will have remote voltage applied), touch the red probe alternately to the B+ and remote terminals of the amp. If the voltage is below ~11 volts on either the B+ or remote line, you need to check the wiring feeding whichever line is too low. If 'both' the B+ and remote turn-on lines are low and your battery is fully charged, you may have a bad ground connection.

Dec 15, 2010 | JBL BP1200.1 Car Audio Amplifier

1 Answer

Amp doesnt turn


If the power wires have been reversed it can cause it to do that. if the positive wire touched any other metel on the amp than the positive it could have damaged the amp. If the amp is screwed down to any part of the body it wont hurt it.Check to make sure the remote wire has enough voltage to startup the amp .you can disconnect the remote wire take a jumper wire and jump the positive and remote inputs on the amp. If that resolves the problem than the voltage on the remote wire is to low to activate the amp.

Dec 05, 2008 | Car Audio & Video

1 Answer

Ultra linear ul-600hc


If the amp is in protect mode, it probably has shorted output transistors. To eliminate other possible problems, do the following. I'll assume that you've checked the amplifier's on-board fuses.

With your multimeter set to DC volts, the black meter lead on the ground terminal of the amp (not on the point where the ground wire connected to the vehicle) and the head unit on (so the amp will have remote voltage applied), touch the red lead alternately to the B+ and remote terminals of the amp. If the voltage is below ~11 volts, you need to check the wiring feeding whichever line is too low.

If the voltage remains near or above 12v, disconnect all speaker wires from the speaker terminals of the amp and disconnect signal cables from the amp. If it powers up, the wiring needs to be checked. If it still shuts down, the amp almost certainly has shorted output transistors and will need to be repaired.

Let me know if you have any other questions.

Aug 26, 2008 | Ultra Linear UL-600HC Car Audio Amplifier

1 Answer

Performance Teknique wont work!!


If the amp is in protect mode, it probably has shorted output transistors. To eliminate other possible problems, do the following. I'll assume that you've checked the amplifier's on-board fuses.

With your multimeter set to DC volts, the black meter lead on the ground terminal of the amp (not on the point where the ground wire connected to the vehicle) and the head unit on (so the amp will have remote voltage applied), touch the red lead alternately to the B+ and remote terminals of the amp. If the voltage is below ~11 volts, you need to check the wiring feeding whichever line is too low.

If the voltage remains near or above 12v, disconnect all speaker wires from the speaker terminals of the amp and disconnect signal cables from the amp. If it powers up, the wiring needs to be checked. If it still shuts down, the amp almost certainly has shorted output transistors and will need to be repaired.

If you want to try to repair it yourself, read through the following page:

Basic Amplifier Repair Primer

Let me know if you have any other questions.

Jul 02, 2008 | Performance Teknique ICBM-779 Car Audio...

1 Answer

Wont turn on...


With your multimeter set to DC volts, the black meter lead on the ground terminal of the amp (not on the point where the ground wire connected to the vehicle) and the head unit on (so the amp will have remote voltage applied), touch the red lead alternately to the B+ and remote terminals of the amp. If the voltage is below ~11 volts, you need to check the wiring feeding whichever line is too low.

Jun 11, 2008 | Alpine MRP-M850 Car Audio Amplifier

1 Answer

Nitro BMW 484 roofers stopped playing


With your multimeter set to DC volts, the black meter lead on the ground terminal of the amp (not on the point where the ground wire connected to the vehicle) and the head unit on (so the amp will have remote voltage applied), touch the red lead alternately to the B+ and remote terminals of the amp. If the voltage is below ~11 volts, you need to check the wiring feeding whichever line is too low.


If the voltage remains near or above 12v, disconnect all speaker wires from the speaker terminals of the amp and disconnect signal cables from the amp. If it powers up, the wiring needs to be checked. If it still shuts down, the amp likely has blown output transistors.

May 15, 2008 | Car Audio & Video

1 Answer

My car amp works produces distorded noise . As I plug in the rca cables i noticed that if just the tip of the connector touches i get a good sound but if i insert the whole connector it becomes distorded...


You have a grounding issue.

The RCA inputs of the amp are many times NOT tied to chassis ( the chassis of the car ) ground.

Same goes for the RCA outputs of your head unit.

The speaker outputs of your amp SHOULD NOT EVER be tied to chassis ground.

  • make sure that no speaker wire from the amplifier is touching or attached to ground.
  • Make sure that your amplifier ground (GND )( of the 3 power inputs.....GND, +12V, Rem) is securely mounted to a bare metal spot on the frame. Best practice is to have the amp GND, and the head unit GND at the exact same physical point.
  • Make sure that your RCA cable shield ( not the center tip, but the part around it ) is not touching the chassis.
  • Make sure that you have not nicked the wire while installing it and are accidentally getting a connection to the frame of the car.
  • Make sure that the head unit is grounded properly.
  • IF for some reason you have an equalizer between the head unit and the amplifier, make sure it has its own switching power supply INSIDE the EQ.
Bad grounds are a pain to troubleshoot......best of luck....Rob

Mar 17, 2008 | Audio Players & Recorders

Not finding what you are looking for?
Kenwood KAC-9152D Car Audio Amplifier Logo

Related Topics:

100 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4844 Answers

yadayada
yadayada

Level 3 Expert

75797 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8140 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...