Question about RTO Massey-Ferguson Tractor TE20, TO20, TO30, ITFE2

Open Question

Ferguson tractor water leaking into the sump

I have just replaced the rings, reconditioned and reground the head, fitted new valves, valve springs, a new head gasket etc on my TE20 Ferguson. When I filled the radiator with water, it went straight into the sump. I am assuming rusted sleeves. Could the block be irreversibly corroded where these are fitted? I haven't disassembled it yet. Are there any seals involved?

Posted by on

Ad

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
  • 10 Answers

SOURCE: I have a massey ferguson

put a circuit tester on top of coil and turn the key to see if power is constants when key turned. If it cuts out then the key is wired up wrong somewhere. If that works, then check that power getting to distributor by leaving HT lead from coil attached to coil but unplugging from distributor. If no power there then the HT lead is stuffed. If that works, points should be checked. max gap should just fit a credit card width. Then condenser should be checked along with the HT leads to plugs and finally the plugs.

Posted on Mar 01, 2011

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 2011 Kia Cerato "S" has been using a lot of oil. The cylinder head was re-conditioned and engine serviced. The now engine blows smoke every time on starting. What is the probable cause ?


depends on how the head was reconditioned
were new valve guides installed along with new valves
were the stem seals correctly fitted
was a compression test done to determine the wear condition of the engine
smoke on start up is oil in the combustion chamber from valve stem seals , worn rings , sump pressure from excessive blow by through the line to the air inlet
check for oil leaks ( filter etc ) but using a lot of oil indicates ring problem, excessive bearing clearance overloading the oil control ring
try using a heavier grade of oil 30w 50 or oil for worn motors

Dec 04, 2016 | Kia Cars & Trucks

1 Answer

My Atos Prime 1.1 GLS has oil on the 3th and 4th plug and is smoking when stretching gears


depends on how many km /miles done on that motor
and service history and treatment

oil on plugs and smoking under load means
leaking rocker cover
oil leaks somewhere else where oil gets hot

lots of oil usage from sump means
oil seal leaks or sump pan leak
worn rings or valves in number 3 and 4 cylinders
or
worn valve stems that can be replaced with the head on

if the latter
a compression test is required to tell if an engine rebuild is required or fit a used engine



0a31e5bc-e31f-4d6e-9bf1-96cbc822d2bc.jpg26276057-fffxrszzok1qni30eqtcokfe-1-2.jpg

Sep 06, 2016 | Hyundai Atos Cars & Trucks

1 Answer

What to do when there no psi on cyl 4 to get the psi up agan"?"


There are at least three possible reasons for no psi in cyl No 4.
1. Burnt or damaged exhaust valve in that cylinder
FIX Remove head and replace faulty valve
2. Blown head gasket (water mixed with sump oil shows milky on dipstick and steam or water coming out of exhaust tailpipe, radiator water disappears )
FIX Remove head, grind flat and assemble with new gasket.
3. Broken piston rings, or cracked piston or burnt hole in piston.
FIX replace faulty parts.
Squirt some sump oil ( 2 or 3 spoonfuls ) through spark plug hole,
spin motor , and if compression PSI improves then it is rings or piston, if no PSI then it is faulty ex valve !!!

Jun 26, 2014 | 2003 Mitsubishi Lancer

1 Answer

My Air Mate MK190 compressor does not pump up preasure.


Check the pitcock valve to make sure it is closed. This valve is used to drain moisture in the tank and could be damaged or open. Make sure the safety valve is not stuck open (it is spring loaded and has a ring attached to it). Last is to check the tube connections from the tank to the compressor housing (be carefully, the tubes and housing could be hot). Do you hear any air leaks? You can use some dish soap and water to drip some on the hose fittings and valves to help see the air leaks. Other than that, it sounds like the motor connection or piston.

Jul 01, 2010 | Dewalt d55151 factory reconditioned emglo...

1 Answer

I have zl 1000 had petrol going into sump afer haveing new camchain fitted,told it,s a carb problem,by same shop,what do you think


hi,this problem is normally caused by the float needles inside the carb bowls not sealing properly,which will allow the carb bowls to keep filling untill they overflow,once they have overflowed the petrol will make its way through the inlet manifold past the valves in the head and then down to the pistons,past the piston rings and into the sump,it is not difficult to replace the needle valve seats once you have the carbs off,all you do is take the carb bowls off (4 screws),pop out the pin that holds the floats in,the needle valve is connected to the floats normally by a little spring type clip,unscrew the needle valve seat(brass) and remove,screw in the new one..job done..replace the needle valve as well..hope this helps...cheers

Feb 02, 2010 | 1987 kawasaki ZL 1000 A1 Eliminator

2 Answers

Diesel getting in to sump on massey 3080 year 89


well its most likley to be the piston rings worn out there is a slght chance its a blown head gasket or duff injectors but im going to put my money on rings
long old job fixing this,, but at least you can get a set of piston and liners for it,,,

Oct 25, 2009 | Spec Cast 1: 16 Massey Ferguson 98 Tractor...

1 Answer

I have a B&S model 40777 mower with low


Yes you need to take the sump off but make sure the valves aren't leaking first of the head gasket may also be leaking and causing the same problem.

Aug 02, 2009 | Husqvarna Garden

Not finding what you are looking for?
RTO Massey-Ferguson Tractor TE20, TO20, TO30, ITFE2 Logo

Related Topics:

92 people viewed this question

Ask a Question

Usually answered in minutes!

Top RTO Toys Experts

Timllfixit

Level 3 Expert

2210 Answers

The Scrivener

Level 2 Expert

154 Answers

Pete Bruk

Level 2 Expert

89 Answers

Are you a RTO Toy Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...