Question about Technics SUV500 2-Channel Amplifier

1 Answer

I am playing my stereo with the su-g95 amplifier what can i do to play all 4 speakers at the same time.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 17 Answers

First dose your amp have 2 or 4 outputs if 4 outputs you have to have 4 speakers ,and connect them on your amp speaker output is that so hard to do ....

Posted on Dec 21, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I got Sony Xplod XM-ZR704 700W 4/3/2-Channel Car Stereo Amplifier and 12" sub. it play good for continuous 2 hours but after that starts tripping and goes on off. i checked all wires and connections.


Amp is probably over heating. Make sure the ohm load of speaker is good for that amp. This amp is not really built to handle a bridged 2 ohm load. Make sure ground wire is clean and tight to the body chassis.

May 18, 2012 | Sony Xplod XM-ZR704 700W 4/3/2-Channel Car...

1 Answer

My su-g95 technics Stereo integrated amplifier wont play any noise. and when i adjust the volume it makes a popping/crackling noise. i am 100% sure all the speakers were hooked up correctly.


Well it sounds like your amplifier IC's are working correctly since you are hearing that pop. I have the same amplifier and every 10db increment it pops. Have you tried every input? Possibly try starting at a low volume, plug an RCA plug into CD or any other input, and touch the center prong of the other end of the cable. You should get a 60hz hum if your in the USA, otherwise it will be 50-55hz. Regardless it should make noise.

Sep 29, 2011 | Technics SUV500 2-Channel Amplifier

1 Answer

Technics SU-G95 Amplifier and no sound on left speakers


Usually this is a defect in the output amp IC. If you have no experience with repairs of these types of units, have it checked by a service shop. If the output AMP IChas failed, it will cost about $75 for a replacement. This unit uses an RSN3306P IC .

Dan

Mar 14, 2010 | Technics Audio Players & Recorders

2 Answers

Su-v55a technics amp cuts off when volume up to 2


usually meens it is protecting itself from destruction
check your wires and speakers for problems

Feb 09, 2010 | Technics SUV500 2-Channel Amplifier

1 Answer

Hello! I have a problem with Technics SU-V2X


Well whatever is playing up sounds like it might be getting too hot to me. In any case it's something common to both channels. Just have a look on the heatsink to see if it uses a single IC for both channels, they are can cause lots of problems!
The IC might be marked STK with numbers after the letters. That is the part number too for ordering a new one.

Jan 08, 2010 | Audio Players & Recorders

3 Answers

Tecnics SU-G95 stereo overloaded


Power down,disconnect the speakers and power back up. If it still say's overload, it needs to go to service. If not, check your wires, connections, and speakers one by one to hunt down the problem and correct. Hope this helps

May 25, 2009 | Technics SUV500 2-Channel Amplifier

1 Answer

5. chanel and stereo sp.B at the same time


The yam 361 can not play A and B speakers at the same time you need to buy a switch box so you can select one pair or two pairs of speakers.

Hope this helps.

CABLE GUY.

Nov 16, 2008 | Yamaha DSP-A1000 5-Channel Amplifier

3 Answers

Technics SU-G91 OVERLOAD PROBLEM


THe amp has detected a problem and shutdown to prevent further damage. This unit has 2 amp pacs inside and one or both have failed. If you can solder, you can fix this yourself. The main amp pac is an SVI3206 and can be purchased online for about $60.

Keep me posted.
Dan

Oct 17, 2008 | Audio Players & Recorders

Not finding what you are looking for?
Technics SUV500 2-Channel Amplifier Logo

Related Topics:

269 people viewed this question

Ask a Question

Usually answered in minutes!

Top Technics Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5047 Answers

T-Comtech Repairs
T-Comtech Repairs

Level 2 Expert

417 Answers

Electro Med Services...
Electro Med Services...

Level 3 Expert

6694 Answers

Are you a Technics Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...