Question about Rode NT1A Professional Microphone

1 Answer

NT1-A just stopped working, Any ideas?

My NT1-A worked very well for a year, and now it just doesn't get any signal at all? nothing. Any ideas what could be causing this? One day it just stopped working. Any help is appreciated

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Contributor
  • 40 Answers

It could be caused by a range of things. but before blaming the mic, try a few things first.

To test it is actually the mic that is broken, and not any of your other gear, try using your current set up with another condenser mic. If this works, your mic is broken.

If you dont have another condeser mic available to you, try, one by one, replacing the cable, and changing the input channel on your mixer/interface.

When you try a different channel, choose an input that is on a different Phantom selector than your current one (most mixers/interfaces of 8+ channels will let you apply phantom to a group of channels, instead of all). If your mic works then, it could be an issue with your mixer's phantom power.

If all the above fails, then you should still be covered by Rode's 10 year warranty, provided it is not caused by missuse/misshandling (http://www.rodemic.com/warranty.php).

Posted on Mar 25, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

All signals stopped working


Sounds to me like the switch itself needs replaced. You could try pulling it apart and checking for corrosion and cleaning the contacts up but the switches are pretty cheap.

Apr 07, 2014 | 1990 Suzuki GSX 750 F (Katana)

1 Answer

1996 thunderbird signal lights and hazard lights not working, works sometimes however doesn't work at all when the headlights are on.


Interior lights check for a blowin fuse, For the signal lights end hazzard lights,Get a new signel light flasher, End try it,, If that dooesn,t work there could be loose wires or a brek in the wires or that there is a short some where in the wireing, That will have to be check out at a auto electric shop,

Nov 27, 2012 | 1996 Ford Thunderbird LX

1 Answer

Last year my fuel gauge and turn signal fuse blew. This year it happened again, however, when I replaced the fuse, it blew as soon as I turned on the car. Any ideas on where to find a short or cause?


I would start by getting a wiring diagram and find what these two seemingly separate systems have in common, or where they overlap. That might narrow down the possibilities. If they have nothing in common, then I would suspect the fuse box itself.

Sep 21, 2012 | 1994 Cadillac DeVille

1 Answer

I've tried all the ideas for a locked digital camera lens and nothing is working. We were on a pretty dusty road the day it locked up, so I'm assuming... Any other ideas?


You could try using some compressed air to see if any dust comes out. If that doesn't work I'd talk to the manufacturer of the camera.

May 10, 2011 | Cameras

1 Answer

Last year I got this device and after 1 & half year my device is not working & showing check gps antenna. Can u please give me a solution Javaid


Probably the gps antenna is not working due to rusty (water inside it). Check the antenna disassembling it. Third part antenna for the NT1 is not available due to proprietary connector so you must buy a (expensive) genuine new one from JVC. Sometimes it's possible repair the old one.

Apr 21, 2011 | JVC KW-NT1 Car GPS Receiver

1 Answer

When using my new rode NT1A microphone with pro tools i can record perfectly ok and there is a strong signal going in but the recording sounds muffled and 'cheap' on playback. Do you have any idea as to...


Assuming your preamp, cables, or room, aren't at fault, then your NT1-A is suffering from typical component failure and will need service. Even new mics of this type can be at the end of their useful lives, due to the cheap components used.

Feb 08, 2011 | Rode NT1A Professional Microphone

1 Answer

I'm using a piece of software called Audacity. When I record using my Rhode NT1-A condenser microphone, the sound isn't as clear as I'd like it to be and I'm sure it can be clearer. NO IDEA WHAT TO DO:(


Switch to Reaper, and see if the problem persists. Audacity is very rudimentary. Other potential problems include the preamp, and the NT1-A not functioning properly.

Aug 17, 2010 | Rode NT1A Professional Microphone

1 Answer

My nt2 started to cut out and fade out so I pluged an nt1 on the same cord and it works fine


Send it back to Rode and if its not caused by Misuse, should be covered under their 10 year warranty.

Mar 21, 2010 | Rode NTK Professional Microphone

Not finding what you are looking for?
Rode NT1A Professional Microphone Logo

309 people viewed this question

Ask a Question

Usually answered in minutes!

Top Rode Audio Players & Recorders Experts

Jay Plesset

Level 3 Expert

2825 Answers

Tom Chichester

Level 3 Expert

33359 Answers

JonSnell Electronic
JonSnell Electronic

Level 3 Expert

20252 Answers

Are you a Rode Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...