Question about Jamo MPA201 2-Channel Amplifier

1 Answer

I have a MPA 201 2 channel amplifier that just stopped putting out power, power light is still on, any suggestions?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Jamo Master
  • 5,017 Answers

You need to determine if the power is getting to the audio amp section. For instance with the volume full up is it humming etc?
As a 'rule' it's unlikely that both left and right channels will fail at the same time (unless you have done something silly with the amp) you are looking for something that is common to both channels. Which is why the power section is first suspect. The exception to the rule (above) is where amps use say an IC power amp for both channels. You will find this IC on the big heat sink. Check whatever is on that anyway for damage or burning.
The only other area could be the pre-amp part. Again this could be a single IC controling both channels, so it's failure could cause a loss of sound. By the way if you can hear music/sound coming through when you put it up to full volume the pre-amp will be generaly good.

Posted on Nov 24, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Is it possible to bridge 4 of the channels into 2 Monster MPA 5150 150 watts x 5 power amp


It would not be recommended, as the intent of the amplifier is to drive 5 individual speakers in a home theater setup. Bridging channels on the amp could cause damage and would definitely void your warranty. I would recommend simply not using two of the channels if you are looking to drive 3 speakers instead of 5.

Oct 26, 2015 | Car Audio & Video

2 Answers

Monster mpa 5150 ss amp


the unit is not able to tune above that channel .

means its a failure of components in the control board.

Jun 29, 2008 | Monster Cable MPA 5150 SS Amplifier

1 Answer

I'm replacing a JAMO amp.


The 201 is 100w in to 4ohms and the 101 is 50w into 4 ohms other then that there the same

Mar 24, 2010 | Jamo MPA201 2-Channel Amplifier

1 Answer

Jamo MPA-101 2 channel amp quit working


Check the small electrolytics on the power supply board for high ESR, Very common problem on these amps. Protect circuit stays latched due to high ripple from PS.

Mar 24, 2009 | Jamo MPA201 2-Channel Amplifier

3 Answers

Two Jamo MPA-101 amps not working


I can almost guarantee that you'll find bad electrolytic caps on the power supply board to be the cause of the problem. I've seen several of these with the same problem. The protect circuit stays latched due to excessive ripple.

Dec 16, 2008 | Jamo MPA201 2-Channel Amplifier

1 Answer

Monster MPA 5150SS


Might be a failing semiconductor component (usually an old transistor) in the amplifier's front end. This caused by the oxidation through the component legs or pin. I usually touch and move each transistor's body to exaggerate the noise. You can research also what kind of noise is it producing- intermittent, static, etc.
hope this helps..

Sep 20, 2008 | Monster Cable MPA 5150 SS Amplifier

1 Answer

Monster mpa 5150 ss amp


As It was mentioned on the premium post, if after removing the fuse(s) from it, the amp powers up and stays ON; the failure is on the transistors or mosfets and they will need to be replace to get the amp working again on channel 4.
I would suggest to contact the manufacturers to get an authorized repair center to fix it under warranty if your amp is less then a year old.
Good Luck.

Jun 30, 2008 | Monster Cable MPA 5150 SS Amplifier

1 Answer

4th channel turns on and then it turns off; 5th channel does not turn on


Hi Alex323a

Nice amps. There is really only one check you can do without getting into the internals of the amp to help you resolve the issue. Disconnect the input and speakers from that channel,and see if it is able to turn on. If are up to it, checking over the poweramp board for that channel for dry or cracked solder joints, and in turn resoldering any you find may fix the problem. If not, the amp will have a problem on that channel and will need a tech to look at it. If it is under warranty still, Monster are pretty good for service I have heard, and they would be your first port of call. Other than that, Call you local HiFi specialist store and see if they can recommend a good audio tech in your area.

regards
robotek

Jun 28, 2008 | Monster Cable MPA 5150 SS Amplifier

Not finding what you are looking for?
Jamo MPA201 2-Channel Amplifier Logo

Related Topics:

468 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jamo Audio Players & Recorders Experts

Electro Med Services...
Electro Med Services...

Level 3 Expert

6694 Answers

Tom Chichester

Level 3 Expert

33342 Answers

Steve

Level 3 Expert

3287 Answers

Are you a Jamo Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...